LinuxQuestions.org

LinuxQuestions.org (http://www.linuxquestions.org/questions/index.php)
-   Linux - Hardware (http://www.linuxquestions.org/questions/forumdisplay.php?f=18)
-   -   gamepad on raspberry pi (http://www.linuxquestions.org/questions/showthread.php?t=4175438207)

vendtagain 11-21-2012 07:46 PM

gamepad on raspberry pi
 
I am trying to get a gamepad working on raspberry pi (model B rev 2 512 mb ram).
I am trying to find some software that will recognize it, I have not been able to find any software that will recognize to calibrate or map it to keys/mouse events.

But, I have found that the command 'lsusb' recognizes the device as a gamepad. It is a Logitech F310 Gamepad in X input mode.

I am running the Raspbian OS version from raspberrypi.org (2012-10-28). I have installed jscal, joy2key, and joystick - all via apt-get.

Neither jscal nor joy2key recognize a joystick/gamepad being available. There is no js0 in the /dev directory, and it is not in /dev/input. (at one point I thought I saw a /dev/input/js0, but it is no longer there, I think it may have been right after I installed the 'joystick' driver, but disappeared after I rebooted).

I have tried using 'modprobe joydev', which sadly did not work either.

The games I want to use the gamepad with are doom and quake3, I am not sure if either support gamepads or if I will have to map it to keyboard/mouse controls, either way I have not making any progress besides seeing the device listed with lsusb's output.

Anyone know how to get this gamepad working?

vendtagain 11-21-2012 09:09 PM

Well just found out it's rated 5V and 500mA. I think this is the problem, will get a powered usb hub to try.

vendtagain 11-29-2012 12:06 AM

Just got a powered usb hub.
js0 now appears in /dev/input.
I have tried with controller in X and D input mode.

The controller is still not recognized by jscal.


All times are GMT -5. The time now is 10:31 AM.