-   Linux - Hardware (
-   -   Funny USB behavior (

darcybaston 02-21-2004 10:40 PM

Funny USB behavior
Hardware : compaq presario 915us laptop, Logitech standard wheel optical mouse
Software: Mandrake 9.2 with 2.6.0 kernel, KDE 3.1.x, XFree86-4

When I log in and the desktop appears, my optical mouse is off, dead. When I run mousedrake, and just click on ok (my previous and correct selection is remembered between reboots), the mouse comes to life and works fine.

Until I reboot.

I reboot, log in and the mouse is dead, run mousedrake, and blip it turns on and comes to life. Reboot, rinse and repeat.

Why do I always have to keep going to mousedrake to get USB turned on and the mouse activated? Is there not automatic way to do this? I've tried having the bios set to 'legacy usb support' so that the usb is always on and the mouse is always lit, but even then the mouse will not control the pointer until I run mousedrake and just click on 'ok'. But in that case, the scroll wheel won't work. The scroll wheel only works when bios legacy usb support is disabled.

I wrote a previous post titled "Mandrake 9.2 won't remember usb mouse settings?" but I can't seem to find it. It hasn't shown up in the forum topic list, so I'm trying again. Thanks for the patience! :)

Electro 02-21-2004 10:59 PM

You have to add an entry in your XF86Config and XF86Config-4 file to include a second mouse. You may want to add /sbin/modprobe usbmouse in rc.local so that the mouse module (driver) is activated.

IMO, I think using a USB keyboard or a mouse is waste. I still use the PS/2 connector on my systems. USB should be used for cameras, hard drives, pen drives and scanners when you need the bandwidth.

darcybaston 02-22-2004 08:21 AM

Thanks Electro, I'll give that a try. I understand your view on USB for mouse use.

darcybaston 02-22-2004 08:39 AM

Ok. The XF86Config-4 file has an entry in there for the mouse and it's using protocol imps/2 and device /dve/usbmouse. There's also lines in the layout section for having it as a CorePointer.
This information was generated by mousedrake itself for I've customized that file before only to have it change after running mousedrake.

I'm thinking mousedrake couldn't activate the mouse unless the driver was already in there to use, since after you run it, the mouse works. The problem is just having to run it every time the computer is booted. I added the line you suggested to rc.local and there was no change.

dmesg shows that things should be alright :

ohci_hcd: 2003 Oct 13 USB 1.1 'Open' Host Controller (OHCI) Driver (PCI)
ohci_hcd: block sizes: ed 64 td 64
ohci_hcd 0000:00:02.0: OHCI Host Controller
ohci_hcd 0000:00:02.0: irq 11, pci mem e0871000
ohci_hcd 0000:00:02.0: new USB bus registered, assigned bus number 1
hub 1-0:1.0: USB hub found
hub 1-0:1.0: 2 ports detected
ohci_hcd 0000:00:0f.0: OHCI Host Controller
ohci_hcd 0000:00:0f.0: irq 11, pci mem e0873000
ohci_hcd 0000:00:0f.0: new USB bus registered, assigned bus number 2
hub 2-0:1.0: USB hub found
hub 2-0:1.0: 4 ports detected
drivers/usb/core/usb.c: registered new driver hiddev
drivers/usb/core/usb.c: registered new driver hid
drivers/usb/input/hid-core.c: v2.0:USB HID core driver
hub 1-0:1.0: new USB device on port 2, assigned address 2
input: Logitech USB-PS/2 Optical Mouse on usb-0000:00:02.0-2

Anyone have other ideas? This used to "just work". I've done a fresh install of Mandrake 9.2 3 times and it's on the third time that something was different that I can't claim to know, and this behavior is one symptom.

All times are GMT -5. The time now is 11:28 AM.