LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 06-20-2002, 08:59 AM   #1
cruane
LQ Newbie
 
Registered: Feb 2002
Posts: 9

Rep: Reputation: 0
Funny mouse behaviour


I've noticed that my mouse behaves funny just after booting.

This is what happens:

Immediately after booting and logging in to windomaker drags are not recognised as drags, instead they're recognised as the first click of a double click. A second attempt to drag the same window results in the window rolling up (which is the correct double click behaviour).

If I log into Gnome immediately after booting, drags work ok but normal clicks are not recognised properly. Some clicks seem to 'get lost'.

The funniest thing about all this is that it stops about 3 minutes after the initial boot and after that everything is fine.

I'm pretty sure it's not X related because if I boot to run level 3, wait 3 minutes and then do an init 5 (X) everything is fine. however booting to runlevel 1 and then going to run level 5 after 3 minutes does show the funny behaviour, which indicates it's not a hardware thing.

So it must be something loaded in runlevel 3 that causes the problems. I'm going to try to rule out various components in a one at a time manner. But maybe someone here can say: 'Aha! I know what that is'.

I'm running SuSE 7.3 with kernel 2.4.16, PS/2 mouse, nothing unusual.

Thanks for any suggestions

Con
 
Old 06-20-2002, 09:46 AM   #2
peter_robb
Senior Member
 
Registered: Feb 2002
Location: Szczecin, Poland
Distribution: Gentoo, Debian
Posts: 2,458

Rep: Reputation: 48
Try removing gpm from bootup if it is started.

chkconfig --level 345 gpm off
service gpm stop

Regards,
Peter
 
Old 06-21-2002, 03:55 AM   #3
cruane
LQ Newbie
 
Registered: Feb 2002
Posts: 9

Original Poster
Rep: Reputation: 0
>Try removing gpm from bootup if it is started.

I was pretty sure that the gpm wasn't the problem but I checked anyway.
gpm was only loaded in runlevels 2 and 3 so I removed that too (No gpm anywhere). but the problem remains.

I also tried not loading the sound and hot plugging subsystems (USB) and removed my sound card but that didn't help either.

Any other ideas.
 
Old 06-21-2002, 05:21 AM   #4
peter_robb
Senior Member
 
Registered: Feb 2002
Location: Szczecin, Poland
Distribution: Gentoo, Debian
Posts: 2,458

Rep: Reputation: 48
Ok,
here's a long shot... (I use RH 7.2)
Get kudzu to re-detect the mouse.
This will mean removing the mouse config from "/etc/sysconfig/hwconf", and removing the "/dev/mouse" link, shutting down X & xdm, "init 3".
Run kudzu again and afterwards run mouseconfig.

Otherwise I suspect you will need to try a serial mouse or another PS/2 mouse, just to clear up that question.
Regards,
Peter.
 
Old 06-21-2002, 07:10 AM   #5
Aussie
Senior Member
 
Registered: Sep 2001
Location: Brisvegas, Antipodes
Distribution: Slackware
Posts: 4,590

Rep: Reputation: 56
You can also try changing the device in your X config to /dev/psaux instead of /dev/mouse (which is normally a sym link to psaux anyway).
 
Old 09-25-2002, 04:21 AM   #6
cruane
LQ Newbie
 
Registered: Feb 2002
Posts: 9

Original Poster
Rep: Reputation: 0
I had actually stopped looking for a solution to this problem but then I discovered the cause by chance.

I used to use ISDN to access my ISP but recently I got DSL and I noticed that the problem disappeared.

Then I remembered that I used to use the ISDN feature to synchronize the system time. So I did a connect and disconnect via ISDN to set the system time and there was my mouse problem again!

My hardware clock was running a couple of minutes fast, and setting the system time to a couple of minutes ago obviously confuses the mouse click timing until the system time catches up with some stored time stamp.

I've known that setting back the time causes problems with version control systems but I'd actually call it a bug that setting the time affects mouse behaviour.

Now I just have to find out why the system doesn't set the hardware clock to the system time on shutdown. I get a message saying that it's setting the hardware clock (without error messages) but it doesn't seem to happen.

Thanks for all the suggestions.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Funny uptime behaviour paul.nel Linux - General 7 05-19-2005 02:49 PM
Really wierd mouse behaviour esteeven Linux - Hardware 1 12-06-2004 05:11 PM
strange mouse behaviour with logitech pilot mouse in debian 3.0r2 g-string 3 Debian 0 11-12-2004 07:27 AM
Mouse acting funny after upgrade to 2.6.8.1 Cosmos95 Slackware 8 08-28-2004 08:36 AM
Strange mouse behaviour J_Szucs Linux - Newbie 15 03-31-2003 03:30 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 05:53 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration