LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 07-02-2004, 09:54 AM   #1
l32
LQ Newbie
 
Registered: Jun 2004
Distribution: Mandrake 10
Posts: 23

Rep: Reputation: 15
Angry fstab!! Stop changing!!


Hi,

Does anyone know how does one stop Linux from changing the fstab? I have set the it to mount sda1

However everytime I reboot 'something' will add two more stuff: removable2 and HD.

Here's my fstab:

/dev/hda1 / ext3 defaults 1 1
none /dev/pts devpts mode=0620 0 0
/dev/hda6 /home ext3 defaults 1 2
/dev/hdc /mnt/cdrom auto umask=0,user,iocharset=iso8859-15,codepage=850,noauto,ro,exec 0 0
/dev/hdd /mnt/cdrom2 auto umask=0,user,iocharset=iso8859-15,codepage=850,noauto,ro,exec 0 0
none /mnt/floppy supermount dev=/dev/fd0,fs=ext2:vfat,--,umask=0,iocharset=iso8859-15,sync,codepage=850 0 0
/dev/hdb1 /mnt/win_c2 vfat umask=0,iocharset=iso8859-15,codepage=850 0 0
none /proc proc defaults 0 0
/dev/hda5 swap swap defaults 0 0

/dev/sda1 /mnt/removable vfat user,noauto,umask=0 0 0


none /mnt/hd supermount
dev=/dev/ide/host0/bus0/target1/lun0/part1,fs=ext2:vfat,--,umask=0,iocharset=iso8859-15,kudzu,codepage=850 0 0
none /mnt/removable2 supermount dev=/dev/scsi/host1/bus0/target0/lun0/part1,fs=ext2:vfat,--,umask=0,iocharset=iso8859-15,kudzu,codepage=850 0 0


I don't want those two: HD and removable2 to be listed in the fstab.
 
Old 07-02-2004, 10:30 AM   #2
Crito
Senior Member
 
Registered: Nov 2003
Location: Knoxville, TN
Distribution: Kubuntu 9.04
Posts: 1,168

Rep: Reputation: 53
It's kudzu that's doing it. Usually when you manually create an entry for the device it won't add a second, so not exactly sure what the other two are. Which one is the /dev/sda1 link pointing to?

Last edited by Crito; 07-02-2004 at 10:32 AM.
 
Old 07-02-2004, 05:38 PM   #3
l32
LQ Newbie
 
Registered: Jun 2004
Distribution: Mandrake 10
Posts: 23

Original Poster
Rep: Reputation: 15
sda1 is pointing to removable, a USB flash card reader.

While, hd, is not pointing to anything, I have no idea what is that. It was aoutomatically created when I install mandrake,
 
Old 07-02-2004, 07:23 PM   #4
Electro
LQ Guru
 
Registered: Jan 2002
Posts: 6,042

Rep: Reputation: Disabled
I do not know if you can disable kudzu in Mandrake. I'll search the internet. Yep, its a pain to edit fstab if you do not want a particular device automatically mounted at boot. I think just disabling supermount might work.
 
Old 07-03-2004, 04:12 AM   #5
l32
LQ Newbie
 
Registered: Jun 2004
Distribution: Mandrake 10
Posts: 23

Original Poster
Rep: Reputation: 15
how do you disable supermount? Since the device is added immediately when system reboots.
 
Old 07-03-2004, 04:59 AM   #6
l32
LQ Newbie
 
Registered: Jun 2004
Distribution: Mandrake 10
Posts: 23

Original Poster
Rep: Reputation: 15
In addition how do I disable kudzu?
 
Old 07-03-2004, 05:41 AM   #7
l32
LQ Newbie
 
Registered: Jun 2004
Distribution: Mandrake 10
Posts: 23

Original Poster
Rep: Reputation: 15
Hmm....after I check it out I think I don't have kudzu in my system, because I ran Drakxservices and see no kudzu entry in there....

Anyone know what's causing my fstab to change itself?
 
Old 07-03-2004, 03:05 PM   #8
apimente.br
Member
 
Registered: Aug 2003
Location: Sao Paulo - Brazil
Distribution: Mageia
Posts: 154

Rep: Reputation: 23
In Mandrake you disable both in the Mandrake Control Center (KDE -> System -> Configuration -> Configure your computer.
 
Old 07-03-2004, 08:08 PM   #9
l32
LQ Newbie
 
Registered: Jun 2004
Distribution: Mandrake 10
Posts: 23

Original Poster
Rep: Reputation: 15
I see no supermount nor kudzu when I accessed the System page in Mandrake control panel. Anyone know how to stop Linux from touching my fstab?
 
Old 07-04-2004, 12:14 AM   #10
Electro
LQ Guru
 
Registered: Jan 2002
Posts: 6,042

Rep: Reputation: Disabled
If you look in the man pages, logging in as su or root and typing "supermount disable" will disable supermount. For kudzu, I can not find it and its not on my CDs. It could be a problem with devfsd. You can try disabling devfs but you may have problems getting device nodes in /dev. If you do not want to disable devfs, you can comment lines in "/etc/devfs/conf.d/dynamic.conf" that has ".*/part.*". I do not know if it will work but it does not hurt to try it.
 
Old 07-06-2004, 07:59 PM   #11
l32
LQ Newbie
 
Registered: Jun 2004
Distribution: Mandrake 10
Posts: 23

Original Poster
Rep: Reputation: 15
ok, I managed to solve this problem now. I comment out the parts in dynamic.conf like Electro said, as well as disabling harddrake and hotlug. Mounting process should be manual now.
 
Old 07-15-2004, 05:44 AM   #12
jbmukund
LQ Newbie
 
Registered: Jul 2004
Location: hyderabad
Distribution: redhat
Posts: 5

Rep: Reputation: 0
I would like enable the supermount for my system how do i do that.
i have my own driver . what modifications should in the driver as well as /etc/fstab to allow my devce be mounted when i first access it .

this is a crucial problem for what i am facing .

thanks linux world for such a help full community,

mukund jampala.
 
Old 07-15-2004, 03:51 PM   #13
Electro
LQ Guru
 
Registered: Jan 2002
Posts: 6,042

Rep: Reputation: Disabled
jbmukund, have a look at l32 first post. It would be something:

none /mnt/cdrom supermount dev=/dev/hdc,fs=auto,--,umask=0,iocharset=iso8859-15,kudzu,codepage=850 0 0

The /dev/hdc is an example but it may not be your cdrom or the device that you want supermount to automatically mount.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
What process is changing /etc/fstab and deleting my swap mount? ffrr Linux - Software 8 03-18-2005 09:16 PM
Changing location of /etc/fstab? Aeiri Linux - Software 1 11-23-2004 04:36 PM
problem booting after changing /etc/fstab buehler Linux - General 2 01-12-2004 05:59 PM
Stop xwmconfig from changing background color in .xinitrc??? Shay Slackware 1 12-04-2003 12:36 PM
Cannot boot system after changing fstab buddhahat Linux - Newbie 2 11-06-2003 06:52 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 08:40 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration