-   Linux - Hardware (
-   -   fstab and loop devices (

MBH 10-21-2004 08:29 AM

[solved] fstab and loop devices

I'm trying to mount a USB memory stick (SanDisk 1.0 GB), mounting works fine, but when trying to unmount I get this :: umount: /mnt/stick: device is busy

I tryed to force unmounting it, but that didn't work either. So I had to reboot each time I wanted to unmount the stick.

I thought of a workaround (which worked) by using a loop device ::
mount -o loop /dev/uba1 /mnt/stick

And unmounting works like charm.

Now I want add that to the fstab, how?! I dont wanna do manual mounting/unmounting .. I'd rather let KDE handle it.

Could someone help?

Thanks in advance

Slackware 10.0 @ kernel 3.6.9


sjalex 10-21-2004 08:42 AM

you should be able to use an entry like
/dev/uba1 /mnt/stick <fstype (vfat?)> loop,noauto 0 0

basically you should be able to translate your command-line mount into an fstab entry pretty easily. The loop should go in the 4th field, which is the option field, so basically anything you'd pass with -o you can put in that field. The noauto tells the kernel not to mount at boot time.

NB you may need to tweak this some as I am doing this from memory. The mount(8) man page should pretty much give you all sorts of information about this, but I recommend trial and error as you are unlikely to break anything by mounting a memory stick incorrectly.

kilgoretrout 10-21-2004 08:46 AM

I'm not sure about mounting loop devices through fstab. But I think your problem is a kde bug. Go into kde control center>System>Performance and cahnge the preloaded instances from 1 to 0. That will fix your unmounting problems. From what I've seen, when you have an instace of konqueror preloaded, kde keeps polling the removable device to update konqueror resulting in a device busy message when you try to unmount. I had the same problem with my usb hard drive and the above workaround fixed the problem.

MBH 10-21-2004 08:58 AM

@ sjalex :: Thanks, that worked! although I tested it before and it didn't! weird!

@ kilgoretrout :: Yea, I've noticed that I have to close konqueror if I was browsing through the device I want to unmount for it to unmount !

Oh, and I couldn't find the option you mentioned!

Under system Admin there's no Performance tab, only LILO and the rest of the gang

One problem though, when passing vfat to the fastab, it uses umsdos instead !
fstab :: /dev/uba1 /mnt/stick vfat loop,noauto 0 0
mount :: /dev/uba1 on /mnt/stick type msdos (rw)

Which shrinks the file names to 6 chars! if I mount it manually, it uses the vfat fs and everything works fine :/

Any ideas ?!

Edit ::

Never mind, I found under konqueror's settings. Worked like charm!
The loop device caused some troubles though, its status didn't update properly, so when I delete files I had to remount the stick!

Thank you both for your help

All times are GMT -5. The time now is 03:54 PM.