-   Linux - Hardware (
-   -   fsck error and no keyboard input to skip (

techrolla 04-05-2005 12:29 AM

fsck error and no keyboard input to skip
Hello, I am running debian on a Blue and White G3 (ppc arch) and I am having a problem booting due to fsck. I mistakingly left an entry in /etc/fstab that was not valid and fsck won't have any of it. That's not that big of a deal, I could just edit fstab at the prompt it provides on boot. However, the problem is that my keyboard won't work! I want to say that my usb modules were not loaded yet, as that is the only way I could have keyboard access. Does anyone know a way I could either disable fsck, tell the kernel not to do anything with the drive (/dev/hdb, I tried adding hdb=noprobe and it worked for the kernel, but not fsck), or get my usb modules to load so I can use the keyboard for this prompt? I also tried adding init=/bin/sh but I could not input from the keyboard. Kernel version is 2.6.10. usb keyboard works normally other than this. Thank you!

Thoreau 04-05-2005 02:37 AM

boot floppy or boot cd. 2 choices.

techrolla 04-05-2005 07:28 AM

Thanks, I actually did get around the problem by booting the other 2.2.20 kernel I had on there which seems to load the usb modules before fsck does its thing. I guess the problem would have been what I would have done had I not had 2.2.20, since I don't have a floppy and the CD room booting is VERY shaky on this thing...Thanks though.

All times are GMT -5. The time now is 03:39 AM.