LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 11-27-2007, 08:55 AM   #1
LordHendrix
LQ Newbie
 
Registered: May 2006
Posts: 16

Rep: Reputation: 0
FreeBSD audio driver (help)


Please help me install my FreeBSD Audio Driver.

$ uname -a
FreeBSD 6.2-RELEASE FreeBSD 6.2-RELEASE #0: Fri Jan 12 11:05:30 UTC 2007 root@dessler.cse.buffalo.edu:/usr/obj/usr/src/sys/SMP i386
$ dmesg
Copyright (c) 1992-2007 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
The Regents of the University of California. All rights reserved.
FreeBSD is a registered trademark of The FreeBSD Foundation.
FreeBSD 6.2-RELEASE #0: Fri Jan 12 11:05:30 UTC 2007
root@dessler.cse.buffalo.edu:/usr/obj/usr/src/sys/SMP
ACPI APIC Table: <052907 APIC2033>
Timecounter "i8254" frequency 1193182 Hz quality 0
CPU: Intel(R) Core(TM)2 Duo CPU E4500 @ 2.20GHz (2199.98-MHz 686-class CPU)
Origin = "GenuineIntel" Id = 0x6fd Stepping = 13
Features=0xbfebfbff<FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CLFLUSH, DTS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE>
Features2=0xe39d<SSE3,RSVD2,MON,DS_CPL,EST,TM2,<b9>,CX16,<b14>,<b15>>
AMD Features=0x20100000<NX,LM>
AMD Features2=0x1<LAHF>
Cores per package: 2
real memory = 1073348608 (1023 MB)
avail memory = 1041166336 (992 MB)
FreeBSD/SMP: Multiprocessor System Detected: 2 CPUs
cpu0 (BSP): APIC ID: 0
cpu1 (AP): APIC ID: 1
ioapic0 <Version 1.4> irqs 0-23 on motherboard
kbd1 at kbdmux0
ath_hal: 0.9.17.2 (AR5210, AR5211, AR5212, RF5111, RF5112, RF2413, RF5413)
acpi0: <\M^?\M^?\M^?\M^?\M^?\M^? \M^?\M^?\M^?\M^?\M^?\M^?\M^?\M^?> on motherboard
acpi0: Power Button (fixed)
acpi0: reservation of ffb80000, 80000 (3) failed
acpi0: reservation of ffee0000, 20000 (3) failed
acpi0: reservation of fed10000, 80000 (3) failed
acpi0: reservation of fec00000, 1000 (3) failed
acpi0: reservation of fee00000, 1000 (3) failed
Timecounter "ACPI-fast" frequency 3579545 Hz quality 1000
acpi_timer0: <24-bit timer at 3.579545MHz> port 0x808-0x80b on acpi0
cpu0: <ACPI CPU> on acpi0
acpi_throttle0: <ACPI CPU Throttling> on cpu0
cpu1: <ACPI CPU> on acpi0
acpi_throttle1: <ACPI CPU Throttling> on cpu1
acpi_throttle1: failed to attach P_CNT
device_attach: acpi_throttle1 attach returned 6
pcib0: <ACPI Host-PCI bridge> port 0xcf8-0xcff on acpi0
pci0: <ACPI PCI bus> on pcib0
pcib1: <ACPI PCI-PCI bridge> at device 1.0 on pci0
pci1: <ACPI PCI bus> on pcib1
pci1: <display, VGA> at device 0.0 (no driver attached)
isab0: <PCI-ISA bridge> at device 2.0 on pci0
isa0: <ISA bus> on isab0
atapci0: <SiS 5513 WDMA2 controller> port 0x1f0-0x1f7,0x3f6,0x170-0x177,0x376,0xffe0-0xffef at device 2.5 on pci0
ata0: <ATA channel 0> on atapci0
ata1: <ATA channel 1> on atapci0
ohci0: <SiS 5571 USB controller> mem 0xfbfff000-0xfbffffff irq 20 at device 3.0 on pci0
ohci0: [GIANT-LOCKED]
usb0: OHCI version 1.0, legacy support
usb0: SMM does not respond, resetting
usb0: <SiS 5571 USB controller> on ohci0
usb0: USB revision 1.0
uhub0: SiS OHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub0: 4 ports with 4 removable, self powered
ohci1: <SiS 5571 USB controller> mem 0xfbffe000-0xfbffefff irq 21 at device 3.1 on pci0
ohci1: [GIANT-LOCKED]
usb1: OHCI version 1.0, legacy support
usb1: SMM does not respond, resetting
usb1: <SiS 5571 USB controller> on ohci1
usb1: USB revision 1.0
uhub1: SiS OHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub1: 4 ports with 4 removable, self powered
ehci0: <EHCI (generic) USB 2.0 controller> mem 0xfbffd000-0xfbffdfff irq 22 at device 3.3 on pci0
ehci0: [GIANT-LOCKED]
usb2: EHCI version 1.0
usb2: companion controllers, 4 ports each: usb0 usb1
usb2: <EHCI (generic) USB 2.0 controller> on ehci0
usb2: USB revision 2.0
uhub2: SiS EHCI root hub, class 9/0, rev 2.00/1.00, addr 1
uhub2: 8 ports with 8 removable, self powered
pci0: <network, ethernet> at device 4.0 (no driver attached)
atapci1: <SiS 5513 WDMA2 controller> port 0xe800-0xe807,0xe400-0xe403,0xe000-0xe007,0xdc00-0xdc03,0xd800-0xd80f,0xd400-0xd47f irq 17 at device 5.0 on pci0
ata2: <ATA channel 0> on atapci1
ata3: <ATA channel 1> on atapci1
pcib2: <ACPI PCI-PCI bridge> at device 6.0 on pci0
pci2: <ACPI PCI bus> on pcib2
pcib3: <ACPI PCI-PCI bridge> at device 7.0 on pci0
pci3: <ACPI PCI bus> on pcib3
fxp0: <Intel 82559 Pro/100 Ethernet> port 0xd000-0xd03f mem 0xfbff7000-0xfbff7fff,0xfbe00000-0xfbefffff irq 19 at device 13.0 on pci0
miibus0: <MII bus> on fxp0
inphy0: <i82555 10/100 media interface> on miibus0
inphy0: 10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
fxp0: Ethernet address: 00:90:27:74:e2:de
pci0: <multimedia> at device 15.0 (no driver attached)
acpi_button0: <Power Button> on acpi0
sio0: configured irq 4 not in bitmap of probed irqs 0
sio0: port may not be enabled
sio0: <16550A-compatible COM port> port 0x3f8-0x3ff irq 4 flags 0x10 on acpi0
sio0: type 16550A
fdc0: <floppy drive controller (FDE)> port 0x3f0-0x3f5,0x3f7 irq 6 drq 2 on acpi0
fdc0: [FAST]
ppc0: <ECP parallel printer port> port 0x378-0x37f,0x778-0x77f irq 7 drq 3 on acpi0
ppc0: SMC-like chipset (ECP/EPP/PS2/NIBBLE) in COMPATIBLE mode
ppc0: FIFO with 16/16/9 bytes threshold
ppbus0: <Parallel port bus> on ppc0
plip0: <PLIP network interface> on ppbus0
lpt0: <Printer> on ppbus0
lpt0: Interrupt-driven port
ppi0: <Parallel I/O> on ppbus0
atkbdc0: <Keyboard controller (i8042)> port 0x60,0x64 irq 1 on acpi0
atkbd0: <AT Keyboard> irq 1 on atkbdc0
kbd0 at atkbd0
atkbd0: [GIANT-LOCKED]
pmtimer0 on isa0
orm0: <ISA Option ROMs> at iomem 0xc0000-0xcefff,0xcf000-0xcffff on isa0
sc0: <System console> at flags 0x100 on isa0
sc0: VGA <16 virtual consoles, flags=0x300>
sio1: configured irq 3 not in bitmap of probed irqs 0
sio1: port may not be enabled
vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
ums0: Genius Optical Mouse, rev 1.10/1.00, addr 2, iclass 3/1
ums0: 3 buttons and Z dir.
Timecounters tick every 1.000 msec
acd0: CDROM <ASUS CD-S520B2/1.0> at ata0-master WDMA2
ad4: 76319MB <Seagate ST380215AS 3.AAD> at ata2-master WDMA2
SMP: AP CPU #1 Launched!
$
 
Old 11-28-2007, 05:54 PM   #2
reddazz
LQ Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 77
I can't see and audio device listed. What is the output of
Code:
#pciconf -l
 
Old 11-29-2007, 08:48 AM   #3
LordHendrix
LQ Newbie
 
Registered: May 2006
Posts: 16

Original Poster
Rep: Reputation: 0
$ pciconf -l
hostb0@pci0:0:0: class=0x060000 card=0x825d1043 chip=0x06711039 rev=0x00 hdr=0x00
pcib1@pci0:1:0: class=0x060400 card=0x000000d0 chip=0x00041039 rev=0x00 hdr=0x01
isab0@pci0:2:0: class=0x060100 card=0x00000000 chip=0x09681039 rev=0x01 hdr=0x00
atapci0@pci0:2:5: class=0x010180 card=0x825e1043 chip=0x55131039 rev=0x01 hdr=0x00
ohci0@pci0:3:0: class=0x0c0310 card=0x825e1043 chip=0x70011039 rev=0x0f hdr=0x00
ohci1@pci0:3:1: class=0x0c0310 card=0x825e1043 chip=0x70011039 rev=0x0f hdr=0x00
ehci0@pci0:3:3: class=0x0c0320 card=0x825e1043 chip=0x70021039 rev=0x00 hdr=0x00
none0@pci0:4:0: class=0x020000 card=0x825e1043 chip=0x01911039 rev=0x02 hdr=0x00
atapci1@pci0:5:0: class=0x010185 card=0x825e1043 chip=0x11831039 rev=0x03 hdr=0x00
pcib2@pci0:6:0: class=0x060400 card=0x000000b0 chip=0x000a1039 rev=0x00 hdr=0x01
pcib3@pci0:7:0: class=0x060400 card=0x000000b0 chip=0x000a1039 rev=0x00 hdr=0x01
fxp0@pci0:13:0: class=0x020000 card=0x000c8086 chip=0x12298086 rev=0x08 hdr=0x00
none1@pci0:15:0: class=0x040300 card=0x82901043 chip=0x75021039 rev=0x00 hdr=0x00
none2@pci1:0:0: class=0x030000 card=0x03460000 chip=0x01d310de rev=0xa1 hdr=0x00
$
 
Old 11-29-2007, 11:18 AM   #4
reddazz
LQ Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 77
My apologies, the command should have been "pciconf -lv".
 
Old 11-30-2007, 06:31 AM   #5
LordHendrix
LQ Newbie
 
Registered: May 2006
Posts: 16

Original Poster
Rep: Reputation: 0
# pciconf -lv
hostb0@pci0:0:0: class=0x060000 card=0x825d1043 chip=0x06711039 rev=0x00 hdr=0x00
vendor = 'Silicon Integrated Systems (SiS)'
class = bridge
subclass = HOST-PCI
pcib1@pci0:1:0: class=0x060400 card=0x000000d0 chip=0x00041039 rev=0x00 hdr=0x01
vendor = 'Silicon Integrated Systems (SiS)'
class = bridge
subclass = PCI-PCI
isab0@pci0:2:0: class=0x060100 card=0x00000000 chip=0x09681039 rev=0x01 hdr=0x00
vendor = 'Silicon Integrated Systems (SiS)'
class = bridge
subclass = PCI-ISA
atapci0@pci0:2:5: class=0x010180 card=0x825e1043 chip=0x55131039 rev=0x01 hdr=0x00
vendor = 'Silicon Integrated Systems (SiS)'
device = 'SiS5513 EIDE Controller (A,B step)'
class = mass storage
subclass = ATA
ohci0@pci0:3:0: class=0x0c0310 card=0x825e1043 chip=0x70011039 rev=0x0f hdr=0x00
vendor = 'Silicon Integrated Systems (SiS)'
device = 'SiS5597/8 Universal Serial Bus Controller'
class = serial bus
subclass = USB
ohci1@pci0:3:1: class=0x0c0310 card=0x825e1043 chip=0x70011039 rev=0x0f hdr=0x00
vendor = 'Silicon Integrated Systems (SiS)'
device = 'SiS5597/8 Universal Serial Bus Controller'
class = serial bus
subclass = USB
ehci0@pci0:3:3: class=0x0c0320 card=0x825e1043 chip=0x70021039 rev=0x00 hdr=0x00
vendor = 'Silicon Integrated Systems (SiS)'
device = 'SiS7002 USB 2.0 Enhanced Host Controller'
class = serial bus
subclass = USB
none0@pci0:4:0: class=0x020000 card=0x825e1043 chip=0x01911039 rev=0x02 hdr=0x00
vendor = 'Silicon Integrated Systems (SiS)'
class = network
subclass = ethernet
atapci1@pci0:5:0: class=0x010185 card=0x825e1043 chip=0x11831039 rev=0x03 hdr=0x00
vendor = 'Silicon Integrated Systems (SiS)'
class = mass storage
subclass = ATA
pcib2@pci0:6:0: class=0x060400 card=0x000000b0 chip=0x000a1039 rev=0x00 hdr=0x01
vendor = 'Silicon Integrated Systems (SiS)'
class = bridge
subclass = PCI-PCI
pcib3@pci0:7:0: class=0x060400 card=0x000000b0 chip=0x000a1039 rev=0x00 hdr=0x01
vendor = 'Silicon Integrated Systems (SiS)'
class = bridge
subclass = PCI-PCI
fxp0@pci0:13:0: class=0x020000 card=0x000c8086 chip=0x12298086 rev=0x08 hdr=0x00
vendor = 'Intel Corporation'
device = '82550/1/7/8/9 EtherExpress PRO/100(B) Ethernet Adapter'
class = network
subclass = ethernet
none1@pci0:15:0: class=0x040300 card=0x82901043 chip=0x75021039 rev=0x00 hdr=0x00
vendor = 'Silicon Integrated Systems (SiS)'
class = multimedia
none2@pci1:0:0: class=0x030000 card=0x03460000 chip=0x01d310de rev=0xa1 hdr=0x00
vendor = 'NVIDIA Corporation'
class = display
subclass = VGA
#
 
Old 11-30-2007, 07:03 PM   #6
reddazz
LQ Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 77
Since you seem to have a sis based multimedia device, try doing
Code:
#kldload snd_ich
After that log in as a normal user and play an audio file. If all went well, edit /boot/loader.conf and add
Code:
snd_ich_load="YES"
 
Old 12-01-2007, 08:37 AM   #7
0.o
Member
 
Registered: May 2004
Location: Raleigh, NC
Distribution: Debian, Solaris, HP-UX, AIX
Posts: 208

Rep: Reputation: 35
Loading your sound driver in FreeBSD is much easier than that. Simply issue these commands:

kldload snd_driver

cat /dev/sndstat

With the cat command it should give you output telling you what your driver is. Something similar to this:

pcm0: <SiS 7012> at io 0xdc00, 0xd800 irq 11 bufsz 16384 kld snd_ich (1p/1r/0v channels duplexdefault)


Once you know which driver you need, place the correct load statement into the loader.conf.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Audio problem in FreeBSD 6.2 saivinob *BSD 1 10-03-2007 02:43 AM
i need audio driver for conexant ac-link audio in compaq presario m2015ap red hat. subratapatel Linux - Hardware 1 08-12-2006 12:46 AM
audio problem in FreeBSD phinux *BSD 2 06-29-2006 09:15 PM
M-audio audiophile 2496 and freebsd jasone *BSD 2 12-19-2005 05:32 AM
How to play Audio/ Video CD on FreeBSD selvyn Linux - General 2 02-25-2004 08:47 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 07:27 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration