LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (https://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   Format USB Diskette Drive to FAT? (https://www.linuxquestions.org/questions/linux-hardware-18/format-usb-diskette-drive-to-fat-357675/)

sipples 08-27-2005 11:43 PM

Format USB Diskette Drive to FAT?
 
This one has me stumped. Is there any way to format a standard DOS FAT 3.5 in. 1.44 MB diskette in a USB diskette drive with Linux? The diskette drive appears as /dev/sda, but mformat doesn't work.

I realize I could possibly "cheat" by creating an image file from a blank diskette and then using something like this:

dd if=/opt/dosblank.flp of=/dev/sda

But that hardly seems satisfying.

Related to this problem, perhaps, is that VMware doesn't really see a USB diskette drive.

Anyone have any ideas on either of these issues? Thanks in advance.

maroonbaboon 08-28-2005 03:18 AM

Have you tried doing the low-level format first using 'fdformat' (see the man page). If mformat still doesn't work you could try mkfs.msdos.

sipples 08-28-2005 08:14 AM

fdformat doesn't think it's a diskette drive. The /dev/sda device is, I believe, basically a SCSI-like device, and fdformat doesn't know what to do with it.

Could it be that there's another /dev that gets instantiated (or could get instantiated)?

I can do this:

dd if=/dev/zero of=/dev/sda

which is, I suppose, sort of a low level format.

NetRAVEN5000 09-05-2005 01:05 PM

Quote:

Originally posted by sipples
I can do this:

dd if=/dev/zero of=/dev/sda

which is, I suppose, sort of a low level format.

Yes, that is a low-level format. What you want to do (assuming you already did the low-level format) is create a new partition table with "fdisk" or "cfdisk". Then use "mkfs.msdos" to make it a FAT partition.

sipples 09-05-2005 05:34 PM

Do diskettes have partitions? I don't understand that part.

NetRAVEN5000 09-06-2005 05:57 PM

Quote:

Originally posted by sipples
Do diskettes have partitions? I don't understand that part.
Yes, floppies do have partitions. Why do you ask? What's that got to do with your flash drive?

scm86 09-06-2005 10:00 PM

It appears to me he has an external 3.5" floppy, that uses USB and is device /dev/sda...

hopefully thats right and gets things cleared up... I can't help unfortionately because I dont have a floppy drive at all...

Scott McNeely

NetRAVEN5000 09-07-2005 02:08 AM

Ohhhhhhh. . . okay, that clears a lot up! I was thinking he was talking about a USB flash memory drive.

Well you can use KFloppy if you want to format a floppy disk. I don't know how to do it from the command line, though (and I doubt it would be worth the extra time).

sipples 09-07-2005 02:49 PM

KFloppy doesn't seem to work, unfortunately. Apparently USB diskette drives are just somehow...different. They look more like SCSI devices to Linux (hence the /dev/sda presence).

I've never known a floppy to be FDISKed under DOS (for example), so that's what's got me confused about partitioning.

NetRAVEN5000 09-07-2005 05:06 PM

Hmm. . . looks like you might just have to go the long route of formatting and creating a new partition manually - I doubt that there's much work being done for floppy disk tools any more since people are switching over to flash drives and CD/DVD-RW's.

Bruce Erlichman 09-16-2005 12:14 PM

Format USB floppy drive
 
I, too, have a floppy connected to a USB port. My
OS is Redhat 9.0. The diskette drive also appears
as /dev/sda (I always wondered why it's not
/dev/fd0).

If it's any consolation, I can't even 'fdformat' a floppy.
Nor can I use the 'floppy' command or any of the
'm---' dos linux commands.

Strangely enough, I can mount/umount the floppy drive,
change directory, mkbootdisk, copy to and from, boot
from, etc.

Can anyone out there help?

Bruce

teckk 09-16-2005 11:20 PM

http://rute.2038bug.com/index.html.gz
http://rute.2038bug.com/node22.html....00000000000000
http://www.google.com/search?q=usb+f...&start=10&sa=N

Google shows some answers.

agrimstad 10-31-2006 09:09 AM

Format USB Floppy
 
I stumbled onto this rather lame thread in trying to deal with my own usb floppy. There are a couple of basic facts I've found.

1. If fdformat supports the usb floppy device (/dev/sda, etc.) the documentation is well hidden. It certainly fails for me. The man page fdformat(8) doesn't hint at such support. fdformat is part of the util-linux package of utilities. There is a related package, fdutils (fdutils[dot]linux[dot]lu), which supports manipulating the parameters of the floppy drive, etc. This package explicitly excludes support for usb floppy drives right there on its home page.

2. Fortunately, as noted by the fdutils people, there is another project that does support usb floppies at this url:

www[dot]geocities[dot]jp[slash]tedi_world[slash]format_usbfdd_e.html

The program you need to format a floppy on a usb floppy drive is ufiformat. The typical use is: ufiformat -f 1440 /dev/sda. After creating a file system on the floppy (mkfs -t msdos /dev/sda), it should be ready to mount and use.

(I modified the urls above because of a strange limitation at this site.)


All times are GMT -5. The time now is 09:11 PM.