LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (https://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   Floppy disk troubles in Slack 10 (https://www.linuxquestions.org/questions/linux-hardware-18/floppy-disk-troubles-in-slack-10-a-287858/)

FattySlack 02-08-2005 05:37 PM

Floppy disk troubles in Slack 10
 
Alrighty, I just got up and running in linux for the first time like last week. (linux has never worked on this box before, until now)
So I've got a Super Disk 120MB floppy drive, that won't mount =-(

IDE1:Primary HDD
IDE1:Slave - the floppy
IDE2:Primary CD-ROM
IDE2:Slave - HDD

IDE1 is the main IDE channel, and 2 is you guessed it, secondary.

Yes, this is a floppy drive on an IDE cable, which is how they got it to be 120MB =-D I assume it's as easy as mounting it in the console, but it won't work right. I've tried to mount /dev/hdb1 (that should be it, right?).

Well, any help would be nice =-D

jailbait 02-08-2005 06:35 PM

"So I've got a Super Disk 120MB floppy drive, that won't mount"

Could you post the mount command that you used and the error message that you got? Have you formatted the floppy and if so what file system type did you format it as?

----------------------------
Steve Stites

FattySlack 02-08-2005 07:14 PM

I haven't formatted it, in fact, I don't even have a 120 disk. I just need to get the drive working, and obviously it won't be under fd's since it's not on the floppy channel.

I have standard floppies formatted by RAWRITEXP with boot/ram images
I don't get an error message, it just reads.... and reads... and reads... until I force the floppy out with the emergency eject thing. (then I have to kill the terminal)

FattySlack 02-08-2005 07:16 PM

I don't remember what I tried for a mount command, something like mount /dev/hdb1 /mnt/floppy or something.

FattySlack 02-09-2005 04:12 PM

No help? please?

GregLee 02-09-2005 05:09 PM

You can't mount a drive, only a device on a drive that has a filesystem. So in my opinion, you ought to buy a disk, put it in the drive, use cfdisk to partition it, use mkfs to format it, and only then try to mount it.

FattySlack 02-09-2005 05:26 PM

Well, I'm trying to mount just a regular floppy in the drive.

GregLee 02-09-2005 06:25 PM

Still, even a floppy needs a file system on it before it can be mounted. Floppies ordinarily come with MSDOS file systems already on them, but you said your floppies have boot/ram images. That doesn't sound like a file system, to me.

FattySlack 02-09-2005 06:27 PM

well it was written with rawritexp, which comes with the boot images on the slackware cd. it's readable in windows, so I assume it's a DOS/FAT filesystem.

J.W. 02-09-2005 07:28 PM

So what exactly is the mount command you are executing? -- J.W.

FattySlack 02-09-2005 09:04 PM

How about this, I rephrase my question.

How do I mount a floppy drive that is connected to the primary ide channel, as a slave?

I assume that it's /dev/hdb1 what mount command would I use?


All times are GMT -5. The time now is 11:50 PM.