-   Linux - Hardware (
-   -   Find an ATI Solution then Sticky It? (

Nalorin 07-19-2006 11:33 AM

Find an ATI Solution then Sticky It?
Hi, Guys:

It's been a while since I've used linux. I used Debian last - and that was about a year ago. Now, I'm using FC5, now - and remember almost nothing.

Now, I was hoping that I could simply install the ATI drivers and follow the same instructions that I did before to get it working - WRONG!! - ATI went and changed the flippin' things around on me - now once again, I cannot get it working. Perhaps we can get a set answer to this issue for Xorg 7.0 users then sticky it?

This time, I get an error different from last time (last time, it just wouldn't run tuxracer, or would run 3d programs crappily) - the error I get is the same as many have been getting:

aticonfig: error while loading shared libraries: cannot open shared object file: No such file or directory
when I run "aticonfig"

I googled the problem, and found a post here where they said try creating soft links - this was to no effect.
I tried another post on that one to "trick" the installer into thinking that this was an Xorg 6.9, instead of 7.0 - and my 2D acceleration no longer worked (bye bye to linux GUI).

I restored the xorg.conf file - and now I'm back to square one:
-----------> GUI is working with no 3D acceleration.

Here is the output of my "fglrxinfo"
Oh... nevermind that - now that's not working, either - I actually got it to say the "mesa" driver information, but now I just get this error, and I don't know what's wrong!:

fglrxinfo: error while loading shared libraries: /usr/lib/ cannot restore segment prot after reloc: Permission denied
According to yumex, mesa-libGL is installed, along with libGLU and I just installed libGLw.
I got this error once before - before I installed mesa-libGL - and fglrxinfo gave me the mesa driver output. Now, however - it's not working at all and I don't know how to fix it.

Can anyone help me, please?

XavierP 07-19-2006 12:08 PM

Have a look at this thread - it's full of information.

Nalorin 07-19-2006 03:42 PM

I took a look at that thread - and it IS full of information.

However, that thread is full of information that is not relevant to my OS - it would be relevant if I was still using FC3 (Heidelberg), though.

I remember doing similar things like that when I was working with FC3 but now I'm using FC5, ATI has changed their drivers, and the way to install everything has changed completely!

Can anyone help with this?

>>-----> Radeon 9600 on Kernel 2.6.15-1.2054_FC5 (Bordeaux) not working. I've tried following ATI's installer verbatim, but I get a shared object file error (noted in previous post).

And, of course, I'm using Xorg 7.0 (stock with Bordeaux)

rajmund 07-19-2006 03:46 PM

Ati has no support for linux 3d anymore - look at for drivers.
or try
yum install kmod-fglrx-2.6.17-2154_FC5 <-this kernel version depend on your system. get it with uname-r
not sure, you might need rpm key from livna repositories.

Nalorin 07-19-2006 04:35 PM


Originally Posted by rajmund
Ati has no support for linux 3d anymore - look at for drivers.
or try
yum install kmod-fglrx-2.6.17-2154_FC5 <-this kernel version depend on your system. get it with uname-r
not sure, you might need rpm key from livna repositories.

I'm currently working on doing just that.
I tried:
# yum install kmod-fglrx-$(uname -r)

I get:
No Match for argument: kmod-fglrx-2.6.15-1.2054_FC5
Nothing to do

I tried using yumex (Yum Extender) last time to install:
kmod-fglrx version: 2.6.17-2154_FC5
However, I think I may have installed the i586 instead of i686 (I have an Athlon XP-M 2600+), so I am now trying the i686 arch install.

I'll let you know how it goes in a few minutes...

rajmund 07-20-2006 01:52 AM

seems to me, yum does recognize livna, do this first to import livna key:

rpm -ivh

IBall 07-20-2006 02:05 AM

See Here for information on installing the ATI drivers on Fedora Core 5. (This is how I installed the drivers, so they should work)

Basically, you need to enable the livna repos, and then run the following as root:

yum -y --enablerepo livna install kmod-fglrx
I hope this helps

billymayday 07-20-2006 02:20 AM

This is testing my memory a lot, but wasn't kernel version 2.6.15-1.2054 the original one that shipped with FC5? If so, you will need to update your kernel, because if I remember correctly, a patch wa s required before the updated drivers would work.

I could be completely wrong though. Have a look at

it may help.

Nalorin 07-20-2006 10:57 AM

Great news! - it worked!\

(I did this from a fresh install)

I went to livna's configuration page ( and followed the instructions there.

I then went to rpm home page ( and followed the instructions there (I actually used yumex and was sure to select the i686 package (since I have an AthlonXP and not a regular Athlon) - it downloaded the new kernel version and the x11 driver file along with the kernelmod (kmod-fglrx) files for me (in a matter of short moments).

It said it completed fine.

I rebooted my computer and loaded the new Kernel version and DING! it works!

Thanks a bunch for your help guys!


To recap in step-by-step fashion:
  1. Install FC5 (Bordeaux) from DVD
  2. Install yumex (# yum install yumex)
  3. Install repository (# rpm -ivh
  4. Select drivers to install (from yumex, select kmod-fglrx [i686 arch])
  5. Download drivers & dependencies (including new kernel version, automatically done via yumex)
  6. Reboot computer
  7. Select new Kernel version
  8. Log into KDE
  • Test OGL Screensavers - Beautiful
  • Test fgl_glxgears - 300-somewhat fps
  • Test glxgears - 2200-somewhat fps

All times are GMT -5. The time now is 10:43 AM.