-   Linux - Hardware (
-   -   File owner and File group locked - root (

deiphage 02-03-2005 04:15 PM

File owner and File group locked - root
I've been rtfming ever since I started downloading FC3, and I've solved most of my problems thus far, but this has me scratching my head...

The device is a 200gig ide drive... I have no problems reading or writing locally.

Other machines on the network can read the contents, but cannot write...

path = /lunchbox
writeable = yes

/dev/hdc1 /lunchbox vfat users 0 0

* "security level configuration" - in the GUI
Other ports: [443:tcp, 137:udp, 138:udp, 139:tcp, 445:tcp]

On my other samba shares I had to change the ownership of the directory, but with this drive, I keep getting "Error Setting Owner" "The owner could not be changed." "Sorry, couln't change the owner of 'lunchbox'". Both the file owner and group are stuck on "root".

The other shares are just folders on hda...

Is my problem a security issue, or have I done something wrong with my user/file administration?

Also, the drive appears where I put it, /lunchbox, but it also shows up under "Computer" on the desktop. Is that autoload? Could it cause problems with changing ownership?

I am running FC3 with gnome.

Thanks in advance,

Jeff :study:

teckk 02-03-2005 10:22 PM

Only folders under your home folder can be shared I think.
You might want to make it in /home/yourname/lunchbox

Fedora also makes you open a konsole as super user to change certain things while you are in X. It isn't good enough to just open konsole and su to root. The path isn't there for the commands. Although you can specify it like /sbin/hdparm -d1 /dev/hda ect.
You can ctrl+F6 for another shell and su to root and do it.
chown is at /bin/chown

You might want to read the man on chown
man chown

If you mount the drive under /home you can share it.

Make a folder under home. mkdir /home/whatever
Then mount the drive to it.
mount -t vfat /dev/hdc1 /home/lunchbox users 0 0
Make the entry in your fstab to mount it auto.

deiphage 02-03-2005 11:14 PM

still no dice...

I have the exact same situation with /home/me/lunchbox, it won't let me change owners, or groups. In the gui, when I click on write for group and others... it unclicks them for me... I can't change the file owner, file group, or get a 777/775 - but I can take rights away... this is acting like a security issue more than anything...

I do remember reading something about issues regarding samba shares outside of the user's home directory, but I don't have any problems as long as the ownership is properly configured.

I'm logged in locally as root (for now at least), and have two desktops with terminals open, and two in the gui.

I haven't had any trouble with the mounting, or local rw access, but when I try to do a write from the client machine, nothing doing *maybe if I logon there as root... not a permanent solution, or even workable when it comes down to it...

teckk 02-04-2005 06:34 AM

Ok I read your post more clearly this morning.

path = /lunchbox
writeable = yes

I think you may need to specify the user or users who gets access.

I'm not at a Linux box, look at the examples in the smb.conf file. I think that you have to specify a user or users or public access.

phlppmrtns5 02-04-2005 07:55 AM

solving access problem
try maybe to edit changes on gnome as root
select the folder u want to "share" and unlock it for the group you want
creating a new user group may help.

Any doubts goto:

or contact me through

deiphage 02-05-2005 01:30 PM

The answer has been on for just over 3 years... stupid vfat...

Juergen Kreileder
22 Nov 2001 05:51:25 +0100

vfat doesn't support the UNIX concepts of file ownership and
permissions. You might want to use something like [edit]

/dev/hdc1 /lunchbox vfat defaults,uid=alberto,gid=users 0 0

When I changed the entry in fstab, and restarted (stupid MS habit), it had the ownership that I wanted. Now my client PC can read AND write.

Thanks everyone for your help. :D

All times are GMT -5. The time now is 01:42 PM.