LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (https://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   fifth button mouse not working. Tried a lot of things (https://www.linuxquestions.org/questions/linux-hardware-18/fifth-button-mouse-not-working-tried-a-lot-of-things-168839/)

spuppett 04-11-2004 02:37 PM

fifth button mouse not working. Tried a lot of things
 
Hey all,

I've been trying like hell to get my wheel to work on my mouse for about a week now, but to no avail. I've search this forum for help and tried a few things but nothing has worked.

I'm using slackware and kernal 2.4.22.

I've tried edititing /etc/X11/XF86Config and here's what I've got:

Code:

  Section "InputDevice"

# Identifier and driver

    Identifier        "Mouse1"
    Driver        "mouse"

# On platforms where PnP mouse detection is supported the following
# protocol setting can be used when using a newer PnP mouse:

    Option    "Protocol"      "Auto"

# The available mouse protocols types that you can set below are:
#    Auto BusMouse GlidePoint GlidePointPS/2 IntelliMouse IMPS/2
#    Logitech Microsoft MMHitTab MMSeries Mouseman MouseManPlusPS/2
#    MouseSystems NetMousePS/2 NetScrollPS/2 OSMouse PS/2 SysMouse
#    ThinkingMouse ThinkingMousePS/2 Xqueue
#    Option "Protocol"    "IMPS/2"

# The mouse device.  The device is normally set to /dev/mouse,
# which is usually a symbolic link to the real device.

    Option "Device"      "/dev/mouse"
#  Option "Device"      "/dev/psaux"
#  Option "Device"      "/dev/ttyS0"
#  Option "Device"      "/dev/ttyS1"

# When using XQUEUE, comment out the above two lines, and uncomment
# the following line.

# Option "Protocol"                "imps/2"
    Option "Buttons"                    "3"
    Option "ZAxisMapping"        "4 5"

# Baudrate and SampleRate are only for some Logitech mice. In
# almost every case these lines should be omitted.

#    Option "BaudRate"                "9600"
#    Option "SampleRate"        "150"

# Emulate3Buttons is an option for 2-button Microsoft mice
# Emulate3Timeout is the timeout in milliseconds (default is 50ms)

#    Option "Emulate3Buttons"
#    Option "Emulate3Timeout"    "50"

# ChordMiddle is an option for some 3-button Logitech mice

#    Option "ChordMiddle"

EndSection

I'm pretty new to Linux, especialy setting up hardware.

I used Mandrake before and it set all this up for me.

Anyway, any help would be MUCH appreciated.

ilikejam 04-11-2004 04:07 PM

Hi.

Option "Buttons" should be 5, not 3.

You should un-comment out the # Option "Protocol" "imps/2" line (remove the #).

That should get things moving. You *may* have to change the protocol to something different, but probably not

Dave.


All times are GMT -5. The time now is 06:17 AM.