-   Linux - Hardware (
-   -   fglrx 10.5 X segfault (

randname 06-20-2010 04:42 PM

fglrx 10.5 X segfault
1 Attachment(s)
Hi all
I'm at slackware64 13.1, kernel, videocard Ati FirePro v5700, fglrx 8.723

I built kernel module using patch for 2.6.33, then run aticonfig --initial ant started X, everything was fine except boost for maya (such cards intended to boost performance of some apps)
After that i found in aticonfig --help some extra options
run "aticonfig --initial --use-app-profile=maya --overlay-type=opengl --sync-vsync=on --pseudo-color=off"
i've lost my xorg.conf and after reboot got segfault..
I have tried a dozen of confs and drived reinstalations but every time same error


(**) Option "xkb_rules" "evdev"
(**) Option "xkb_model" "evdev"
(**) Option "xkb_layout" "us,ru"
(**) Option "xkb_variant" ",winkeys"
(**) Option "xkb_options" "terminate:ctrl_alt_bksp,grp:rwin_toggle,grp_led:scroll"
(II) fglrx(0): Restoring Recent Mode via PCS is not supported in RANDR 1.2 capable environments

0: /usr/bin/X (xorg_backtrace+0x28) [0x461c78]
1: /usr/bin/X (0x400000+0x5a799) [0x45a799]
2: /lib64/ (0x7f34e8f68000+0xf770) [0x7f34e8f77770]
Segmentation fault at address (nil)

Fatal server error:
Caught signal 11 (Segmentation fault). Server aborting

full Xlog in attachment

any thoughts?
ps sorry for bad english

business_kid 06-21-2010 03:28 AM

Did you google for that lovely error?

I didn't read it, but it certainly looks good.

randname 06-21-2010 04:36 AM

yes i do, but not found any solutions, only one thread about dual-head
there is

Btw, that segfault you posted seems to come from within X, not from fglrx.

Agreed. This segfault seens to be related to X itself. And probably it has to do with, guess what? Composite :D Im not sure, but I think composite is now enabled by default in the newer versions of Xorg. Im trying to disable it in xorg.conf file, but Im not sure if Xorg cares about it, since it look like its just ignoring my configuration.
I add
"Section "Extensions"
Option "Composite" "Disable"
in my xorg.conf , but same error

your link about OpenCL and solution is "upgrade to new version of catalist"

randname 06-21-2010 11:33 AM

Removing /etc/ati folder, reinstalling fglrx and aticonfig --initial did the job
happy and :)

All times are GMT -5. The time now is 06:05 AM.