LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 11-17-2007, 09:49 PM   #16
Simon Bridge
LQ Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 198Reputation: 198

Right: if entering "system-config-soundcard" successfully gets sound going... add that to the bottom of /etc/rc.local and it will reconfigure your soundcard automatically when you boot.

This is a workaround, shouldn't be needed, but it aught to give you working sound today.

Try:
/sbin/lsmod | grep snd
ls /etc | grep mod
 
Old 11-18-2007, 02:43 AM   #17
DarkFalcon
LQ Newbie
 
Registered: Oct 2007
Posts: 14

Original Poster
Rep: Reputation: 0
system-config-soundcard is an application, its the soundcard control application and theres a button in it to reload the drivers. But i made a shortcut to it on my desktop so i just run it and fix it when i boot.

I have ordered a new comp so will not be using this one for long anyway, it was just an "in the mean time" thing because my other one broke.

Thanks for your help anyway,

Andrew.
 
Old 11-18-2007, 04:02 AM   #18
Simon Bridge
LQ Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 198Reputation: 198
Well... for the record.

You can load the drivers manually with modprobe. Probably just the main driver would be needed, but it may be that the AC97 driver wasn't loading on boot. Compare the lsmod | grep snd list before and after the drivers are reloaded. You'll find there is a difference. Use modprobe to load the difference.
 
Old 12-02-2007, 02:58 PM   #19
rakku
LQ Newbie
 
Registered: Nov 2007
Distribution: Fedora 8 x86_64
Posts: 11

Rep: Reputation: 0
Hello,

I have the same problem here. Sometimes I receive the message
"Sound server informational message:
Error while initializing the sound driver:
device: default can't be opened for playback (Connection refused)
The sound server will continue, using the null output device."

Some other times, the message is something like "CPU overload, the sound system cannot be loaded".

In the first case, all the applications which don't use System Notification, i.e. Amarok, games, etc, will work. But those which use System Notification won't play any sound (Kopete, Konversation, Kmail, and so on). If I try to reload the modules with system-config-soundcard, the answer is somehing like "the modules can't be unloaded from the kernel. You must restart the computer for the changes to take effect", but restarting it don't change anything.

In the second case, simply testing the sound system in kcontrol will load the modules correctly. In this case the sound system will work perfectly.

"lsmod | grep snd" when the sound system is working well and when it's not show me the same modules. "sudo modprobe snd_ac97_codec snd_intel8x0" doesn't show me any error message but doesn't change anything, for these modules always show up in "lsmod | grep snd".

One more piece in the puzzle: uninstalling "alsa-plugins-pulseaudio" won't let the applications which don't use System Notification play any sound unless they are run as root, i.e., Kopete, Konversation, Kmail, etc will play sounds normally, but Amarok, for example, must be run as root to have access to the sound system.

Uf. If you you could read it through, do you have any ideas?

Thank you.
 
Old 12-03-2007, 07:02 PM   #20
Simon Bridge
LQ Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 198Reputation: 198
What is listed as the default soundcard?
But it looks like there may be a bug in there.
One approach would be to uninstall the pulseaudio server and install artsd, effectively returning the system to the old style. Basically, pulseaudio has problems with KDE. Have you tried sound under Gnome?

Reply te the thread below - this guy needs support.
http://forums.fedoraforum.org/showth...396#post914396

Also see:
http://www.redhat.com/archives/fedor.../msg01442.html
... covers setting pulseaudio to work with KDE.

yum install kde-settings-pulseaudio

Last edited by Simon Bridge; 12-03-2007 at 07:06 PM.
 
Old 12-03-2007, 11:15 PM   #21
DarkFalcon
LQ Newbie
 
Registered: Oct 2007
Posts: 14

Original Poster
Rep: Reputation: 0
Hey guys, I never got that fixed, i had to reload the drivers every time i started up ym computer, i now use kubuntu, if its not a hassle, i suggest switching to kubuntu if you have this problem, its very stable (7.10) and ive not had any problems with it, you can order a cd free of charge online. Not sure of the site but i used it to get my cd. Google free kubuntu cds if you are interested.
 
Old 12-04-2007, 12:31 AM   #22
Simon Bridge
LQ Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 198Reputation: 198
The fix for fedora 7 is in the second link in my last post - for those who find changing distro a bit extreme. The needed bit is to get pulseaudio to restart on login without needing to call up the sound configuration.

It's supposed to work in f8, but if it doesn't, I bet this is the problem.
 
Old 12-04-2007, 05:11 AM   #23
rakku
LQ Newbie
 
Registered: Nov 2007
Distribution: Fedora 8 x86_64
Posts: 11

Rep: Reputation: 0
Stangely enough, in my last 5 or 6 boots the sound system loaded perfectly.

I don't know if one thing has to do with the other, but I had changed my SELinux policy to "permissive". The first couple of boots after that didn't change anything, then it suddenly started working. I'm trying to remember if there was any update in between.

Quote:
Originally Posted by Simon Bridge View Post
What is listed as the default soundcard?
Sorry, I had forgotten:

Code:
+00:1e.2 Multimedia audio controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) AC'97 Audio Controller (rev 03)
Fedora 8 on 2.6.23.1-49.fc8
I do have kde-settings-pulseaudio installed, and I had already checked RexDieter's wiki page - it seems that it's done automatically now. I don't have Gnome installed.

Quote:
Originally Posted by DarkFalcon View Post
i now use kubuntu, if its not a hassle, i suggest switching to kubuntu
I've used Kubuntu for six months, then I switched to Fedora 8

Now I need to change SELinux back to "enforcing", I'll post the results.

Thank you guys

Last edited by rakku; 12-04-2007 at 05:14 AM.
 
Old 12-08-2007, 04:14 AM   #24
rakku
LQ Newbie
 
Registered: Nov 2007
Distribution: Fedora 8 x86_64
Posts: 11

Rep: Reputation: 0
Post

Quote:
Originally Posted by rakku View Post
Now I need to change SELinux back to "enforcing", I'll post the results.
All of a sudden, it all started once again, and changing SELinux didn't make any difference.
But since I've upgraded the kernel some days ago the problem seems to be gone. Once again.

I can only hope it won't come back.
In case it does, I'll be back to bother you
 
Old 12-08-2007, 05:02 AM   #25
Simon Bridge
LQ Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 198Reputation: 198
[default sound card] You listed the physically present one - I mean the alsa default... it may not be the same as the physical one.
Quote:
Fedora 8 on 2.6.23.1-49.fc8
I do have kde-settings-pulseaudio installed, and I had already checked RexDieter's wiki page - it seems that it's done automatically now.
And... you have noticed that it has suddenly started working?

There has been some fiddling in the way pulse-audio gets handled - the last update should have done the trick, but this is fedora, the developers like to fiddle. I used to limit updates to security fixes once everything was going.

BTW: edit your profile to show your distro. That way, when you juwp in with "I have the same problem" people won't guess you also have the same distro.

Last edited by Simon Bridge; 12-08-2007 at 05:03 AM.
 
Old 01-21-2008, 05:20 PM   #26
rakku
LQ Newbie
 
Registered: Nov 2007
Distribution: Fedora 8 x86_64
Posts: 11

Rep: Reputation: 0
For the record:

What definitely solved my problem - no earlier than one week ago(!), from a post in fedoraforum.org:

Quote:
By the way, I had audio intermittently working and not working on boot up. I did some reading around the web that suggested there was a problem with the pilot-link package that was causes pulseaudio to fail on boot up. Upgrading it did seem to resolve the issue, though I have no idea why pilot-link would be affecting pulseaudio...

yum -y upgrade pilot-link --enablerepo=development

did the trick...
source
 
Old 01-21-2008, 08:26 PM   #27
Simon Bridge
LQ Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 198Reputation: 198
Yep... a general update would have fixed it.

Well spotted that solution: a specific fix is always more valuable.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Get sound working on Fedora Core 3 ponka Linux - Newbie 2 12-25-2005 03:04 PM
Master sound control in kmix not working..fedora core 4 zoltrix Linux - Hardware 2 07-20-2005 09:39 AM
Sound card not working in Fedora Core 3 hybridstorm Linux - Hardware 3 06-18-2005 01:05 PM
sound not working on fedora core 2... total linuxian newbie here... pc tweakz Linux - Newbie 5 08-04-2004 10:50 PM
Sound card not working in Fedora Core 2 Fredstar Linux - Newbie 8 07-05-2004 04:30 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 06:01 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration