LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (https://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   Fedora Core 6 on Dell Dimension E520 (https://www.linuxquestions.org/questions/linux-hardware-18/fedora-core-6-on-dell-dimension-e520-508484/)

sandyman 12-08-2006 05:08 AM

Fedora Core 6 on Dell Dimension E520
 
Hi,

I've recently purchased a Dell Dimension E520 (Intel Core Duo 2 @1.86MHz, 1024MB DDR2) and I've installed an additional harddisk (WD 250GB, SATA) to install Fedora Core 6 Linux on. Installation went fine, however, I don't see the GRUB bootloader which should have been installed on /dev/sda. In stead, the machine plainly boots Windows XP MCE.

This particular model only has SATA interfaces available. I haven't changed any of the BIOS settings regarding this, since this is highly recommended unless you *really* know what you're doing. For some reason, Dell has enabled the RAID settings (which I don't use) and I don't want to change this. Who knows what might happen if I do...

Has anyone seen this problem before? If so, what's the solution? Any pointers would be greatly appreciated!

Regards,
Sander

dombrowsky 12-29-2006 05:03 AM

the installation of the bootloader must have failed.

Honestly, I know its the "older" one and all that, but I've NEVER had lilo fail on me. If it isn't going to work, it tells me when I run /sbin/lilo. Look into it.

sandyman 01-07-2007 03:47 AM

Quote:

Originally Posted by dombrowsky
the installation of the bootloader must have failed.

Honestly, I know its the "older" one and all that, but I've NEVER had lilo fail on me. If it isn't going to work, it tells me when I run /sbin/lilo. Look into it.

I've fixed it this way:

I've swapped the Windows harddisk and the Linux harddisk (Linux is now /dev/sda on SATA1, Windows is now /dev/sdb on SATA4), so it successfully boots GRUB from the Linux partition. In the grub.conf I have a section for Windows and in it, I swap the partitions of Windows and Linux in order to get Windows at (hd0,0):

title Windows XP MCE
map (hd0,0) (hd1,1)
map (hd1,1) (hd0,0)
rootnoverify (hd1,1)
chainloader +1

(hd1,1) is naturally my Linux partition. This way, Windows will boot properly and it will see the second drive (/dev/sdb in Linux) as the first one (C: in Windows).

Sander

ravenlife 01-24-2007 06:15 PM

I am having the same problem on the same machine.

but as i am a complete newbie to linux (this would be my first install)

im not quite sure what you mean in your post about the fix

do you mean switch the Cables on the harddrives?

as i get an error everytime i try to install Grub

thanks in advance

RL

sandyman 01-25-2007 01:58 AM

Hi,

could you be a little more specific about the error message you get?

With respect to the cables: I've physically swapped them. I believe the harddisk is initially connected to SATA1 (the DVD-drive to SATA2). At first, I installed my additional harddisk on SATA4, but then I got all the errors from GRUB. So, I simply swapped the cables so that my Linux drive is on SATA1, my (original) Windows XP drive is on SATA4 and I added the swap lines in my grub.conf (as I posted previously). Please turn to the GRUB documentation for details about this.

Hope this helps.

Sander

ravenlife 01-25-2007 12:22 PM

Okay - ill explain everything (as i have run into more troubles)

I have Windows Xp on my Primary HD, and i also need to store data on my second (250gb) HD - so i created a partition of 150gb for the files.

i then booted into Fedora install using the DVD, i followed all the instructions,
selected the create partition using free space option

it did this and continued the install and finished with no errors.
so i rebooted and it loaded windows first up = after browsing for a while i found this thread (amongst others)

after reading another thread - i re-inserted the DVD selected repair and tried to install GRUB on the windows HD, this failed not with an error persay but with something like

"NO Kernal Package was installed on your system, please reboot" thats not exact

so i unplugged my first harddrive and tried to boot fedora as primary

this gave me

"error starting operating system"

so i removed fedora and did it all again - making sure i did everything as i should = but still nothing

Can Fedora boot off of the second partition of a drive?

thanks

RL

ravenlife 01-25-2007 04:07 PM

Sorry for the double post but i thought i would keep the above one clear

i have managed to fix the problem this way.

removes main windows drive
make second drive master
install linux as only operating system
with all default settings (apart from the ones you need to change)

and thats it - it boots

when you plug you windows drive back in it should boot windows first

just disable it in the bios to use linux

not perfect i know, but its good enough for me

thanks all

RL


All times are GMT -5. The time now is 01:08 PM.