-   Linux - Hardware (
-   -   Fedora 16, Ubuntu 11.10 liveCD not booting - possibly linked to Cyborg v7 keyboard (

Linuxstudent 03-08-2012 08:56 AM

Fedora 16, Ubuntu 11.10 liveCD not booting - possibly linked to Cyborg v7 keyboard
Hi All,

When I try to boot to Fedora 16 or Ubuntu 11.10 liveCD I get stuck just after the kernel seems to recognise my keyboard - a Cyborg V7.

Unfortunately I don't have another keyboard before the obvious answer is posted and won't have access to one for a week or two. I also can't plug out the keyboard to test the boot since I can't press the "any" key to boot from cd :D

Is there any way to set a boot flag to ignore specific hardware and just load generics?

I assume that the keyboard is what causes the freeze as it's the last thing on screen. I'm also running on an Intel 510 SSD. These are the only two changes since I successfully installed 11.10 on the same system (Old HD was a Hitachi Deskstar SATA II)

Thanks in advance

jefro 03-08-2012 04:15 PM

The only time I ever have seen a keyboard issue was with some one of a kind industrial ones made for a specialized use. They seemed to take too much current for the motherboards we used.

Try each of the live cd's in fail safe.

Never tried it but see what happens if you simply remove the keyboard.

Linuxstudent 03-09-2012 08:18 AM

Thanks Jefro,

I'll try fail-safe this evening and post back, running for a lecture right now.

I can try unplugging the keyboard after I boot from CD. Now that I think about it I'm pretty sure I can use the keyboard on the "what do you want to do" pre-boot screen of the FC16 CD.

I might give OpenSuSe or a KDE spin a shot to rule out the GDM if this doesn't work and maybe drop back to a 2.6 kernel distro.

Post the results tomorrow

Linuxstudent 03-13-2012 06:36 PM

Ok no joy, although I have ruled out the cyborg -

Tried both discs, couldn't see a failsafe mode for either. I was having difficulty with my CD drive so I formatted a USB key and used UNetbootin to create an Ubuntu 11.10 image.

Selected "Try without installing" and immediately unplugged keyboard - booting still hung at SCSI sdc detected (from what I could see SDC is the USB key it was booting from)

Rebooted, selected "Install Ubuntu Now". Same result. I plugged the keyboard in AFTER it stalled and keyboard was recognised (I could see it loading the drivers)

I went into my BIOS and disabled hot-swapping on all my SATA drives, no change.

I'm currently downloading a KDE spin of Fedora 16 to rule out GNOME issues.

Any suggestions on how to proceed from here? Is there any way to capture a detailed logfile of the boot attempt?

Changes to my system since I successfully installed Ubuntu 11.10 -

1. Intel 510 series SSD installed, BIOS set to AHCI where it was previously IDE
2. Cyborg V7 keyboard attached
3. System moved to new case (This issue occurred before moving to the newer case also but mentioning for completeness)
4. GTX 580 installed

Linuxstudent 03-13-2012 06:48 PM

I've found bugs for the same issues

Looking like this is caused by the newer generation of graphics cards.

Going to try work-arounds and try to get myself back into Linuxland. I'll reply again if I succeed.

Linuxstudent 03-13-2012 08:44 PM

I'm back up and running :)

Solution was posted here

To summarise -

How to set NOMODESET and other kernel boot options in grub2
I had to do this with my Nvidia 9600GT:
To install Ubuntu, boot from the cd press any key at accessibility circle and keyboard, press F6 and then select the nomodeset option.
USB boot - At the menu press tab on the first option to edit the boot options and replaced the 'splash' option with 'nomodeset'.
On first boot after install, press e on getting the GRUB bootloader.
Hold shift from BIOS boot to get menu if only one system installed.
Using arrow keys navigate to and delete quiet and splash and type the word nomodeset in their place

Huge thanks to oldfred for providing this step by step solution. Once installed successfully I installed the proprietary Nvidia drivers and there was no need to edit GRUB to add nomodeset as a permanent option.

educaon999 03-13-2012 09:51 PM

Try each of the live cd's in fail safe.

jefro 03-13-2012 10:19 PM

Thanks for posting back and the solution. Failsafe is a choice one can get to usually. It's defaults are many of the kernel line options such as that and a few more that help stubborn systems to start. Then I try some of the options a few at a time to see what is going on.

All times are GMT -5. The time now is 06:27 AM.