-   Linux - Hardware (
-   -   Fedora 13 SSD TRIM Support (

Potatos 06-11-2010 12:56 PM

Fedora 13 SSD TRIM Support

Ive been working with seting up a linux image to be used on the computers at my work. Its based off Fedora 13 and uses the kernel.

The PC's will use SSDs, currently I'm developing with a Intel X-25E 64GB SSD, Firmware version 8850.

I have been trying to test the TRIM feature that is included in this kernel. To do this I have followed the instructions I found here:

Essentially I create a tempfile on the drive, read the memory location, delete the file and check the memory location again. The file has not been deleted from the SSD, If I am correct this means the TRIM feature is not functioning correctly.

My Fstab has the drive set up for discard.

Is there something I am missing in order to get TRIM working properly or am I misunderstanding the test. If you need any other information I'd gladly provide it.

smoker 06-12-2010 02:02 AM

Have you got the data=writeback flag in your mount options ?

Which actual version of the SSD is it, because according to this the X25-V has TRIM enabled, but I can't see any references to anything earlier that either didn't support TRIM or you needed to flash the firmware which seemed to break the SSDs.

X25-E looks earlier than X25-V to me.

Electro 06-12-2010 02:42 AM

Use DRAM based SSD, then you do not have to worry about TRIM. Yes you will have to worry about the battery, but that is easier to replace than trying to figure out a way to get NAND Flash based SSD to function correctly in any operating systems.

mrgroover 06-13-2010 05:42 PM

AFAIK the Intel X-25E does not support TRIM, so no matter if it is included in the kernel, the SSD will not know what to do with the command...

Potatos 06-14-2010 09:21 AM

Thanks for the help everyone,

The actual model number is: SSDSA2SH064G1GC with FW: 8850

I can't find anything to suggest that the drive does or doesn't have trim support. I assumed that it being a higher priced intel drive would have the support.

I also didn't have the data=writeback flag and will look into testing with that enabled. Additionally I am also going to see if i can find another SSD to test, I will update when I get a chance.

smoker 06-14-2010 11:27 AM

From the link I gave :

Anyways, all X25-V are shipped with TRIM enabled firmware.
My current firmware is 2CV102HD.
hdparm -I /dev/sda gives this, too:
Enabled Supported:
* Data Set Management TRIM supported
* Deterministic read ZEROs after TRIM
can you try running that on the correct drive and see what you get ?

Potatos 06-14-2010 03:17 PM


Originally Posted by smoker (Post 4003255)
From the link I gave :

can you try running that on the correct drive and see what you get ?

I ran that on the X25-E and I got neither of those flags.

I was able to test with a X25-M and it worked perfectly with just the discard option!

The X25-M had the 2CV102HD firmware but I didn't get a chance to run the hdparm test before I returned it :(.

Thanks again for all the help

All times are GMT -5. The time now is 11:32 PM.