-   Linux - Hardware (
-   -   Fedora 11 RAID 1, Disk failure - How to boot from the single working disk (

NothingSpecial 10-16-2009 02:18 PM

Fedora 11 RAID 1, Disk failure - How to boot from the single working disk

my Fedora 11 system is not starting anylonger. It stops with the message:


VFS: Can't find ext4 filesystem on dev dm-0
The system told me since a while, that a lot of the sectors of one disk of the (software) RAID compound are failed already. So tried to disconnect each of the disks and start them separately. Unfortunaltly this is not working (for one its is not working at all, the other wents the same far as with both), when I tried to recover the system with the Fedora DVD, it said no distribution found.
I am quite new and do not know so much about linux system, so i do not know what further information you could need. Maybe it can be important, that both disks are encryped (the system wents so far, that I can type in the password).

Thanks in advance,

Nothing Special

Raum the Old 10-18-2009 07:12 PM

Maybe you should use a simpler setup than encrypted ext4 on software RAID1 next time. And before you put valuable data on the system, test that you can actually recover from a failing disk.

Your hardware might not actually be bad, it may be due to some problem with the software.

I recommend that you try to boot from a CD or DVD and mount your filesystems, get your important data off, and reinstall your system.

oli 10-18-2009 07:20 PM

The master boot record can only be stored on one disk, so while there is redundancy with the two drives in RAID 1 if the drive with the MBR on it dies then you need to boot to a rescue disk and use grub to reinstall a new MBR. Google for "reinstall grub" and you will find plenty of guides to do this.

All times are GMT -5. The time now is 03:34 PM.