-   Linux - Hardware (
-   -   FC3 nvidia logout crash (

bwa 02-03-2005 05:12 PM

FC3 nvidia logout crash
I have used FC2 and now FC3, and I install the Nvidia drivers from their website (Not the ones), and everything works well - the X server starts up, nice and fast, and openGL works great. However, when I logout of X, or reboot directly from X, then the system freezes up. All of the correct options are edited into xorg.conf, and it has worked before, all the way from RH8.0, and worked just fine with FC1, but with FC2 and FC3, this problems occurs. X works fine, both starting and exiting, when I use "nv" and not "nvidia". Any help would be appreciated. Oh, and btw, I got an error about "rivafb" when installing the NVidia drivers on FC3, but the kernel does not load them up, and the Nvidia driver works fine until I quit X or reboot, so I do not think rivafb has anything to do with this.


bushidozen 02-04-2005 09:21 PM

Please post your xorg.conf file.
Also, what version nvidia driver are you using?

Ace07 02-04-2005 09:41 PM

There is a bug with the newest Nvidia driver and FC3. Check this link out.

bwa 02-04-2005 11:45 PM

Using latest Nvidia drivers 1.0-6629. Absolutely no problems loading X, only problems when I exit it.


# XFree86 4 configuration created by redhat-config-xfree86
#Section "extmod"
# Option "xfree86-dga" #don't load the dga extension, supposedly makes the mouse work in games like duke3d

Section "ServerLayout"
Identifier "XFree86 Configured"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"

Section "Files"
ModulePath "/usr/X11R6/lib/modules/extensions"
ModulePath "/usr/X11R6/lib/modules"
FontPath "unix/:7100"

Section "Module"

#Load "GLcore" # OpenGL support
#Load "dri" # Direct rendering infrastructure
# Load "record" # X event recorder
# You only need the following two modules if you do not use xfs.
# Load "freetype" # TrueType font handler
# Load "type1" # Adobe Type 1 font handler
Load "v4l" # Video4Linux
Load "dbe" # Double-buffering
Load "glx" # OpenGL X protocol interface
Load "extmod" # Misc. required extensions

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbLayout" "us"

Section "InputDevice"

# Modified by mouseconfig
#Option "BaudRate" "7000"
Identifier "Mouse0"
Driver "mouse"
Option "Device" "/dev/input/mice"
Option "Protocol" "IMPS/2"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
#Speed below is for Logitech mice only, I set speed in .xsession (xset m 1 2 for cordless optical)

Section "Monitor"

# was VertRefresh 50 - 120
Identifier "MEI2640"
VendorName "Panasonic"
ModelName "PanaSync S50"
HorizSync 40.0 - 67.0
VertRefresh 50.0 - 80.0
Option "dpms"

Section "Device"

#Driver must be "nvidia" NOT "nv" for the 3D to work
Identifier "nVidia Corporation|NV11 DDR"
Driver "nvidia"
BoardName "GeForce 4 MX 440"

Section "Device"
Identifier "Linux Frame Buffer"
Driver "fbdev"
BoardName "Unknown"

Section "Screen"

#This agp options apparently makes this driver stable
# Option "NVAGP" "0"
#TwinView (nView below)
# Option "TwinView" "true"
# Option "SecondMoniterHorizSync" "30-90"
# Option "SecondMoniterVertRefresh" "50-160"
# Option "MetaModes" "800x600, 640x480; 1280x1024, 640x480"
# Option "ConnectedMoniter" "crt,tv"
# Option "TVOutFormat" "COMPOSITE"
# Option "TVStandard" "NTSC-M"
# Option "TwinViewOrientation" "Clone"
# Option "Xinerama" "on"
#Twinview (nVew) done
#Display the Nvidia logo on startup is below
Identifier "Screen0"
Device "nVidia Corporation|NV11 DDR"
Monitor "MEI2640"
DefaultDepth 24
Option "NoLogo" "1"
SubSection "Display"
Virtual 1240 1024
Depth 16
Modes "1024x768" "800x600"
SubSection "Display"
Virtual 1240 1024
Depth 24
Modes "800x600"

Section "DRI"
Mode 0666

bushidozen 02-04-2005 11:52 PM

# Option "SecondMoniterHorizSync" "30-90"
# Option "SecondMoniterVertRefresh" "50-160"
# Option "MetaModes" "800x600, 640x480; 1280x1024, 640x480"
# Option "ConnectedMoniter" "crt,tv"

Are you sure you are supposed to spell it "Moniter" in my xorg.conf file, I spell it "Monitor".

bwa 02-04-2005 11:55 PM

Thank you for pointing that out, that section never worked, that must be why :) However, that will not fix my current problem. I will change that though.


All times are GMT -5. The time now is 02:41 PM.