LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 09-20-2004, 02:24 PM   #1
pfaendtner
Member
 
Registered: Nov 2003
Posts: 57

Rep: Reputation: 15
FC2 Soundcard


Hi,

I have a new IBM NetVista,

I am running FC2 (2.6.5 kernel) and I can't get my soundcard to work? Using the soundcard detection the module comes up as "snd-intel8x0" , playing a test sound doesn't play anything.

Does anybody have any thoughts on how I can diagnose this problem and fix it?

thanks!

Jim
 
Old 09-20-2004, 06:29 PM   #2
Peacedog
LQ Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,296

Rep: Reputation: 168Reputation: 168
Please post the output of the following commands.

/sbin/lspci -v

lsmod

good luck.
 
Old 09-21-2004, 08:53 AM   #3
pfaendtner
Member
 
Registered: Nov 2003
Posts: 57

Original Poster
Rep: Reputation: 15
/sbin/lspci -v

00:00.0 Host bridge: Intel Corp. 82845G/GL[Brookdale-G]/GE/PE DRAM Controller/Host-Hub Interface (rev 01)
Flags: bus master, fast devsel, latency 0
Memory at d0000000 (32-bit, prefetchable)
Capabilities: [e4] #09 [0105]

00:02.0 VGA compatible controller: Intel Corp. 82845G/GL[Brookdale-G]/GE Chipset Integrated Graphics Device (rev 01) (prog-if 00 [VGA])
Subsystem: IBM NetVista A30p
Flags: bus master, fast devsel, latency 0, IRQ 11
Memory at 88000000 (32-bit, prefetchable)
Memory at 80000000 (32-bit, non-prefetchable) [size=512K]
Capabilities: [d0] Power Management version 1

00:1d.0 USB Controller: Intel Corp. 82801DB (ICH4) USB UHCI #1 (rev 01) (prog-if 00 [UHCI])
Subsystem: IBM NetVista A30p
Flags: bus master, medium devsel, latency 0, IRQ 11
I/O ports at 1800 [size=32]

00:1d.1 USB Controller: Intel Corp. 82801DB (ICH4) USB UHCI #2 (rev 01) (prog-if 00 [UHCI])
Subsystem: IBM NetVista A30p
Flags: bus master, medium devsel, latency 0, IRQ 10
I/O ports at 1820 [size=32]

00:1d.2 USB Controller: Intel Corp. 82801DB (ICH4) USB UHCI #3 (rev 01) (prog-if 00 [UHCI])
Subsystem: IBM NetVista A30p
Flags: bus master, medium devsel, latency 0, IRQ 5
I/O ports at 1840 [size=32]

00:1d.7 USB Controller: Intel Corp. 82801DB (ICH4) USB2 EHCI Controller (rev 01) (prog-if 20 [EHCI])
Subsystem: IBM NetVista A30p
Flags: bus master, medium devsel, latency 0, IRQ 9
Memory at c0080000 (32-bit, non-prefetchable)
Capabilities: [50] Power Management version 2

00:1e.0 PCI bridge: Intel Corp. 82801BA/CA/DB/EB/ER Hub interface to PCI Bridge (rev 81) (prog-if 00 [Normal decode])
Flags: bus master, fast devsel, latency 0
Bus: primary=00, secondary=02, subordinate=02, sec-latency=32
I/O behind bridge: 00002000-00002fff
Memory behind bridge: c0100000-c01fffff

00:1f.0 ISA bridge: Intel Corp. 82801DB (ICH4) LPC Bridge (rev 01)
Flags: bus master, medium devsel, latency 0

00:1f.1 IDE interface: Intel Corp. 82801DB (ICH4) Ultra ATA 100 Storage Controller (rev 01) (prog-if 8a [Master SecP PriP])
Subsystem: IBM NetVista A30p
Flags: bus master, medium devsel, latency 0, IRQ 5
I/O ports at <unassigned>
I/O ports at <unassigned>
I/O ports at <unassigned>
I/O ports at <unassigned>
I/O ports at 1860 [size=16]
Memory at 10000000 (32-bit, non-prefetchable) [size=1K]

00:1f.3 SMBus: Intel Corp. 82801DB/DBM (ICH4) SMBus Controller (rev 01)
Subsystem: IBM NetVista A30p
Flags: medium devsel, IRQ 9
I/O ports at 1880 [size=32]

00:1f.5 Multimedia audio controller: Intel Corp. 82801DB (ICH4) AC'97 Audio Controller (rev 01)
Subsystem: IBM NetVista A30p
Flags: bus master, medium devsel, latency 0, IRQ 9
I/O ports at 1c00
I/O ports at 18c0 [size=64]
Memory at c0080c00 (32-bit, non-prefetchable) [size=512]
Memory at c0080800 (32-bit, non-prefetchable) [size=256]
Capabilities: [50] Power Management version 2

02:08.0 Ethernet controller: Intel Corp. 82801BD PRO/100 VE (LOM) Ethernet Controller (rev 81)
Subsystem: IBM NetVista A30p
Flags: bus master, medium devsel, latency 66, IRQ 9
Memory at c0100000 (32-bit, non-prefetchable)
I/O ports at 2000 [size=64]
Capabilities: [dc] Power Management version 2

[root@chief jim]# /sbin/lsmod
Module Size Used by
snd_pcm_oss 40740 0
snd_mixer_oss 13824 3 snd_pcm_oss
snd_intel8x0 26280 3
snd_ac97_codec 50436 1 snd_intel8x0
snd_pcm 68872 2 snd_pcm_oss,snd_intel8x0
snd_timer 17156 1 snd_pcm
snd_page_alloc 7940 2 snd_intel8x0,snd_pcm
gameport 3328 1 snd_intel8x0
snd_mpu401_uart 4864 1 snd_intel8x0
snd_rawmidi 17184 1 snd_mpu401_uart
snd_seq_device 6152 1 snd_rawmidi
snd 38372 11 snd_pcm_oss,snd_mixer_oss,snd_intel8x0,snd_ac97_codec,snd_pcm,snd_timer,snd_mpu401_uart,snd_rawmidi, snd_seq_device
soundcore 6112 3 snd
parport_pc 19392 1
lp 8236 0
parport 29640 2 parport_pc,lp
autofs4 10624 5
nfs 142912 3
lockd 47944 2 nfs
sunrpc 101064 7 nfs,lockd
e100 25348 0
mii 3584 1 e100
ipt_REJECT 4736 1
ipt_state 1536 1
ip_conntrack 24968 1 ipt_state
iptable_filter 2048 1
ip_tables 13440 3 ipt_REJECT,ipt_state,iptable_filter
floppy 47440 0
sg 27552 0
scsi_mod 91344 1 sg
microcode 4768 0
dm_mod 33184 0
joydev 6976 0
uhci_hcd 23708 0
ehci_hcd 21896 0
button 4504 0
battery 6924 0
asus_acpi 8472 0
ac 3340 0
i830 55856 2
ipv6 184288 10
ext3 102376 1
jbd 40216 1 ext3


thanks dude!
 
Old 09-21-2004, 09:20 AM   #4
Peacedog
LQ Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,296

Rep: Reputation: 168Reputation: 168
Looks like the modules are all loaded, try running a mixer and unmuting your sound.
good luck.
 
Old 09-21-2004, 10:28 AM   #5
pfaendtner
Member
 
Registered: Nov 2003
Posts: 57

Original Poster
Rep: Reputation: 15
I turned on all the chanels with alsamixer but I still can't get any audio (I also checked the port which the headphones are connected to). I'm trying to play a CD or use the "play test sound" in system-config-soundcard

any thoughts?
 
Old 09-21-2004, 10:57 AM   #6
Peacedog
LQ Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,296

Rep: Reputation: 168Reputation: 168
There are a few suggestions here.

https://bugzilla.redhat.com/bugzilla....cgi?id=123631

good luck.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Soundcard Driver for ALi M5451 Soundcard (Trident Module) xianzai Linux - Hardware 3 12-15-2006 12:00 PM
Sound card won't work unless I do a soundcard detection in FC2 jonlake Linux - Hardware 2 09-07-2005 10:07 AM
Soundcard not detected... FC2 TBennettcc Linux - Hardware 8 11-04-2004 10:40 AM
FC2: Soundcard no longer detected ummmmm Linux - Hardware 3 07-06-2004 01:18 PM
Soundblaster Audigy Platinum 1 Soundcard Help with FC2 axess_denied Linux - Hardware 1 06-07-2004 02:48 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 07:19 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration