-   Linux - Hardware (
-   -   Failure to boot (no POST, no BIOS, no nothing) after freeze (

Grady 08-16-2007 05:47 AM

Failure to boot (no POST, no BIOS, no nothing) after freeze
I'm possibly looking at four distinct problems here, but anyway...I also hope that this is the right place to post this query, but I think it is.

I've been building a system using Source Mage GNU/Linux (SMGL). Late last night, I downloaded the latest module-init-tools release ("spell" in SMGL-speak), 3.3. It didn't compile ("cast"), so I went to bed, thinking to solve the problem this morning.

When I booted up, my system hung while doing, shortly after trying to mount a particular hard drive partition (which is empty at the moment). There is a known bug in SMGL to do with this, but obviously I needed more information in order to move forward; and it would seem that the bug's been squished besides (Aargh! the anti-spam thing in this forum stopped me from linking to the bug report, but if one googles "init hangs at" it comes up at number one). So I booted off my rescue/install disk, and got into a bash.

Now all of a sudden, the system didn't seem to acknowledge that I had a hard drive at all. Since it was booting off the hard drive initially till it froze, obviously the drive was at least partially working first thing this morning.

So I rebooted, intending to go into BIOS to see what I could see about hard drives or absences thereof.

This time, the computer wouldn't do anything. Symptoms:

* Fans on - hence there is some flow of power
* It seems, judging from LEDs, sounds, etc., that the hard drive spins
* No keyboard/mouse (no numlock LED, no light on the optical mouse) - hence power wouldn't seem to reaching peripherals
* Monitor on amber light, not green
* No beeps, and hence probably
* Not even getting as far as a POST

Not being a complete twit, I've tried all the obvious things like making sure everything's connected to the motherboard properly, clearing CMOS memory (using both battery-removal and jumpers), etc. Nothing's working.

The problem obviously isn't with any of the I/O devices, since there would then be POST beeps all over the place, and they are unlikely to have all failed simultaneously anyway. I haven't tried putting the hard drive into another box, because that's tedious and I'm lazy, but theoretically even if the hard drive is fried (which it may well be) I should at least be getting error messages on startup, not silence, and be able to get into my BIOS - and when I tried booting with the hard drive disconnected (i.e. just with the CD), the same thing happened anyway.

So the hard drive issue is possibly extraneous to what would appear to be a motherboard problem. And it may well be that the is superfluous to that (linked to SMGL bug 12840), with the module-init-tools compilation error sitting on top of all of them. Alternatively, that a stable release of module-init-tools didn't compile on a really very straightforward system could have been an omen of some incipient hardware problem (I wish I could remember now why it said it couldn't compile!) which systematically got worse as I tried new things (the problem, then, having nothing to do at all with what I was doing - the hardware just shutting down, step-by-step).

So, I'm looking for suggestions as to how to proceed. Is there anything else that could be causing this annoying startup problem? If I can fix that, then I'm probably capable of sorting out the other problems myself...I've just never had one of these before.

Thanks awfully for any assistance I may receive.

Wim Sturkenboom 08-16-2007 06:17 AM

My feeling is that your HW just has died (proc / mobo / memory). The probably froze because of this HW failure.

The 'normal' procedure for fault finding is to disconnect everything and start with a system with only MoBo, proc, mem (one module unless HW requires more) and video and see if that wants to boot.
If yes, start adding other components one by one till a problem occurs. The last added device is probably the culprit but be aware that it can be a combination of multiple faulty devices and only the last one triggers it.

Other option that might help are to reset the BIOS.

And if you have the option to swap components, try that.

Grady 08-16-2007 06:38 AM

Dankie vir die vinnige antwoord, Wim!

I already reset the BIOS, and tried booting with the hard drive disconnected. I just tried disconnecting the CD drives as well - following your suggestion for a `minimal' boot - but still the same problem. When I disconnected the graphics card and used the onboard video (hence only mobo, proc, mem, onboard video), still the same.

I can swap memory with stuff from other boxes, and probably a processor as well, as an absolute last resort (that really is a pain), but I was wondering whether there's anything else obvious that I'm missing, that I can try first.

michaelk 08-16-2007 07:53 AM

Maybe a bad power supply or motherboard.

All times are GMT -5. The time now is 01:29 PM.