LinuxQuestions.org

LinuxQuestions.org (http://www.linuxquestions.org/questions/index.php)
-   Linux - Hardware (http://www.linuxquestions.org/questions/forumdisplay.php?f=18)
-   -   Failure in Installing HP PSC 1401 All-in-One in Ubuntu 12.04 (http://www.linuxquestions.org/questions/showthread.php?t=4175496445)

julianvb 02-27-2014 12:22 PM

Failure in Installing HP PSC 1401 All-in-One in Ubuntu 12.04
 
When I was running the hplip-3.12.1 driver, the printer seemed to be detected by Ubuntu 12.04 LTS but all the print jobs just got stored in the queue and I could not use its scanner function. I feel that there has never been any communication between the O.S and the printer.

So I next tried replacing the driver with hplip-3.14.1, but at the end of the installation I saw the following error, which I also saw when I tired hplip-3-13.11 subsequently.

"error: Configure failed with error: General/unknown error"

I'll appreciate very nuch getting any help from this forum.

Julianloui

notKlaatu 02-27-2014 12:33 PM

You say the printer "seemed" to be detected by Ubuntu. What makes you say that? What indication has there been that Ubuntu sees the printer?

Also, how did you install the printer initially? Have you gone into Printer configuration in System Settings and added the printer along with the appropriate driver?

Also also, how is the printer connected? I'm assuming USB?

julianvb 02-27-2014 12:56 PM

You say the printer "seemed" to be detected by Ubuntu. What makes you say that? What indication has there been that Ubuntu sees the printer?

> > > I said that because I saw the jobs in the queue. I think my conclusion was wrong.
-------------------------------------------------------------------------------------------
Also, how did you install the printer initially? Have you gone into Printer configuration in System Settings and added the printer along with the appropriate driver?

> > > I don't rememeber how I did it. But today I cannot find the HP PSC1401 in the Printer configuration list in System Settings.
------------------------------------------------------------------------------------------
Also also, how is the printer connected? I'm assuming USB?

> > > Yes, USB. Thank you very much.

Julianvb

notKlaatu 02-27-2014 01:08 PM

Well maybe it's good that the printer can't be found now, it gives you a bit of a chance to start over. I would unplug the printer. Reboot for good measure. Once Ubuntu is back up and running, turn the printer on and then plug the printer into the computer. Wait to see if Ubuntu prompts you to add a driver or accept the printer, or whatever magical thing Ubuntu does these days.

If nothing magical happens, the go to System Settings > Printer and go through the steps of adding a printer. You should see in the Add Printers window your printer connected via USB (accept no substitutions). Click through to add that printer, making sure you are pointing Ubuntu to the right printer driver. Otherwise, Ubuntu will "see" the printer alright, but it will never know how to "drive" it. So make sure you have provided it with a valid and appropriate driver (it should be in the list of possible drivers as you add the printer).

Keep us posted.

julianvb 02-28-2014 04:56 PM

Hi,

I was luckier today. After I moved the printer's USB connector to a different port on the computer. Linux finally recognized it according to the 'lsusb' command as HP PSC1400. The only URI in the setup I could use was ipp//cups-server/printers/printer-queue, which showed the following PSC series devices. In other words my PSC1401 was missing from the list.

I decided to pick PSC2110 and pretended that my printer was PSC2110. I still could make Lunix communicate with the printer as all the jobs were still piled up in the queue. Printer State said
that Linux was uanble to locate printer "cups-server".

Julianvb



PSC370, PSC380, PSC500, PSC750,PSC950,pSC950xi, PSC2110, PSC2150, PSC211 0.

julianvb 02-28-2014 11:03 PM

Tonight I decided to delete from my Downloads directory hplip-3.13.11 and hplip-3.14.1. If I enter
the "dpkg -l hp*" command, I can see hplip-3.12.1 listed as shown in the attached image file. I've also replaced PSC2110 with PSC1401 as my default printer. Thus far nothing useful has resulted and there is still no communication between the printer and the computer. I guess my current problem is that Linux is still waiting for me to provide it with the correct driver for the PSC1401.

Question: How can I put hplip-3.12.1 to use in connection with CUPS, especially its URI entry?

Julianvb

cwizardone 02-28-2014 11:07 PM

You have CUPS installed?
Open a browser and on the location bar type, localhost:631 and go from there.

notKlaatu 03-01-2014 12:47 AM

And yeah, the odds are that Ubuntu is not going to be able to control the printer properly if you tell it to use the incorrect driver.

julianvb 03-02-2014 02:51 PM

3 Attachment(s)
Hi, Everyone,

Thank you very much for your kind help. By the way, I do have CUPS installed on my LInux computer.

Yesterday I decided to re-do my printer driver installation from scratch the rtegular automatic CUPS way as follows.

1. Added HP-PSC-1401 (as the sole default printer).
2. Let CUPS search and select a suitable driver.
3. Tested driver by sending jobs to printer in power-on and power-off states.

CUPS also failed to find my printer's driver but the selected driver can send jobs to the printer and can tell whether the machine is actively connected or off. Due to the simplicity of the system-to-printer interface, as soon as the job is dumped to the printer, the driver considers its work completed even though my printer has not blinked even once throughout each job's transmission to the printer. In other words, the printer does not know that it has received a print job. So I am not sure that the driver is working perfectly.

When I open Simple-Scan, it reports that it does not detect a scanner. The HP-PSC-1401 comes with a scanner.

Even though my printer prints a Self-Test page at power-up and its offline copier works fine, I am not certain that it's all fine. I bought it last year from someone who is no longer around.

However, I hope that by examining my attachments you might find some new clues. Thanks again.

Julianvb

notKlaatu 03-02-2014 03:32 PM

OK so it sounds like the printer part of the unit is working. I mean, if you send print jobs to it, and a piece of paper comes out with ink on it that accurately reflects what you sent to the printer...then that is working. Right? or am I missing something?

In terms of scanning, this link:
Actually, looking
http://hplipopensource.com/node/302

seems to state that your printer/scanner does not support computer-initiated scans. You have to scan a document to email or a network location, from the printer/scanner itself. So you will not use an OS-based scanning software. Configure a place where the printer can dump your scanned files (like a shared folder, I mean) and then scan from the printer/scanner. The scanned document will be placed, probably as a PDF, in the shared folder.

julianvb 03-02-2014 04:45 PM

What I am trying to report is that even though the driver appears to be doing its job OK, the printer may have received the data but it hasn't blinked its lights or moved its motor! In short, it just sits idly there, ignoring the input from the driver. I tend to think there's still no real reaction or response from the printer. Perhaps it's not a suitable driver.

That's also why I'm trying to use Simple-Scan to test the printer out from another angle. I've been very successful in using Simple-Scan with my other Linux 12.04 computer's HP Deskjet F4210 All-in-One printer.

Julianvb

julianvb 03-02-2014 11:57 PM

3 Attachment(s)
Hi, Everyone.
Glad Tidings!

Tonight I purged all traces of HPLIP from my computer and re-instlalled the most basic version, namely hplip-3.12.2.run without a glitch. Thus far the Printer Properties configuration table looked OK except that the Print Status box indicated that /usr/lib/cups/filter/foomatic-rip-hplip was missing. Since I could find only foomatic-rip, I just named a copy of it as foomatic-rip-hplip and put that in /usr/lib/cups/filter, hoping it would work.

Well, this did change things quite a bit. At least now when I enter 'lp filename.txt', the printer reacts, but not exactly the way I want it to. It either spits out an old file that I've seen before consistently or just a Self-Test page! This old file, a library-catalog file, appears to have been stuck in the printer's firmware from the previous owner of the printer, like a ghost. I thought i had got rid of it last year.

But at least I think things are going my way. My next step is to find the foomatic-rip-hplip file. I think it should not be too difficult. I'll report back when and if I locate it.

Julianvb

julianvb 03-07-2014 06:02 PM

Hi, Everyone,

<> <> Excellent Solution to HPLIP-3.12.2's Missing foomatic-rip-hplip Problem <> <>

I should have browsed more carefully at this forum for a solution to my problem. I've just found it in an answer given by bryan641 at this very forum to a another missing foomatic-rip-hplip question. My original simplistic attempt to create foomatic-rip-hplip didn't work because it was not based on Linux knowledge but rather intuition. I wish I could e-mail Bryan to thank him directly.

Repeated below is Bryan's answer:

cd /usr/lib/cups/filter
ln -s foomatic-rip foomatic-rip-hplip


Julianvb


All times are GMT -5. The time now is 11:00 PM.