-   Linux - Hardware (
-   -   Failed to start scanner: Invalid argument HPc6380 (

theAdmiral 06-20-2010 10:32 PM

Failed to start scanner: Invalid argument HPc6380
Trying to get scanning going with my all-in-one, and have been troubleshooting it for awhile, and nothing works. Could use expert advice on this topic for an HP c6380 All-in-One. Printing does fine. All attempts at scanning are failing. scanimage -L says the device is my webcam. I don't know if usb scanner is in /dev. Please help.


tredegar 06-21-2010 03:46 PM

You have told us your device, but not your linux distro. So please help us to help you.

Some "all in one" devices do not show up as scanners until you press the "Scan" button on the device. Then, they appear, and work.

So put a piece of paper in, press the scan button, then fire up your distro's scan program, and tell us what happens.

Laurens73 06-24-2010 01:57 PM

What most distro's do have in common is that the scanner doesn't have the right permissions set to it.

Try to scan the same images as root. If it works now, the scanner is installed correctly, but the permissions have to be set.

Depending on the distro you have the permissions should be altered. For example Debian / Ubuntu put users who are allowed to scan also in the group scanner. This can be done by editing /etc/group with your favourite text editor, or with your favourite graphical user adminstration tool. Sometimes the rules files in /etc/udev/rules need altering too. In that case we need more information from you, wich distro you use, and wich model shows up when asking your system:


laurens73@pc39:~$ sane-find-scanner

  # sane-find-scanner will now attempt to detect your scanner. If the
  # result is different from what you expected, first make sure your
  # scanner is powered up and properly connected to your computer.

  # No SCSI scanners found. If you expected something different, make sure that
  # you have loaded a kernel SCSI driver for your SCSI adapter.

found USB scanner (vendor=0x147e [TouchStrip        ], product=0x1001 [Fingerprint Sensor  ]) at libusb:001:004
  # Your USB scanner was (probably) detected. It may or may not be supported by
  # SANE. Try scanimage -L and read the backend's manpage.

  # Not checking for parallel port scanners.

  # Most Scanners connected to the parallel port or other proprietary ports
  # can't be detected by this program.

  # You may want to run this program as root to find all devices. Once you
  # found the scanner devices, be sure to adjust access permissions as
  # necessary.

In this case: vendor=0x147e and product=0x1001 are the items to search for. Look what number your scanning device offers and try to find it in one of the rules files. Alter the line over there, giving the user full acces by using MODE=0666 in stead of MODE=0644.

After altering group memberships or altering the rules, restart the system to reload the modules automaticly.

tredegar 06-24-2010 02:14 PM

Thanks for the additional information.

But this thread is marked as [SOLVED] and AFAIK this can only be done by the Original Poster, so presumably the OP has found a solution.

It would be helpful to linux users finding this thread if "theAdmiral" told us just how he solved his problem, and supplied the information requested in post #2.

Then we can let this thread lie in peace.

theAdmiral 06-25-2010 12:37 AM

The original link is embedded in the second link.

Sorry for rushing off.

Thank you,

All times are GMT -5. The time now is 03:28 AM.