-   Linux - Hardware (
-   -   F5D7050 USB Wireless adaptor under Debian linux, Sarge (

chebbes 07-13-2006 04:02 AM

F5D7050 USB Wireless adaptor under Debian linux, Sarge
Hi everyone, I'd be very appreciative of your help with a problem that
I've been having with the Belkin F5D7050 USB adaptor device under Debian (Sarge).

I have read the other threads and tried their solutions, but to no avail, so I apologise if this covers "already visited" ground.
I'm a bit of a linux newbie (I've played around for a bit, and
eventually seem to be learning some of the basics...)

I've been having problems getting this device to work at all.

As I understand it, there are two techniques to installing it

1) Use the RALink RT2500 series windows driver and use NDISWrapper,
mapping to the correct usbid for the device.
- NDISwrapper fails
- ndiswrapper -l shows that the driver is installed and that the
hardware is present
- dmesg and /var/logs/syslog reports that "the windows driver cannot
initialise the device"
- dmesg also states that the device times out.
- no wlan devices show up in iwconfig
- have tried editing /etc/network/interfaces file to give basic
configuration data, but no success - when I ifup or /etc/networking
restart, the error message is just that the device does not exist, the
configuration is not complete or the interface flags are not present.

2) Use RT2500 series native linux driver
I installed this from the etch testing distribution, but, although the
driver installed, I cannot see any wlan0 or rausb0 interfaces on the

I've just tried on a fresh distribution from a knoppix live CD, but the
same thing happens - the device is "seen" but I cannot use it.

lsusb shows that the device is present, and I know USB is working as I
can print to my USB printer and see my USB flash drive.

Does anyone have any suggestions on how I might get this up and
running - also which of the solutions "should" be the best/easiest/most stable under sarge.

My ultimate plan is to use my main PC as a router so that I
can use my laptop to access the net and my files from elsewhere in my
flat. If anyone wants the output of any files, I'd be happy to post

Thanks in advance,


All times are GMT -5. The time now is 07:05 AM.