LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (https://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   External USB HD works at first, then stops after creating FS?? (https://www.linuxquestions.org/questions/linux-hardware-18/external-usb-hd-works-at-first-then-stops-after-creating-fs-568263/)

thinksincode 07-10-2007 07:56 PM

External USB HD works at first, then stops after creating FS??
 
Hi all,

I'm having a strange problem with a 320 GB IDE hard drive in a USB enclosure...

Quick background: I'm running Ubuntu 7.04 server edition, kernel 2.6.20-15-server. When I first booted up the computer, with the new HD attached, it worked fine and assigned the external USB drive to /dev/sdb.

So I created a single primary Linux partition via fdisk - no problem. Then I created an ext3 filesystem by typing 'sudo mkfs.ext3 /dev/sdb1'. That also completed successfully, no problem.

Then I rebooted the computer. Here is where the problems started. After the reboot, I noticed that there was no /dev/sdb or /dev/sdb1 device anymore. I looked in the syslog and found this:

---
usb 4-3: device descriptor read/64, error -71
usb 4-3: new high speed USB device using ehci_hcd and address 3
usb 4-3: device descriptor read/64, error -71
usb 4-3: device descriptor read/64, error -71
usb 4-3: new high speed USB device using ehci_hcd and address 4
usb 4-3: device not accepting address 4, error -71
usb 4-3: new high speed USB device using ehci_hcd and address 5
usb 4-3: device not accepting address 5, error -71
---

I rebooted several times, leaving the USB hard drive plugged in and turned on, and this kept happening. The weird part is, if I turn the drive off and on again, then it works and /dev/sdb and /dev/sdb1 show up in my filesystem.

I decided to go back and redo it, rebooting at each stage. Here are the results:
  • Booting up with the drive empty and unpartitioned: Works, /dev/sdb is there
  • Create Linux primary partition (320 GB), reboot: Works, /dev/sdb and /dev/sdb1 are there
  • Create ext3 filesystem, reboot: Doesn't work! This is where I get the errors listed above. Turning the drive off and on again fixes the problem.

Does anyone have any idea what could cause this? I wouldn't mind having to turn the drive off and on but this is going to be a server machine and if I have to reboot it remotely, all my files on the drive will be inaccessible. Any ideas would be greatly appreciated!

--
Joe

macemoneta 07-11-2007 01:00 PM

I remember a similar problem in an old Fedora release. The issue there was that the system wasn't allowing enough time for the device to settle at boot. It seems that some external devices take a few extra seconds to spin up at boot, but the system skips them when they don't respond.

You can test this by recreating the problem, then:

sudo modprobe -r ehci_hcd
sudo modprobe ehci_hcd

If the drive comes up, then that's the issue.

thinksincode 07-13-2007 09:53 AM

In case anyone was interested, the cause seems to be that the USB enclosure I was using was a piece of junk. I bought a new I/O Magic one at Staples yesterday, put my hard drive in there, and it seems to be working flawlessly now!

I occasionally still get the "error -71" message at bootup, but the drive still gets recognized eventually.

Thanks for your ideas though!

Joe

cheesus 09-28-2007 12:10 PM

Increase USB startup timeout (to get drive recognized without modprobe cmd!)
 
Hello,

I've just had this problem with current SuSE 10.2, and the
modprobe command got the drive running.

Is there any way to get increase the recognition timeout ?

Thanks,
Tom.

macemoneta 09-28-2007 12:55 PM

Updating to a more current udev and/or kernel should correct the problem. It looks like there is a bug report covering this issue in the Suse Bugzilla.

cheesus 09-28-2007 01:26 PM

Cool, thanks, that's probably the issue.
Well, it is unfixed in lates SuSE with latest updates.
Me, personally, I'd not install that libs from "beta" something.
Hopefully an official update will come through in the next weeks.
Cheers, Tom.

cheesus 10-01-2007 06:08 AM

BUT it is really slow now!
 
Hmm, mounting worked now, as reported, but the 25G copy job
I started yesterday evening was still running this morning,
so there must be a huge performance penalty to using this
"workaround"...

macemoneta 10-01-2007 10:16 AM

It sounds like the port you are using is not running at USB 2.0 speed. When the device was plugged in do you see a "high speed" message in the log? For example:

Quote:

new high speed USB device using ehci_hcd and address 3

cheesus 10-03-2007 03:56 AM

Yes,

Quote:

Oct 3 10:54:47 ozz kernel: usb 1-4: new full speed USB device using ohci_hcd and address 9
that's the cost of the workaround. So let's hope SuSE fixes this really fast... :-/

macemoneta 10-03-2007 09:31 AM

The "full speed" message indicates that the device is operating at USB 1.1 speed, not USB 2.0. Are you sure the port is USB 2.0?

cheesus 10-11-2007 01:06 PM

Yes, all worked well with previous kernels, so it can't be hardware.

Please see above, I'd think that using "full speed" instead
of "high speed" is the penalty for unloading the module.
With with "high speed" it doesn't work at all.

No progress in the Bugzilla ... :-(

Cheers, Tom.

macemoneta 10-11-2007 01:29 PM

You always have the option of building your own kernel from kernel.org.

cheesus 11-26-2007 04:10 PM

Well, I have the latest 10.2 patches, and the problem still persists.
I can't believe they closed the bug with "No response after six weeks."

Did upgrading to 10.3 solve the problem for anybody...?

uzbad 02-26-2008 05:27 PM

Possible solution
 
I had a similar problem with my usb hdd. Additional power cable solved it. It seems high speed uses much more power.


All times are GMT -5. The time now is 06:45 AM.