-   Linux - Hardware (
-   -   external partitioned usb hard disk (

mr_a_ali 08-14-2004 10:02 AM

external partitioned usb hard disk
Hi everyone,

I'm brand new to Linux, and I'm using SuSE Linux Personal 9.1.

Thankfully, a lot of my equipment (such as my external CD burner) works via USB.

However, I also have an external USB hard disk that doesn't work. I used it on my Windows machine, and partitioned it as 1 FAT32 drive and 1 NTFS drive.

Well, under Hardware Configuration in SuSE, it recognizes it as a Maxtor 80 GB hard disk, and even recognizes the partitions, and their file system type. Even under the "My Computer" folder, there is an icon that says "USB Hard Disk".

However when I try to open it, it simply says that it can't access it. I'm only interested in accessing the FAT32 part. How can I?

Any help is appreciated. Thank you.

Oliv' 08-14-2004 10:19 AM


It's probably a problem of rights... Can you access it as root? If yes, you need to change your /etc/fstab file... Post it, and someone will tell which changes to do ;)


kpachopoulos 08-14-2004 11:22 AM

I have exactly the same problem; only difference is that my 40G Seagate is formated as NTFS. It seems to be recognized in Yast ( i have also Suse 9.1) and i can find it as "file:/media/usb-storage-DEF13B18AC79:0:0:0p1". I tried to access it as root, but the same problem ("can't access it'). The HD can be found in "/dev" as asd1, but not in fstab. So, i think i must edit fstab; the first problem is that i don't know exactly how to do it and the second is that even when i tried to edit it, it couldn't be written (even when i was logged in a root). Here's my fstab:
/dev/hda2 / reiserfs acl,user_xattr 1 1
/dev/hda1 /windows/C ntfs ro,users,gid=users,umask=0002,nls=utf8 0 0
/dev/hda3 swap swap pri=42 0 0
devpts /dev/pts devpts mode=0620,gid=5 0 0
proc /proc proc defaults 0 0
usbfs /proc/bus/usb usbfs noauto 0 0
sysfs /sys sysfs noauto 0 0
/dev/cdrecorder /media/cdrecorder subfs fs=cdfss,ro,procuid,nosuid,nodev,exec,iocharset=utf8 0 0
What's the problem ? What can i do?

All times are GMT -5. The time now is 12:36 PM.