LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (https://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   External HDD Mounting Issues (https://www.linuxquestions.org/questions/linux-hardware-18/external-hdd-mounting-issues-419260/)

opiea 02-24-2006 06:59 PM

External HDD Mounting Issues
 
I have an external NTFS HDD and it sometimes won't mount during boot up during the SuSe 10.0 Bootup. I've tried running the commands as root: umount /dev/sdb1 and it said it was unmounted, but when I went mount /dev/sdb1 /media/External it said that /dev/sdb1 was already mounted on Windows D. I don't have permissions to read the folder but I tried chmod u=rwx and it said it changed but I still can't access it. It is turned on and plugged in. When it doesn mount to /media/External during boot-up it works fine, except for the fact that it says the HDD is write-protected and I don't know how to fix that either soo...

How do I mount the HDD and set it to be Writable in SuSe Linux 10.0?

ralvez 02-24-2006 07:32 PM

Try to mount it by adding this to your /etc/fstab
/dev/sdb1 /media/External vfat auto,user,rw,exec 1 2

Hope this helps.

Rick

opiea 02-24-2006 07:58 PM

I have my fstab now setup like this:

/dev/sdb1 /media/External ntfs ro,users,rw,exec,gid=users,umask=0002,nls=utf8 1 2

It mounts fine now but it is still read-only

ralvez 02-24-2006 08:01 PM

I think the read-only problem is due to the fact that is mounted NTFS. On that format linux can only read.

Rick

jschiwal 02-24-2006 08:30 PM

I would suggest reading chapters 32 & 33 in the SuSE Administrators guide. It sounds like you may have the hotplug system and you manual /etc/fstab entry fighting each other. So you are unable to mount the device because it is already mounted.

If the filesystem is NTFS, then that explains why the partition is read-only. You may consider using a different filesystem on the device.


All times are GMT -5. The time now is 10:44 PM.