Download your favorite Linux distribution at LQ ISO.
Go Back > Forums > Linux Forums > Linux - Hardware
User Name
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?


  Search this Thread
Old 08-14-2003, 01:14 AM   #1
LQ Newbie
Registered: Aug 2003
Location: Canada, Eh!
Distribution: Slackware 10.0
Posts: 5

Rep: Reputation: 0
Angry External Drive Mounted, Can't access as a user

Linux Newbie...

My Distro is SUSE 8.2, Kernel 2.4.20-4GB, installed on a Toshiba Satellite 1800-s100.

I have a 14 GIG external Toshiba drive Connected via USB, through a USB 2.0 Cardbus card. It is formatted as FAT32. The drive is recognized; Mounts automatically both root, and user; and I can write to it --- but only as root.

Here is my /etc/fstab entry:

/dev/sda1 /windows/External vfat user 0 0

I can't change ownership of directories on this drive, nor can I change ownership of the drive itself!

When I create a directory X and then chown it to the user I want to let access that directory I get "Can't change permissions on folder X, You do not have sufficient privleges to do this" --- this being whilst logged on as ROOT!

linux:/windows/External # mkdir TheWaker
linux:/windows/External # chown -c thewaker TheWaker
chown: changing ownership of `TheWaker': Operation not permitted
linux:/windows/External #
(I am logged on as root here)

This is annoying the heck out of me....all I want to do is write files to this drive in both Linux and WinXP so I can share back and forth with ease!

Any help is greatly appreciated, and I hope I've included enough information.
Old 08-14-2003, 03:54 AM   #2
LQ Newbie
Registered: Aug 2003
Location: India
Distribution: Red Hat 9.0
Posts: 9

Rep: Reputation: 0
This *might* work...

in /etc/fstab
1. add the device and mount point.
2. specify the file system as auto
3. specify the other options as-rw,owner,user
4. mount the drive.
Old 08-14-2003, 07:43 AM   #3
Registered: Aug 2002
Posts: 24,733

Rep: Reputation: 5596Reputation: 5596Reputation: 5596Reputation: 5596Reputation: 5596Reputation: 5596Reputation: 5596Reputation: 5596Reputation: 5596Reputation: 5596Reputation: 5596
Are you trying to change permissions of the directory with the drive mounted?

This question is asked a lot here so have you searched the stite yet?

Hint: You will need to add the option umask=000 to the entry in the /etc/fstab file.
Old 08-14-2003, 12:32 PM   #4
LQ Newbie
Registered: Aug 2003
Location: Canada, Eh!
Distribution: Slackware 10.0
Posts: 5

Original Poster
Rep: Reputation: 0
Ha, I don't know what I did, but it's working now.

Actually I did nothing....I rebooted a few times whilst configuring other hardware...

I've been reading from/writing to it all morning...GIG after GIG...

By the way...I did search the forum, but couldn't seem to find any information answering my specific problem.

Anyways Thanks for you help...I'll remember those answers for the future
Old 08-14-2003, 03:26 PM   #5
Senior Member
Registered: Jun 2003
Distribution: Debian/other
Posts: 2,104

Rep: Reputation: 45
A useful addition to a suitable umask value is your user id number ( uid =xxx ) - it grants you ownership of your mounted files etc.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
External Hard Drive --No Access as USER only ROOT (10.1) 1kyle Mandriva 1 10-31-2004 09:09 AM
cant access mounted drives when logged in as a user Shantesh Linux - General 1 12-25-2003 08:07 PM
write access to mounted drive woja Linux - Newbie 3 11-05-2003 02:24 AM
External Hard Drive Not Mounted during Install chazdg Mandriva 5 10-30-2003 11:02 AM
Common user access to mounted partitions? JoooN Slackware 2 02-16-2003 06:17 AM > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 05:42 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration