-   Linux - Hardware (
-   -   EXT4fs error occurs periodically (

thiemster 04-05-2010 05:50 PM

EXT4fs error occurs periodically
I am running Linux Mint 8 on my Dell Precision 350 computer. Every so often (sometimes every few hours, sometimes every few days, it appears to be random) my desktop will crash and display the message:

"70822.286411 EXT4fs error (device sda1): ext4_ext_check_inode: bad header/extent in inode #139281: invalid magic - magic 800c, entries 121, max 3278020), depth 171(171)"

This is displayed several times on all of the terminals, but with different numbers each time. When this happens, typing any commands in the terminal result in the error message being displayed again. When I restart after this happens, linux generally displays "Give root password for maintenance (or type control-D to continue):" and I give the root password. Running "fsck /dev/sda1" seems to fix this problem for the next boot, but then it will come back in either a few hours or a few days. Reinstalling the distro does not work, as I have already tried this. I suspect a hard disk error, but before I run out and buy and install a new hard disk, I wanted to know if maybe there is some way to fix this through software.


MrCode 04-05-2010 06:26 PM

If this is a recurring problem, then the drive is probably going bad, I hate to say. Do you have a backup that you could restore from? If not, then I would make one now, while you can still boot into the OS at all, get a new drive, and restore from backup.

You can do this without re-installing the OS when you restore with a handy little tool called Clonezilla. This basically will allow you to create a perfect byte-for-byte copy of the contents of the disk in an image file, or straight onto another disk. Just clone your current disk to the new one, and you should be good to go! :)

thiemster 04-05-2010 06:42 PM

Yes, it is a very frequent problem that started about a month ago and has not stopped since. So I might as well get a new hard drive (or computer, as the ram and processor are pretty pathetic on this one). Thanks, though.
And yeah, I already have a backup. But I'll investigate clonezilla if that ever happens again.

thiemster 04-08-2010 07:47 PM

It actually seems to have gone away since install Arch Linux 2 days ago. Before that, I had experienced this error every few hours, but since install Arch I haven't experienced it at all. I'm pretty sure this has to do with switching from ext4 back to ext2/ext3. I think it was the ext4 filesystem, as apposed to my hard drive itself, that was causing the error.

All times are GMT -5. The time now is 11:36 PM.