LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (https://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   EXT-fs error (device hda3) in start_transaction: Readonly filesystem (https://www.linuxquestions.org/questions/linux-hardware-18/ext-fs-error-device-hda3-in-start_transaction-readonly-filesystem-371169/)

kiwibird 10-09-2005 06:58 AM

EXT-fs error (device hda3) in start_transaction: Readonly filesystem
 
Lately my laptop harddrive has been getting errors or something, with all the terminals showing this repeatedly:

EXT-fs error (device hda3) in start_transaction: Readonly filesystem

I can log in to terminals, ls and stuff, use X but not start new programs, and even log off and reboot (with some things failing due to the readonly filesystem, but rebooting all the same). On startup it'll do a forced hd-check, then give me "UNEXPECTED INCONSISTENCY RUN fsck MANUALLY", i run fsck and hit y for to fix some orphaned inode thingies, ctrl+d to reboot and it works normally again. This has happened about 3 times the last week, once within an hour of startup with just the last.fm-player and firefox running, once I discovered it like that after it'd been on for about a day. I've had it happen some months earlier, but I have no idea what causes it. Google.com/linux just showed me pages saying "obscure kernel error" ( http://seclists.org/lists/linux-kern.../May/1084.html ) and heavy-duty-geek-sites like that, not much help to me.

uname -a gives:
Linux kiwishiba 2.6.10-5-386 #1 Fri Sep 23 14:13:55 UTC 2005 i686 GNU/Linux

and /etc/fstab has my harddrive as:
/dev/hda3 / ext3 defaults,noatime,errors=remount-ro 0 1
/dev/hda1 /boot ext3 defaults,noatime 0 2
/dev/hda5 none swap sw 0 0

Anyone got a clue what to do? Hope I don't have to scrap this HD, now that I finally got a working install heh...

free_ouyo 10-10-2005 03:37 PM

EXT-fs error (device hda3) in start_transaction: Readonly filesystem
 
Hello,

Maybe you have a deffect HD that cause the errors on the FS. How old is you HD ?
You can also try to upgrade the kernel if you think it's a kernell generated error. I currently use 2.6.11.4-21.9-default and don't have problems.

--
free_ouyo

kiwibird 10-21-2005 11:15 AM

My harddrive is barely half a year old, it really doesn't seem likely that it'd fail, especially considering how little it's been used. I upgraded the kernel now, to 2.6.12-9-386, and so far I've had to reboot once due to read-only-errors, but I didn't get the "EXT-fs error (device hda3) in start_transaction: Readonly filesystem"-message showing on the text-terminals this time, only got some errors in X saying things were read-only whenever I tried doing stuff requiring writing. Really weird - I can't tell what's making the disk hickup like that and turn read-only on me.


All times are GMT -5. The time now is 07:38 AM.