-   Linux - Hardware (
-   -   Ethernet connection not detected (

rnorth6920 05-14-2004 08:32 AM

Ethernet connection not detected
I just set up my 2nd system with linux 9.0, and it will not detect the onboard LAN or the PCI card that I put in. I've even tried to uninstall and reinstall linux and that didnt work.

I'm very new to linux and any help is appreciated.

The first system I set up with linux is working fine and has no problems.

fransemail 05-14-2004 08:42 AM

check ifconfig
please post more specific information. ( for example post output of 'ifconfig' and 'ifconfig up eth0' ). First of all are network card modules loaded?

rnorth6920 05-14-2004 09:00 AM

Re: check ifconfig

Originally posted by fransemail
please post more specific information. ( for example post output of 'ifconfig' and 'ifconfig up eth0' ). First of all are network card modules loaded?
the ipconfig gives me this info:

LInk encap: Local Loopback
inet addr: Mask:
RX packets:371 errors:0 dropped:0 overruns:0 frame:0
TX packets:371 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:24951 (24.3Kb) TX bytes:24951 (23.3Kb)

I dont really know what you mean by the network cards being loaded.

fransemail 05-14-2004 10:28 AM

loopback device
this is only loopback ( device
try to ifconfig up eth0

it's possible that your card module is not loaded

rnorth6920 05-14-2004 10:38 AM

how do you go about loading you card module?

fransemail 05-14-2004 10:43 AM

for example for via-rhine you must run

modprobe via-rhine

after this setup network interface

ifconfig eth0 [YOUR IP] netmask gw [YOUR GATEWAY IF YOU HAVE]

if yiu have a gw you must set routing tables by route!

michaelk 05-14-2004 03:45 PM

Which linux 9? Mandrake, Redhat... etc
post the output of:

brighamr 05-18-2004 12:19 AM

I have the same problem. I am on Redhat 9 and am trying to install a D-Link DFE-690TXD on my toshiba laptop. Here is what I get:

00:00.0 Host Bridge: Toshiba America Info Systems 601 (rev 11)
00:04.0 VGA compatible controller: Chips and Technologies F65550 (rev 45)

any suggestions?

rnorth6920 05-24-2004 08:09 PM

when i type in does show both of my ethernet devices.

they are listed second and third to last:

00:0e.0 Ethernet controller: National Semiconductor Corporatio Co., Ltd.
Dp83815 (MacPhyter) Ethernet Controller

00:12.0 Ethernet controller: Realtek Semiconductor Co.,
RTL-8139/8139C/8139C+ (rev 10)

sorry its taken so long to respond... please help..


LavaDevil94 05-24-2004 08:31 PM

Are they wireless devices? If they are, try the Madwifi drivers:

rnorth6920 05-25-2004 05:24 AM

No they arent wireless. I tried to add the realtek ethernet manually, it even has it listed in the ethernet hardware list. But once i try to add it, it says it is not connected. It says the same thing when the system is starting up.......something like the process is delayed because its not present.

rnorth6920 05-26-2004 08:33 PM

anyone else?

All times are GMT -5. The time now is 12:29 PM.