-   Linux - Hardware (
-   -   Ethernet Adsl Modem Driver Problems And Install Problems... (

akhilnair 04-15-2004 09:36 AM

Ethernet Adsl Modem Driver Problems And Install Problems...

i jes received madrake 9.2 and installed it without much trouble.
Howevr i have a USB ADSL MODEM which is not recognized by MANDRAKE 9.2.

I am using this modem that runs in wondows using a globespan virata ADSL driver, it uses Encapsulation:RFC2364

Now the problem i am facing is that mandrake does not recognize / detect the ADSL modem.

Hence i cannot get online using linux, i have to keep switchign back to windows to access the internet, hence even if there is a driver available to download.. how can i download it using wondows if linux is on a anopther partition??

and how does the installation of this driver work??
please am real newie at this.... and very eager to do away with BILL GATES~!!!

-----I AM RUNNING-----
Intel celeron 1.7 GHz
40 GB HDD with 10 separate partition for LINUX
Mandrake 9.2 OS


Proud 04-15-2004 03:11 PM

Have you tried looking online for mentions of a linux driver or others with that modem working?

What format's your windows partition? You should be able to mount it and at least read from it, eg copy downloaded drivers over.

akhilnair 04-15-2004 10:53 PM

hey proud,

i have found this eciadsl site that has its own driver developed but after configuring teh driver... it doesnt seem to have downloaded what they mention as ARK SOFTWARE.. which i think makes the connexion...

the site is

Also i am using win98.. so am guessing its a FAT32 format.. i dunno reeally.. abny help would be great!!

tricky_linux 04-16-2004 04:55 PM

what chipset was your modem?
i assume you don't know.
you should download at
then extract it using file roller to your home directory.
open up an terminal and type chmod a+x scanModem
next type "./scanModem" then that will gave you lots of information about your modem. please post that and i will have an idea if you found the right driver or not.

akhilnair 04-17-2004 06:22 AM

hi tricky linux,

one small very basic and almost dumb doubt.. if i download this in windows (whihc i am using to get online now) how do i get it to linux if its bigger thana floppy size??

please explain in howto commandline inputs... thanks o much

tricky_linux 04-17-2004 03:46 PM

the files is only around 40kb when it's compressed. it's small enough for a floppy disc.
Try solve it yourself, before waste time.

akhilnair 04-18-2004 03:45 AM

hey again tricky linux,

ok i downloaded it.... and tried CHMOD

but it doesnt work...

it says, bad command... cannot find file or directory


tricky_linux 04-18-2004 08:50 PM

sorry, for got to tell you
you have to extract the file first. use file roller.
then the extracted file should be "scanModem" and you could run it "./scanModem"

akhilnair 04-19-2004 12:28 PM

HYE tricky!!

ok.. i tried extracting.. it but to which directory??
anywys i think i foundout that my modem runs off a globespan chipset.. mostly ti is GS7070...

so now what do i do??... pls advise!!


tricky_linux 04-20-2004 07:13 AM

you extract it to your home directory which would be
"yourusername" is your user name.
did you check wether there is a driver thats on the modem's installation cd?
after you extract it just open a teriminal, then do "./scanModem"

akhilnair 04-22-2004 01:40 AM

Hi tricky,
ok confrimation on 2 things, my modem runs of a globespan GS7070 chipset,
the installation CD (for windows) has a driver for it.. but i am guessign that works only for windows...
if however u think this same CD can work for mdk9.2 pls do tell me how!! as in if i have to make mdk9.2 search for the driver then how do i do that??

warm regards

tricky_linux 04-23-2004 04:07 PM

download at
to /home/"yourusername"
and install it as root
you login as root by "su -"
type passwd
#cd /home/"yourusername"
#rpm -Uhv eciadsl-usermode-0.9-1.i586.rpm

that should get your dsl modem working

aLexus 11-28-2004 08:19 AM

Hi, i have problem like your. Help me plz..:cry:

scanModem writing:

[alexey@langames modem]$ chmod a+x scanModem
[alexey@langames modem]$ ./scanModem

ONLY use scanModem downloaded as:

./scanModem should ONLY be run within a Linux/UNIX partition.
If within a MicroSoft/DOS partition, abort with Ctrl-C now !!!
Copy scanModem.gz to your Linux partition and restart.

./scanModem: line 1: gcc: command not found

Please browse the folder Modem/ containing the following files:
1stRead.txt DriverCompiling.txt General.txt ModemData.txt Rational.txt SoftModem.txt Testing.txt UNSUBSCRIBE.txt

I don't now my chipset ver., but i find my modem by PID & VID, it is here: my modem
What can i do???
I find this, but i don't sure..

P.S. I have Mandrake 10.1 & my modem is USB!

All times are GMT -5. The time now is 08:25 PM.