LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 09-25-2004, 07:19 AM   #1
linuxhippy
Senior Member
 
Registered: Sep 2004
Location: Philadelphia, PA
Distribution: Xubuntu, Mythbuntu, Lubuntu, Picuntu, Mint 18.1, Debian Jessie
Posts: 1,207

Rep: Reputation: 47
Question eth0 doesn't work now?


I have been using Linux for a while and have 3 Linux distros on my system. Two of them automatically use GNOME or KDE on bootup and shutdown, and my eth0 DSL works fine with them. The third distro is a new install of Slackware 10 with Fluxbox as my GUI. With Slackware, my eth0 works fine on the first boot out of Fluxbox. When I reboot, the eth0 connection disappears in Slackware.

Could how I shutdown effect eth0?

I have shutdown from the console after exiting Fluxbox using the shutdown command and the halt command. I've also tried the key combo CTRL-ALT-DEL
 
Old 09-25-2004, 08:41 PM   #2
enyawix
Member
 
Registered: Sep 2003
Location: ky
Distribution: gentoo
Posts: 404

Rep: Reputation: 32
type lsmod is the driver loaded

type lspci -v and post so i can help you more
 
Old 09-26-2004, 03:40 PM   #3
linuxhippy
Senior Member
 
Registered: Sep 2004
Location: Philadelphia, PA
Distribution: Xubuntu, Mythbuntu, Lubuntu, Picuntu, Mint 18.1, Debian Jessie
Posts: 1,207

Original Poster
Rep: Reputation: 47
Wow-I like those commands! My eth0 is working now-I reinstalled Slackware 10. I must have messed something up installing some files. I figure I'll just leave Slack the way it installed from cd-no changes.
 
Old 09-28-2004, 03:02 PM   #4
linuxhippy
Senior Member
 
Registered: Sep 2004
Location: Philadelphia, PA
Distribution: Xubuntu, Mythbuntu, Lubuntu, Picuntu, Mint 18.1, Debian Jessie
Posts: 1,207

Original Poster
Rep: Reputation: 47
Slackware won't get on the internet again (my other 2 Linux distros do). I have a Netgear FA311 on eth0. I executed lsmod and lspci and both displayed that natsemi (my eth0) is getting loaded.

lsmod:

Module Size Used by Not tainted
snd-pcm-oss 37736 0 (unused)
snd-mixer-oss 12504 0 [snd-pcm-oss]
snd-sb16 6284 0
snd-pnp 3168 0 [snd-sb16]
isa-pnp 30736 0 [snd-sb16 snd-pnp]
snd-sb16-dsp 5808 0 [snd-sb16]
snd-pcm 56072 0 [snd-pcm-oss snd-sb16-dsp]
snd-page-alloc 6328 0 [snd-pcm]
snd-sb16-csp 14924 0 [snd-sb16]
snd-sb-common 6980 0 [snd-sb16 snd-sb16-dsp snd-sb16-csp]
snd-opl3-lib 5892 0 [snd-sb16]
snd-hwdep 4804 0 [snd-sb16-csp snd-opl3-lib]
snd-timer 13604 0 [snd-pcm snd-opl3-lib]
snd-mpu401-uart 3200 0 [snd-sb16]
snd-rawmidi 12740 0 [snd-mpu401-uart]
snd-seq-device 3888 0 [snd-opl3-lib snd-rawmidi]
snd 30852 0 [snd-pcm-oss snd-mixer-oss snd-sb16 snd-sb16-dsp snd-pcm snd-sb16-csp snd-sb-common snd-opl3-lib snd-hwdep snd-timer snd-mpu401-uart snd-rawmidi snd-seq-device]
soundcore 3396 6 [snd]
keybdev 2052 0 (unused)
mousedev 4212 0 (unused)
hid 21220 0 (unused)
input 3200 0 [keybdev mousedev hid]
uhci 24444 0 (unused)
usbcore 59308 1 [hid uhci]
natsemi 15840 0
crc32 2880 0 [natsemi]
ide-scsi 9328 0
agpgart 43940 0 (unused)


lspci -v:
00:00.0 Host bridge: VIA Technologies, Inc. VT82C693A/694x [Apollo PRO133x] (rev 44)
Flags: bus master, medium devsel, latency 0
Memory at d8000000 (32-bit, prefetchable) [size=64M]
Capabilities: [a0] AGP version 1.0

00:01.0 PCI bridge: VIA Technologies, Inc. VT82C598/694x [Apollo MVP3/Pro133x AGP] (prog-if 00 [Normal decode])
Flags: bus master, 66Mhz, medium devsel, latency 0
Bus: primary=00, secondary=01, subordinate=01, sec-latency=0
Memory behind bridge: d0000000-d7ffffff
Capabilities: [80] Power Management version 2

00:07.0 ISA bridge: VIA Technologies, Inc. VT82C596 ISA [Mobile South] (rev 12)
Subsystem: VIA Technologies, Inc. VT82C596/A/B PCI to ISA Bridge
Flags: bus master, stepping, medium devsel, latency 0

00:07.1 IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/C/VT8235 PIPC Bus Master IDE (rev 06) (prog-if 8a [Master SecP PriP])
Flags: bus master, medium devsel, latency 32
I/O ports at e000 [size=16]

00:07.2 USB Controller: VIA Technologies, Inc. VT6202 [USB 2.0 controller] (rev 08) (prog-if 00 [UHCI])
Subsystem: VIA Technologies, Inc. (Wrong ID) USB Controller
Flags: bus master, medium devsel, latency 32, IRQ 10
I/O ports at e400 [size=32]

00:07.3 Host bridge: VIA Technologies, Inc. VT82C596 Power Management (rev 20)
Flags: medium devsel

00:09.0 Serial controller: 5610 56K FaxModem 56K FaxModem Model 5610 (rev 01) (prog-if 02 [16550])
Subsystem: 5610 56K FaxModem: Unknown device 00d3
Flags: medium devsel, IRQ 11
I/O ports at e800 [size=8]
Capabilities: [dc] Power Management version 2

00:0f.0 Ethernet controller: National Semiconductor Corporation DP83815 (MacPhyter) Ethernet Controller
Subsystem: Netgear FA311 / FA312 (FA311 with WoL HW)
Flags: bus master, medium devsel, latency 32, IRQ 9
I/O ports at ec00 [size=256]
Memory at dd000000 (32-bit, non-prefetchable) [size=4K]
Expansion ROM at <unassigned> [disabled] [size=64K]
Capabilities: [40] Power Management version 2

01:00.0 VGA compatible controller: S3 Inc. 86c368 [Trio 3D/2X] (rev 02) (prog-if 00 [VGA])
Subsystem: CardExpert Technology: Unknown device 8888
Flags: bus master, medium devsel, latency 32, IRQ 11
Memory at d0000000 (32-bit, non-prefetchable) [size=64M]
Expansion ROM at <unassigned> [disabled] [size=64K]
Capabilities: [dc] Power Management version 1
Capabilities: [80] AGP version 1.0

Last edited by linuxhippy; 09-28-2004 at 03:03 PM.
 
Old 09-28-2004, 05:31 PM   #5
enyawix
Member
 
Registered: Sep 2003
Location: ky
Distribution: gentoo
Posts: 404

Rep: Reputation: 32
type uname -a
it will show what kernel is running

? = the kernel number from uname -a
type ls --color /lib/modules/?/kernel/drivers/net

look for you network driver

than type modprobe module name

now to get on line!

type dhcpcd eth0
 
Old 09-28-2004, 07:57 PM   #6
J.W.
LQ Veteran
 
Registered: Mar 2003
Location: Boise, ID
Distribution: Mint
Posts: 6,642

Rep: Reputation: 85
linuxhippy -- if natsemi is the module your NIC needs and it is being loaded, then it's possible that you just need to bounce your eth0 interface. Try running these commands (as root), which will list your eth0 settings, then bounce eth0.
Code:
ifconfig
ifconfig eth0 down
ifconfig eth0 up
ifconfig
The purpose of the 4th command is to see whether eth0 has been assigned an IP address. If it has, then you should be all set to surf -- J.W.
 
Old 09-28-2004, 08:24 PM   #7
enyawix
Member
 
Registered: Sep 2003
Location: ky
Distribution: gentoo
Posts: 404

Rep: Reputation: 32
dhcpcd eth0


will look for a dhcp server


but you can do this

ifconfig 192.168.0.2 eth0

route add defalt gw 192.168.0.1

that is if you have a gateway at 192.168.0.1

than edit /etc/resolv.conf like this

nameserver 192.168.0.1
domain home
 
Old 09-29-2004, 05:16 PM   #8
linuxhippy
Senior Member
 
Registered: Sep 2004
Location: Philadelphia, PA
Distribution: Xubuntu, Mythbuntu, Lubuntu, Picuntu, Mint 18.1, Debian Jessie
Posts: 1,207

Original Poster
Rep: Reputation: 47
Exclamation this is strange....

this is strange....sometimes my DSL work in Slack and sometimes it doesn't work in Slack (always works in my other Linux Distros). I think it's because my pc doesn't shutdown all the way by itself from cli. Eth0 will work till I power it down. When it's done the shutdown processes and the red light on my harddrive goes out, then I hold in the power button till the pc shuts off. When I power it back up, eth0 doesn't work in Slack till I boot into another distro and connect. Then it works in Slack when I reboot.

ifconfig only displays lo till I take it up and down (like J.W. suggested), but I don't get the server assigned dhcp addy. Here what I get:

eth0 Link encap:Ethernet HWaddr 00:40:F4:4C:F0:80
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:13 errors:0 dropped:0 overruns:0 frame:0
TX packets:21 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:829 (829.0 b) TX bytes:4731 (4.6 Kb)
Interrupt:9 Base address:0xe000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

When I type dhcpcd eth0 my pc freezes till I press CTRL-C

When I assign a previously assigned IP addy, I get an error.

Any more suggestions?
 
Old 09-29-2004, 05:55 PM   #9
J.W.
LQ Veteran
 
Registered: Mar 2003
Location: Boise, ID
Distribution: Mint
Posts: 6,642

Rep: Reputation: 85
It may be that the DHCP daemon process isn't running. Try this
Code:
dhcpcd -r eth0
That will restart the DHCP process, and should assign an IP address to eth0. As you've already indicated, the system may just sit there a while, apparently doing nothing. If you don't get returned to the prompt, hit Ctl-C. Check ifconfig again, and you should see an IP address associated with eth0; if not, try bouncing eth0 again using the down and up options. (Side note: attempting to reuse a previous IP address is sure to fail under DHCP, due to DHCP assigning addresses dynamically, meaning randomly. The only way you could successfully reuse an existing address would be if you had a static IP connnection, in which case that would be the one and only address you could ever use.)

In any event, I'm a bit surprised that you're finding it necessary to run these steps manually - my Slack installation the best-performing and most stable thing I've ever used, and I'm not sure what might be causing this periodic conflict that you seem to be encountering. Good luck with it -- J.W.
 
Old 09-29-2004, 07:00 PM   #10
linuxhippy
Senior Member
 
Registered: Sep 2004
Location: Philadelphia, PA
Distribution: Xubuntu, Mythbuntu, Lubuntu, Picuntu, Mint 18.1, Debian Jessie
Posts: 1,207

Original Poster
Rep: Reputation: 47
that did it!!

Thanx J.W.-the command you suggested worked after about 30 seconds of silence:

dhcpcd -r eth0

I'm now online with Slack (hopefully for good)!
 
Old 09-29-2004, 07:14 PM   #11
linuxhippy
Senior Member
 
Registered: Sep 2004
Location: Philadelphia, PA
Distribution: Xubuntu, Mythbuntu, Lubuntu, Picuntu, Mint 18.1, Debian Jessie
Posts: 1,207

Original Poster
Rep: Reputation: 47
Question dhcpcd every time I boot?

I shutdown to see if my eth0 settings would keep and they didn't. When it restarted I typed:

dhcpcd -r eth0

After I sall from ifconfig that eth0 wasn't present. After two tries it works again. How can I save these eth0 settings so that my ethernet card and dynamic IP addy is set up when my pc boots?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
eth0 starts [ ok ] but won't work... perl4ever Linux - Networking 8 09-03-2004 05:49 PM
Problem withInternet, DHCP, connect with eth0 down work, connect with eth0 up not zowey Linux - Networking 1 03-12-2004 10:05 AM
getting eth0 to work madrake ferretmanus Linux - Networking 3 02-10-2004 03:48 AM
My eth0 doesn't work CONWON Linux - Hardware 2 10-25-2003 12:54 AM
eth0 doesn't work when eth1 is up Amir Linux - Networking 4 09-08-2003 08:57 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 12:27 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration