LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (https://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   EsounD (https://www.linuxquestions.org/questions/linux-hardware-18/esound-199352/)

imonfya 06-30-2004 01:02 AM

EsounD (Gaim\XMMS)
 
a couple of weeks ago I recently installed EsounD to work with gaim, a couple of days ago it all of sudden stopped working. Somehow I got it work again, but then today when I booted up my system sounds and gaim doesn't work anymore, but when I play media files and sound test my sound works fine. Any suggestions?

I have a Sound Blaster 16

Also when I run XMMS with the esound driver and try to play an mp3 file I get the error:

"Please check that your sound card is configured properly, You have the corrent output selected, any other programs are blocking the sound card"

OSS sound drivers work fine under XMMS but I haven't been able to configure them under gaim.

motub 06-30-2004 06:23 AM

You rebooted, thereby stopping esd... do you have it set to run on startup? Are you in fact using GNOME (which would start it on login if you have that set in the GNOME Control Center)? If not, what window manager or DE are you using?

I suspect that esd is not running, you can run it manually by typing esd into a terminal.

We can worry about getting it to run on startup when we know more.

imonfya 06-30-2004 09:58 AM

When I run esd at the terminal it says "no alsa cards found"

I'm running GNOME

motub 06-30-2004 10:12 AM

What kernel are you running? Could you post the output of lsmod?

imonfya 06-30-2004 01:14 PM

I'm running 2.4.20-31.9 as my kernel and lsmod command isn't found

imonfya 07-01-2004 12:26 AM

bump

LavaDevil94 07-01-2004 12:30 AM

Try running lsmod as root instead.

imonfya 07-01-2004 01:01 AM

nope, command still not found. Should I try reinstalling ALSA?

motub 07-01-2004 06:07 AM

You could, I suppose, but you've got bigger problems than that if a base system applicaton like lsmod is not installed on the system.

How did you install ALSA in the first place? Did you use RPMs from http://freshrpms.net (or other RedHat repository), or did you compile it from source? Can you reconfigure ESD in the GNOME Control Center to use OSS instead?

imonfya 07-05-2004 03:35 PM

i think i downloaded ALSA, and yes I can use OSS but I cant get my GNOME sound schemes to work with it, and same goes with gaim


All times are GMT -5. The time now is 05:57 PM.