-   Linux - Hardware (
-   -   Epson Stylus DX7400: problems printing in colour (

FSHero 06-02-2008 04:05 AM

Epson Stylus DX7400: problems printing in colour
Please note: this forum post was first posted in the Ubuntu forums at, but I thought I would also post it here so I may gain 'access' to a wider audience. Also, for some reason, I cannot post attachments to this forum; please refer to the Ubuntu forums for them.

I have a problem with my Epson Stylus DX7400 printer. I am using Kubuntu Gutsy (7.10) amd64. When installing my printer using K Menu --> System Settings --> Printers --> Add --> Add printer/class, I could not see my printer in the list. However, I decided to try the Epson DX4800 driver, thinking that it is the most recent printer listed!

For reference: in the Printer settings, the following details are listed under driver details (Properties tab --> Driver on LHS):
Manufacturer: Epson
Printer model: Eps.S. DX4800 gutenpr.-ijs.5.0
Driver info: Epson Stylus DX4800 Foomatic/gutenprint-ijs.5.0

This worked to a limited extent; the black and white output is fine. However, the colour output is slightly incorrect. When I print a printer test page, the colours on the left-hand "colour-wheel" are not continuous; rather, each colour has a gradient. I know that this is not supposed to happen, as I used to have an HP Deskjet 950C whose colour output was a single colour for each of the colours on the "colour wheel" (R K Y M C W B G). I have facetiously scanned with the printer's built in scanner the printout of the test page!
printer-test-page-epsonstylusdx7400-gutsy.jpg (full page)
colour-wheel-epson.png (losslessly-compressed picture of the colour wheel)

The colour problem also occurs with other documents, e.g. those printed from Firefox or However, there are absolutely no colour problems whatsoever when printing from Windows Vista, using the Epson drivers that are on the driver CD that came with the printer.

Hence... how can I fix this problem to get colour output back to normal?

I would have thought that using the "official" DX7400 driver from Epson's website would solve the problem, but I have not been able to install it successfully. I have tried to compile the driver from their website ( then go to the "Image Scan! for Linux & Photo Image Print System Lite" option and click on the option: Epson Stylus CX7300/CX7400/DX7400). Running ./configure seems to be fine, but when I run make, it seems to fail. I have attached the console output as a text file. File:

(Please note: I don't have any prior compiling experience; it was really just 'type and pray' for me!)

Thanks to everyone in advance!

dwpbike 02-16-2009 01:40 PM

epson stylus nx400 experience
sorry for the tardy response - noticed this hanging here while researching what may be a photo paper problem. have you tried simply configuring your printer as postscript? after googling (i think ubuntu forum was most helpful), i went with defining a postscript printer in cups (sorry, i don't cap). only workaround (so far) i have had to do is use guten print in gimp when printing local file (so, no gthumb).

FSHero 02-17-2009 06:04 AM


Thanks for replying! I thought my post was completely forgotten!

I'll give your suggestion a try. Do you have a link that describes setting up the printer as postscript?


dwpbike 02-17-2009 08:40 PM

i think this is the one
(couldn't get the "link" button to insert correctly) the ubuntu forum helped quite a bit in understanding the ppd files and cups. http://localhost:631/ should get you up on cups. what i remember most in the config is that when you get to driver name, you ignore and insert ppd file which this japanese company has created.

H_TeXMeX_H 02-18-2009 04:36 AM

It say here the various drivers you can use:
If you have a problem installing one of the drivers please post what you did and the exact error that came up (I don't really want to register for the Ubuntu forums, and these forums now allow attachments).

Also note that you should have used the CX4800 drivers NOT the DX4800 drivers.

All times are GMT -5. The time now is 01:48 AM.