LinuxQuestions.org

LinuxQuestions.org (http://www.linuxquestions.org/questions/index.php)
-   Linux - Hardware (http://www.linuxquestions.org/questions/forumdisplay.php?f=18)
-   -   epson printer no longer accessible across network (http://www.linuxquestions.org/questions/showthread.php?t=4175433151)

samhill5215 10-19-2012 09:03 PM

epson printer no longer accessible across network
 
I have an Epson Workforce 1100 attached via usb to my Ubuntu 10.10 network server (text only, no gui). Printing from the server works. I have both windows and ubuntu computers on the network. Both used to print to the epson but no longer. Not sure why. I installed the printer with cups and it is shared so I don't think it's a permissions problem. The ubuntu machines don't even find the printer anymore. The windows machines find the printer but can't access it. Any ideas anyone?

frankbell 10-21-2012 08:16 PM

Can the other machines on your network access the server to browse folders and files? In other words, is the network working except for the printer?

samhill5215 10-21-2012 08:35 PM

Yes, everything works fine otherwise. In fact I manage the server with webmin and when I wrote I can print from the server I did it with cups from a client.

frankbell 10-21-2012 09:46 PM

Have there been any recent changes to the networked machines, such as software updates?

Take a look at the logs in /var/log/cups on the server and on the Ubuntu client. One machine or the other might reveal something about what's happening to your print jobs.

samhill5215 10-22-2012 05:07 AM

Both windows and ubuntu machines are regularly updated. As for the logs error_log was last updated on the 16th and it's empty. Access_log and page_log were last updated when I successfully sent a job to the printer a minute ago. I did it through a windows client. The confusing thing is that the epson status monitor on that same machine (the gui that shows ink level etc) fails to communicate with the printer and this is what led me to believe that the windows machines had lost the printer. So I can print from at least one windows machine despite the fact that the status monitor fails to find the printer. I tried printing from a linux machine and the job was held for authentication. I used my admin user name and password but that failed as well. More on that later, I have to go now.

samhill5215 10-22-2012 05:48 PM

Back on task. I believe I've narrowed it down to an authentication issue for the linux machines. The printers.conf file in /etc/cups contains the line:
AuthInfoRequired username,password
for the epson printer. None of the other printers have it. I can stop cups, remove the line or comment it out, restart cups and as soon as a job is issued the line reappears. Using the admin user name and password has no effect. The line reappears only when a job is issued. At this point I'm not sure where else I can look. There is nothing related to authentication in the printer properties dialog. I guess I have to dig deeper into cups but any advice would be more than welcome.

samhill5215 10-22-2012 06:45 PM

After some surfing I found a workaround. It's not perfect but it works. By default printers are set up to use samba. I found a post from 2007 that described an identical situation and the last comment might as well have been mine. This user set up his printer with the ipp interface instead of smb and it worked for me too. That doesn't explain the authentication issue which affects the epson only because all my other printers work just fine from the linux machines. Here's the link:
http://ubuntuforums.org/showthread.php?t=1211404

frankbell 10-22-2012 07:47 PM

Nice piece of detective work. You are way ahead of me.

Maybe someone more knowledgeable will stumble over this thread and offer some ideas on why the sudden need to authenticate.

samhill5215 10-22-2012 09:11 PM

Thanks for your input. It opened new avenues for me. I think you're right about an update screwing things up but as to which it's impossible and counterproductive to determine. For all I know it may even be some incompatibility between the server which is running 10.10 and the clients which are running 12.04 lts. I'm still on the trail and will continue to post on this thread what I discover.

samhill5215 11-06-2012 06:40 PM

The final solution came about via a totally unrelated avenue. After performing an upgrade from 10.10 to 11.04 to 11.10 to 12.04 the system hung after the last upgrade and I was forced to reinstall from scratch. I had no problem reinstalling the epson with cups. There were a couple of other fixes unrelated to the printer as well. I am now running 11.10 and will reattempt the upgrade to 12.04 when the server has a down day in case it hangs again.


All times are GMT -5. The time now is 02:20 PM.