LinuxQuestions.org

LinuxQuestions.org (http://www.linuxquestions.org/questions/index.php)
-   Linux - Hardware (http://www.linuxquestions.org/questions/forumdisplay.php?f=18)
-   -   Epson Perfection 350 Scanner driver will not recognize the scanner (http://www.linuxquestions.org/questions/showthread.php?t=4175432142)

Mikech 10-14-2012 09:47 AM

Epson Perfection 350 Scanner driver will not recognize the scanner
 
I had previously posted here but the scanner suddenly began to work so I listed it solved. I had not needed the scanner so I unplugged it. Today I needed it but the driver won't recognize it.

The operating system knows its there:
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 008 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 002: ID 05e3:0608 Genesys Logic, Inc. USB-2.0 4-Port HUB
Bus 002 Device 003: ID 04b8:012f Seiko Epson Corp. Perfection V350 (GT-F700)
Bus 002 Device 004: ID 046d:c529 Logitech, Inc. diNovo Keyboard for notebooks

Also dll.conf has the driver listed.

The driver worked and now it doesn't and the only difference is that I had the scanner unplugged for a while. Its not the scanner or the cable because it works just fine in Windows despite being unpluggeg from that machine for a year.

I have no idea how to get software to recognize a USB device on a LINUX machine. On a Windows machine it just works every time so I have never had to learn anything about it.

pdc_2 10-14-2012 01:52 PM

allow access to Epson Perfection Scanner
 
can I suggest you create a file in the rules.d folder so your system allows access to the scanner

Quote:

sudo gedit etc/udev/rules.d/epson/75-epson-scanner.rules
........that should open up/create a file called 75-epson-scanner.rules

.....into it if you paste

Quote:

#Epson Perfection 350 Scanner
ATTR{idVendor}=="04b8", ATTR{idProduct}=="012f7", MODE="666"
if you then save and close the file; and try a reboot: any joy?

Mikech 10-23-2012 10:33 PM

Thank you
 
First off I want to apologize for not responding. I have been on travel for work and I do not take a laptop with me nor do I use computers in hotels (can't tell where they have been!).

Thank you very much for your help. I tried what you suggested but it made no difference.

I do want to rant about "udev" though! How in the world is anybody supposed to know about that? There is no mention of it in any of my textbooks, or even my CompTIA exam study guide which is 778 pages. I took a college course in LINUX and there was no mention of it. Of course none of these texts or the course tells you how to get a driver to work except in very superficial ways. For someone with 40 years experience programming and using just about every operating system known to man, it is emnbarrassing to have to ask for help!! The fact that udev is a "secret" and not mentioned in about 2000 pages of LINUX books really makes me angry.


I took the scanner to my Windows 7 machine and it works great so thats where it will stay. LINUX is still not ready for a production world. Not even Mint. I did get my security camera to work with minimal fuss though so its not a complete loss. VERY disappointing not to be able to use my scanner (and I am not buying a new one) on this machine.

But thanks again for taking the time to help a newbie (to LINUX). I really appreciate your generosity. One question though. How did you learn about "udev?" Am I just reading the wrong textbooks?

pdc_2 10-24-2012 02:56 AM

you have obviously got a wealth of experience and expertise; and a very structured approach to learning; you ask how I hear about things like udev? It would be from a very unstructured approach; reading forums; .......using google A LOT !!

in linux, the SANE project http://www.sane-project.org/ provides support for scanners

They have thorough documentation: http://www.sane-project.org/docs.html

...and a FAQ page: http://ljm.home.xs4all.nl/SANE-faq.html

eg I wondered if you were having what is termed a "permissions" issue, where only root has access

http://ljm.home.xs4all.nl/SANE-faq.html#48

I think with your rich background you have all the skills and abilities to get this scanner problem sorted; and enjoy the experience

There are two commands to look for a scanner

Quote:

sane-find-scanner
and

Quote:

scanimage -L
........as already quoted above: http://ljm.home.xs4all.nl/SANE-faq.html#48

____________________________________________________________________________________________________ ________

I now see you have posted before

http://www.linuxquestions.org/questi...canner-942184/

I wonder what

Quote:

sudo dpkg -l | grep iscan
gives......if you COPY and PASTE the command in and the same back here........the | you may well recognise as a pipe command typed as shift\

.........and just going over things

I myself would go here if I was looking for Epson drivers...........

http://download.ebz.epson.net/dsc/se...search/?OSC=LX

for Epson linux drivers...........

Epson say install the data first so that should be

Quote:

iscan-data_1.18.0-1_all.deb
and then seems like you are using 64bit Mint...............

Quote:

scan_2.29.1-5~usb0.1.ltdl7_amd64.deb
...........as the ltdl7 is for more recent distros....................

and you said you have a plugin

Quote:

iscan-plugin-gt-f700_2.1.2-1_amd64.deb
...........so we should be able to sort this if you are willing.......

.....having researched the Epson drivers................. the SANE driver sane-epkowa - SANE backend for EPSON scanners

http://manpages.ubuntu.com/manpages/...-epkowa.5.html

seems uncertain (to me) .............

as SANE lists it as unsupported by them

http://www.sane-project.org/sane-mfgs.html#Z-EPSON

.........I am sorry if this is rambling......... just laying out ideas for discussion

Mikech 10-25-2012 12:09 PM

Thank You Again!
 
My programming and computer experience is with FORTRAN writing health physics applications. I have never programmed at the operating system level (other than writing scripts) which is why I am not expert in this area. I started programming using toggle switches in the early 70's and then moved to teletype machines before we finally moved to punch cards. Your probably too young to remember know about that!

I know about the method of installing the Epson driver and did everything you mentioned and it worked (although I don't understand why). It was challenging and time consuming and I did check that the epkowa file was present. It suddenly just started working after one of my reboots!

The reason I didn't do anything with SANE is because I was using the Epson driver and it worked until I disconnected the scanner. SANE never even occurred to me. I assumed that there must be some simple way to let the driver know the scanner is reconnected. Its not a question of permissions because it worked with the same permissions.

Thank you again for your generosity, but I am not going to try to get the scanner to work. It works on the Windows machine and I can transfer the files if I need to. It just means that I can never get rid of Windows.

This is also my very last post on this forum. It try's to run 45 different scripts on my computer which I will not allow. I don't mind advertising and support that, but running 5 different Google scripts and many, many others; some that are tracking scripts and others that I don't recognize is unacceptable to me and a major security concern. Its a great forum but not worth the risk.

THANK YOU SO MUCH! You are a generous and kind person.


All times are GMT -5. The time now is 04:49 AM.