LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
 
Search this Thread
Old 02-26-2014, 10:29 PM   #1
prkhr4u
LQ Newbie
 
Registered: Oct 2013
Location: Bangalore,India
Distribution: ubuntu 12.04
Posts: 19

Rep: Reputation: Disabled
enable jumbo frames permanently


I want to enable jumbo frames permanently.
Temporarily i am using:
Code:
sudo ifconfig eth0 mtu 8192
and everything is working fine,I have tested it.
But when i reboot,again the mtu size is reset to 1500.

I tried this to permanently set it :
Code:
sudo gedit /etc/network/interfaces
and added the last 6 lines:

//interfaces file
auto lo
iface lo inet loopback

iface eth0 inet static
address 192.168.0.11
network 192.168.0.0
gateway 192.168.0.255
netmask 255.255.255.0
mtu 8192

then I restart networking like this:
Code:
sudo /etc/init.d/networking restart
and reboot my system.
But now I am unable to connect to my network,says "wired network device not managed"

How to correctly enable jumbo frames permanently?
P.s.: I am directly connecting a GigE camera to a GigE network adapter (Intel 82579LM),which is 1000 Base-T compatible.Using ubuntu 12.04 (64 bit)
 
Old 02-27-2014, 01:15 AM   #2
Ser Olmy
Senior Member
 
Registered: Jan 2012
Distribution: Slackware
Posts: 2,225

Rep: Reputation: Disabled
This isn't really a hardware problem, since you were able to successfully alter the MTU using the ifconfig command. The real question here is "where does my distribution store the jumbo frame/MTU setting", but it seems you've found the right file.

It could be as simple as the gateway setting messing thing up. 192.168.0.255 is the broadcast address for the 192.168.0.0/24 network, and cannot possibly be the gateway.
 
Old 02-27-2014, 11:15 PM   #3
prkhr4u
LQ Newbie
 
Registered: Oct 2013
Location: Bangalore,India
Distribution: ubuntu 12.04
Posts: 19

Original Poster
Rep: Reputation: Disabled
I have tried to set the gateway address to my camera's IP (192.168.0.1), but still I am unable to set the mtu size permanently.
Any other suggestions?
 
Old 02-28-2014, 04:28 AM   #4
Ser Olmy
Senior Member
 
Registered: Jan 2012
Distribution: Slackware
Posts: 2,225

Rep: Reputation: Disabled
Why would you try to use an IP camera as a gateway?

But never mind that. Do you still get the same error message? Could you post the output from ifconfig eth0?
 
Old 03-02-2014, 10:34 PM   #5
prkhr4u
LQ Newbie
 
Registered: Oct 2013
Location: Bangalore,India
Distribution: ubuntu 12.04
Posts: 19

Original Poster
Rep: Reputation: Disabled
Here is the output:
//setting mtu size to 8192 and running the camera
Code:
eth0      Link encap:Ethernet  HWaddr 24:be:05:23:97:e2  
          inet addr:192.168.0.11  Bcast:192.168.0.255  Mask:255.255.255.0
          inet6 addr: fe80::26be:5ff:fe23:97e2/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:8192  Metric:1
          RX packets:99637 errors:0 dropped:0 overruns:0 frame:0
          TX packets:225 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:215692740 (215.6 MB)  TX bytes:20203 (20.2 KB)
          Interrupt:20 Memory:fb100000-fb120000
//setting changes permanently in interfaces file>restart>no network found>output:
Code:
eth0	  Link encap:Ethernet  HWaddr 24:be:05:23:97:e2  
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupt:20 Memory:fb100000-fb120000
//removing settings from interfaces file> restart>network connected back to mtu 1500
Code:
eth0      Link encap:Ethernet  HWaddr 24:be:05:23:97:e2  
          inet addr:192.168.0.11  Bcast:192.168.0.255  Mask:255.255.255.0
          inet6 addr: fe80::26be:5ff:fe23:97e2/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:3 errors:0 dropped:0 overruns:0 frame:0
          TX packets:44 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:192 (192.0 B)  TX bytes:8427 (8.4 KB)
          Interrupt:20 Memory:fb100000-fb120000
 
  


Reply

Tags
network, ubuntu 12.04


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] sessions locking using jumbo frames clcbluemont Linux - Networking 3 09-09-2010 03:17 PM
How to set jumbo frames in linux? linuxunix Linux - Newbie 1 03-28-2010 09:07 AM
Jumbo Frames tntcoder Linux - Networking 2 09-03-2007 07:30 AM
Support of Jumbo frames by NIC bzlaskar Linux - Hardware 3 02-22-2007 10:27 AM
GigE 10/100 Jumbo Frames mixing lazlow Linux - Networking 2 06-28-2006 05:28 PM


All times are GMT -5. The time now is 07:45 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration