LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 01-14-2008, 08:47 PM   #1
DragonM15
Member
 
Registered: Sep 2003
Location: USA
Distribution: Slackware (Multiple Versions)
Posts: 455

Rep: Reputation: 31
enable dma on one drive and it disables the other?


Ok, subject might be kinda iffy. Basically this is what I have:

1. Slackware 10.2 Linux Server (by server I mean i am using it as such... ftp, http, mail)

2. Just got a brand new hard drive (320GB Western Digital) for storage purposes. I have a 10 GB HD that stores the Slackware OS itself, and the 320 is mounted as '/home'

3. Immediately after I installed my new drive, I started moving files/folders from my original /home directory onto my new hard drive, and noticed the usual 100% CPU usage signifying that DMA is probably not enabled on my new drive. So I enable it with 'hdparm -d1 /dev/hdb'. I then run 'hdparm /dev/hdb' to ensure everything is as it should be, and it is. Although now I continue moving files and it is still running at 100% CPU, so I check again 'hdparm /dev/hdb' and everything is good, so I check my first hard drive (the one storing the OS on it) and dma is disabled, so i enable it 'hdparm -d1 /dev/hda' and it enables it on my first drive but disables it on my 2nd. and visa versa.

Is there a way to fix this?

Thanks,
DragonM15
 
Old 01-15-2008, 07:49 AM   #2
kilgoretrout
Senior Member
 
Registered: Oct 2003
Posts: 2,842

Rep: Reputation: 326Reputation: 326Reputation: 326Reputation: 326
If might be a hardware problem. It appears that you have the new drive slaved to your old one. That shouldn't cause any problems with dma, however. Do you have the drives jumpered master/slave or cable select and are you using an 80 wire cable or a 40 wire cable? You need an 80 wire cable for udma and with that type of cable you would normally jumper both drives cable select with the slave drive on the middle connector. Older systems do not support cable select and you have to explicitly jumper master/slave but you still have to use an 80 wire cable for dma.

If you have the other ide channel available, moving your new drive to hdc(Secondary - Master)would probably get rid of the problem. If you have an optical drive on that ide channel, try configuring the new drive as master and the optical as slave using an 80 wire cable.

Last edited by kilgoretrout; 01-15-2008 at 07:51 AM.
 
Old 01-18-2008, 06:06 PM   #3
DragonM15
Member
 
Registered: Sep 2003
Location: USA
Distribution: Slackware (Multiple Versions)
Posts: 455

Original Poster
Rep: Reputation: 31
I do have the hard drives master/slave and plugged into the correct plugs (master at the end of the ribbon, slave in the middle, and motherboard at the appropriate opposite end of the cable). The cables are also the correct IDE 40 wire cables. These cables also supprt udma because my new drive runs perfectly fine on udma6, however while the master hard drive is not on dma, it slows my system down. Later tonight I will connect my new drive to the ide1 cable and see if that resolves the issue.

Thank you for your time.
DragonM15

P.S. I noticed some odd entries in my /var/log/messages file regarding hdb (my new 320GB drive) that I will post later, seems I am not currently at my computer.
 
Old 01-19-2008, 03:23 PM   #4
kilgoretrout
Senior Member
 
Registered: Oct 2003
Posts: 2,842

Rep: Reputation: 326Reputation: 326Reputation: 326Reputation: 326
Try jumpering them cable select instead of master/slave if that's how they are currently setup, leaving both drives on the same ide channel.

You can also run Western Digitals's hard drive diagnostic utilities on the drive just to make sure the drive is not defective:

http://support.wdc.com/download/

They come as downloadable isos which you burn as image to a cd-r to create a bootable cd. The dignostics are run off the bootable cd.

Finally, take a look in your bios setup just to make sure your 320GB drive is being properly detected.
 
Old 01-24-2008, 03:34 PM   #5
DragonM15
Member
 
Registered: Sep 2003
Location: USA
Distribution: Slackware (Multiple Versions)
Posts: 455

Original Poster
Rep: Reputation: 31
Alright, I tried putting them on cable select on the same cable, but that didnt help, so I went ahead and put one hard drive on ide0 and the other on ide1 and that fixed the problem completely. Both hard drives have udma enabled and my system is cruising. At least as fast as a 686 can cruise

Thanks for all the help.

DragonM15
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Slackware 12: kernel disables DMA on HDD drives. ErV Slackware 7 07-11-2008 07:07 AM
Can`t enable DMA Sushy Slackware 14 07-09-2006 07:55 PM
Suse 8.2 change my DMA setting on my DVD-R drive to off & IDE DMA MODE NOT SHOWING IT maximalred Linux - General 0 08-23-2003 04:58 AM
How to enable DMA? Piero Linux - Hardware 14 07-21-2003 06:05 AM
sndconfig disables my keyboard (Why? + How to re-enable?) aethereal Linux - General 2 12-16-2001 11:38 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 02:56 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration