LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 06-03-2005, 11:14 PM   #1
festx
LQ Newbie
 
Registered: Jun 2005
Location: Southern NJ
Distribution: Debian (testing)
Posts: 5

Rep: Reputation: 0
eloinput XFree86 4.5.0


Hi all,

Has anyone had any luck with the eloinput driver in XFree86 and an Elo 1725L usb touch screen. I just install XF86-4.5.0 and it is working fine, however I can not get the touch screen to work. Any help is appreciated. I posted a snippet of the config below.

Section "InputDevice"

Identifier "TouchScreen0"
Driver "eloinput"
Option "Device" "/dev/input/event2"

EndSection


Thanks
 
Old 06-04-2005, 02:13 AM   #2
Simon Bridge
LQ Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 198Reputation: 198
Please put yor distro in you profile ("user CP" at top of page)
Show us that USB is working - output of dmesg, lsusb, lsmod and lspci.

Please read the sticky - how to post in this forum.

Though this is actually a good first post.
 
Old 06-04-2005, 07:50 AM   #3
festx
LQ Newbie
 
Registered: Jun 2005
Location: Southern NJ
Distribution: Debian (testing)
Posts: 5

Original Poster
Rep: Reputation: 0
Sorry for my ignorance.

Here is the output lspci

0000:00:1d.0 USB Controller: Intel Corp. 82801EB/ER (ICH5/ICH5R) USB UHCI #1 (rev 02)
0000:00:1d.1 USB Controller: Intel Corp. 82801EB/ER (ICH5/ICH5R) USB UHCI #2 (rev 02)
0000:00:1d.2 USB Controller: Intel Corp. 82801EB/ER (ICH5/ICH5R) USB UHCI #3 (rev 02)
0000:00:1d.3 USB Controller: Intel Corp. 82801EB/ER (ICH5/ICH5R) USB UHCI #4 (rev 02)
0000:00:1d.7 USB Controller: Intel Corp. 82801EB/ER (ICH5/ICH5R) USB2 EHCI Controller (rev 02)

output of lsmod:

ehci-hcd 18412 0 (unused)
usb-uhci 23344 0 (unused)
usbcore 62924 1 [hid ehci-hcd usb-uhci]

output of lsusb:

Bus 005 Device 001: ID 0000:0000
Bus 004 Device 001: ID 0000:0000
Bus 003 Device 001: ID 0000:0000
Bus 002 Device 001: ID 0000:0000
Bus 002 Device 002: ID 046d:c00e Logitech, Inc. Optical Mouse
Bus 001 Device 001: ID 0000:0000
Bus 001 Device 002: ID 04e7:0008 Elo TouchSystems
Bus 001 Device 003: ID 413c:2100 Dell Computer Corp. SK-3106 Keyboard

dmesg:

input: USB HID v1.00 Pointer [Elo TouchSystems, Inc. Elo TouchSystems AccuTouch 3000U] on usb1:2.0

XFree86.log :

(**) Eloinput X device name: TOUCHSCREEN
(**) Eloinput associated screen: 0
(**) Eloinput maximum x position: 3000
(**) Eloinput minimum x position: 0
(**) Eloinput maximum y position: 3000
(**) Eloinput minimum y position: 0
(**) Eloinput device will work in Landscape mode
(II) XINPUT: Adding extended input device "TOUCHSCREEN" (type: Elo USB TouchScreen)

Thanks

-steve
 
Old 06-04-2005, 11:27 PM   #4
Simon Bridge
LQ Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 198Reputation: 198
According to this, everything is present and accounted for.
I take it you twiddle the touchscreen and nothing happens?

If you would expect the touchscreen to perform mouse actions (say) then try without the mouse.

Apart from a possible conflict with another usb system - BIIK
 
Old 06-05-2005, 08:45 AM   #5
festx
LQ Newbie
 
Registered: Jun 2005
Location: Southern NJ
Distribution: Debian (testing)
Posts: 5

Original Poster
Rep: Reputation: 0
I removed the mouse, but it still is not picking up the touchscreen. How do I check to see what device (/dev/somedevice) the touchscreen is attached to? I don't think it is /dev/input/event* because I tried all of them.

-Steve
 
Old 06-06-2005, 02:05 AM   #6
Simon Bridge
LQ Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 198Reputation: 198
I havn't been able to figure out how udev assigns block special device names to things. I myself have a card reader (and nothing else) and it still assigned /dev/sdd1 to it (where I expected /dev/sda1).

In FC, usb devices get assigned to /dev/sd??

(The "?" is an intended wildcard.)

some systems put them in /dev/usb/... or similar. You may just have to try all the likely looking ones.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Undefined Screen " XFree86" reference by serverLayout "XFree86 Configured" comox *BSD 7 01-17-2005 05:47 PM
"extension "XFree86-DRI" missing on display" upgrading XFree86 to 4.3.0 on Sarge Moloko Debian 5 03-31-2004 05:06 PM
Help configuring XFree86 on YDL 2.3 (black screen & failed XFree86 -configure) EnVoy Linux - General 1 11-24-2003 04:32 PM
XFree86 4.3 on woody, can't run XFree86 -Config mtr Debian 6 08-15-2003 12:50 PM
Will ATI Radeon 8500 XFree86 4.2 driver work with Xfree86 4.3? Stevetgn Linux - Hardware 1 06-24-2003 06:16 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 10:17 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration