-   Linux - Hardware (
-   -   (EE) NVIDIA(0): Failed to initialize the NVIDIA Kernel module (

latino 02-21-2005 08:48 PM

(EE) NVIDIA(0): Failed to initialize the NVIDIA Kernel module

This originates from another thread named Unable to resize monitor display. I am opening a new thread since that error was fixed.

Now, this is a different (altough related) story. Basically, I have an AMD 64 with Red Hat 4 (kernel 2.6.9-5.03).

The display card is a NIVIDIA GeForce FC52000XT. I installed latest drivers from NVIDIA. Installation went fine.

The problem is when I try:

startx I get the

(EE) NVIDIA(0): Failed to initialize the NIVIDIA kernel module!

IF I check the dev dir there is NO nvidia files there.

However IF I try modprobe nvidia the driver gets initialized!
/dev have
nvidia0 and nvidiactl **after** doing a modprobe nvidia

STARTX works and I get into the GUI with full NVIDIA DRIVERS. For example, glxgears runs nicely.

Someone told about placing a script at startup (/init.d?) that copy the files to the dev/ directory But dont know how.

Any other idea how to fix this one???

Even executing:

nvidia-installer --sanity

get a correct installation message no errors.

Need help for this one.


perfect_circle 02-21-2005 09:51 PM

You probably don't have red-hat 4. Check again. Red-hat 4 is way too old. Your error looks exactly the same as the one people have when they try to install nvidia in Fedora Core 3.
Read this:

latino 02-21-2005 09:57 PM

Sorry for not being clear. I am using Red Hat Enterprise WS v4 not Red Hat v4. BTW, RHEL v4 is *derived* from Fedora Core 3. So after reading the link you provided, it makes sense to test that solution.

Thanks a lot.

Here is the relevant part of that suggestion:

CURRENT PROBLEM: The new udev included in FC3 seems to prevent
the nvidia module from loading automatically.
There are 2 options:

Recommended Fix

# cp -a /dev/nvidia* /etc/udev/devices
# chown root.root /etc/udev/devices/nvidia*

Only if above does NOT work

EDIT /etc/rc.local

ADD the following to the END of the file:

/sbin/modprobe nvidia

Other Kernel Issues:

If you update your kernel the NVidia driver must be re-installed to
match the new kernel.

I have not verified it yet, but seems it should work.

Thanks Again!

latino 02-21-2005 10:56 PM

Hi perfect_circle:

Just to tell you that this did the job.

# cp -a /dev/nvidia* /etc/udev/devices
# chown root.root /etc/udev/devices/nvidia*

Thanks for the link! Working nicely... and now the driver starts automatically.



perfect_circle 02-22-2005 08:08 AM

Well... fedora is what the enterprise version of red-hat will use in the future after they test things more, so finding the solutions to a problem for fedora, maybe the key to solve something in redhat enterprise. :)

BlackUnicorn 06-03-2008 04:55 AM

to me it is almost the same problem
I'm using Kubuntu 7.10 (Gutsy), with kernel 2.6.22-14-generic and a Nvidia GeForce 7600GS 512MB graphic card.
My problem is that I tried to get my graphic card to work with the latest nvidia driver and after that the X Server (after typing "startx") didn't work at all.
The installation seemed to work fine, except to the message

"/usr/lib/xorg/modules/extensions/ is not a symbolic link"
, but it seemed also that the installer fixed that:


-> Your X configuration file has been successfully updated.  Installation of the NVIDIA Accelerated Graphics Driver for Linux-x86 (version: 173.14.05) is now complete.
So when I now try to start the X-Server, I get the message


(II) Setting vga for screen 0.
(**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 888
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(**) NVIDIA(0): Enabling RENDER acceleration
(II) NVIDIA(0): Support for GLX with the Damage and Composite X extensions is
(II) NVIDIA(0):    enabled.
(EE) NVIDIA(0): Failed to initialize the NVIDIA graphics device!
(II) UnloadModule: "nvidia"
(II) UnloadModule: "wfb"
(II) UnloadModule: "fb"
(EE) Screen(s) found, but none have a usable configuration.

Fatal server error:
no screens found

Before that (and now, I made a baclup of my old xorg.conf) my system worked well with the nv driver, but I would like to use (almost) the full capacity of my graphic card, so that is the reason why I want the nvidia driver.

My xorg.conf (with nvidia) is:

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  (buildmeister@builder63)  Mon May 19 00:33:37 PDT 2008

# xorg.conf (xorg X Window System server configuration file)
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#  sudo dpkg-reconfigure -phigh xserver-xorg
#Section "Device"
#        Identifier        "nVidia Corporation G70 [GeForce 7600 GS]"
#        Driver                "nvidia"
#        BusID                "PCI:1:0:0"

Section "ServerLayout"

# Uncomment if you have a wacom tablet
#        InputDevice    "stylus"        "SendCoreEvents"
#        InputDevice    "cursor"        "SendCoreEvents"
#        InputDevice    "eraser"        "SendCoreEvents"
    Identifier    "Default Layout"
    Screen        "Default Screen" 0 0
    InputDevice    "Generic Keyboard"
    InputDevice    "Configured Mouse"

Section "Files"

Section "InputDevice"
    Identifier    "Generic Keyboard"
    Driver        "kbd"
    Option        "CoreKeyboard"
    Option        "XkbRules" "xorg"
    Option        "XkbModel" "pc105"
    Option        "XkbLayout" "de"
    Option        "XkbVariant" "nodeadkeys"

Section "InputDevice"
    Identifier    "Configured Mouse"
    Driver        "mouse"
    Option        "CorePointer"
    Option        "Device" "/dev/input/mice"
    Option        "Protocol" "ImPS/2"
    Option        "ZAxisMapping" "4 5"
    Option        "Emulate3Buttons" "true"

Section "InputDevice"
    Identifier    "stylus"
    Driver        "wacom"
    Option        "Device" "/dev/input/wacom"
    Option        "Type" "stylus"
    Option        "ForceDevice" "ISDV4"                # Tablet PC ONLY

Section "InputDevice"
    Identifier    "eraser"
    Driver        "wacom"
    Option        "Device" "/dev/input/wacom"
    Option        "Type" "eraser"
    Option        "ForceDevice" "ISDV4"                # Tablet PC ONLY

Section "InputDevice"
    Identifier    "cursor"
    Driver        "wacom"
    Option        "Device" "/dev/input/wacom"
    Option        "Type" "cursor"
    Option        "ForceDevice" "ISDV4"                # Tablet PC ONLY

Section "Monitor"
    Identifier    "Standardbildschirm"
    HorizSync      28.0 - 51.0
    VertRefresh    43.0 - 60.0
    Option        "DPMS"

Section "Device"
    Identifier    "nVidia Corporation G70 [GeForce 7600 GS]"
    Driver        "nvidia"

Section "Screen"
    Identifier    "Default Screen"
    Device        "nVidia Corporation G70 [GeForce 7600 GS]"
    Monitor        "Standardbildschirm"
    DefaultDepth    24
    SubSection    "Display"
        Depth      24
        Modes      "1024x768" "832x624" "800x600" "720x400" "640x480"

Has anyone an idea what could be wrong? If I missed some information, please write a note.

All times are GMT -5. The time now is 12:13 AM.