LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 01-25-2006, 10:04 PM   #1
adds2one
Member
 
Registered: Aug 2005
Location: Vancouver, BC
Distribution: Ubuntu 6.06
Posts: 154

Rep: Reputation: 30
Echo Indigo IO


Has anyone been successful in getting this PCMCIA card to work with in a Linux environment? I haven't been able to confirm that it works by searching the net but it does seem to have an ALSA driver.
 
Old 07-19-2006, 09:39 PM   #2
Jeiku
Member
 
Registered: Jul 2005
Posts: 64

Rep: Reputation: 18
Hi,

I got it working!

I didn't use Slackware though, I used Gentoo.

What I did in the kernel:

Enable Yenta PCMCIA support in my kernel (2.6.16)

Device Drivers-> Sound[*] Sound Card Support

<M> Advanced Linux Sound Architecture[*] Verbose printk

Go into PCI devices and make sure they are all unchecked.

Compile the kernel.

Install coldplug.

Add ALSA_CARDS="indigoio" to /etc/make.conf

Install alsa-driver, alsa-firmware and alsa-tools.

Copy new kernel from /usr/src/linux/arch/i386/boot/bzImage to /boot/kernel

Run lilo and reboot.

When it's booted, the alsa driver should automatically load the module.

If it doesn't work, check the output of dmesg and post it here and I'll try and help.

Jake
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
ALSA drivers for Indigo IO adds2one Slackware 12 08-05-2006 05:35 PM
Echo Indigo IO PCMCIA on Slackware 10.2 Jeiku Linux - Hardware 2 01-12-2006 04:22 AM
Kphone echo (echo echo) scabies Linux - Software 0 10-18-2004 02:59 PM
Installing Linux on an iMac indigo Mankind75 Linux - Hardware 5 07-16-2004 05:18 PM
Echo /devPrinting doesn't work, echo /usb/lp0 works, Testpage works, Printing doesn't Hegemon Linux - General 3 08-15-2002 01:13 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 02:03 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration