-   Linux - Hardware (
-   -   DVI monitor screen resolution not detected (Debian Wheezy) (

ocafu 03-12-2011 12:24 PM

DVI monitor screen resolution not detected (Debian Wheezy)
Hi guys!

Just installed a fresh copy of Wheezy (kernel: 2.6.32-5-amd64) and all is cool... except for my monitor.
The system just can't detect the optimal resolution. When I open gnome-display-properties, it doesn't show up correctly either.

I've also tried with Xrandr but without any progress. Here is a dump of xrandr -q command:
xrandr: Failed to get size of gamma for output default
Screen 0: minimum 640 x 480, current 1600 x 1200, maximum 1600 x 1200
default connected 1600x1200+0+0 0mm x 0mm
1600x1200 0.0*
1280x1024 0.0
1024x768 0.0
800x600 0.0
640x480 0.0
The maximum resolution is apparently 1600x1200, which of obviously is not right, so I tried to add a new modeline (to add a resolution of 1920x1080) using Xrandr, but it doesn't work. I always receive the same message "xrandr: Failed to get size of gamma for output default".

<< Hardware info >>

Monitor: Samsung Syncmaster BX2440 (native 1920x1080@60Hz) hooked up with DVI cable instead of VGA
Graphics: Intel Integrated Graphics Controller
Processor: Intel i5-2300

Can anyone lend a kind hand? If you need some other data dumps, let me know. Thanx!

dreamwalking 03-12-2011 01:00 PM

It's not very clear to me what steps you followed up to now, so maybe I'm stating the obvious here, but I remember having xrandr complaining when I was forgetting the '--addmode' step when adding the new modeline.

The way I had managed to configure the screen, if I recall well, was to calculate the modeline with a

cvt 1920 1080
and add

xrandr --newmode <your_modeline>
xrandr --addmode <mode>
Also, I haven't used Debian for sometime, so I don't know: What X version you have and do you have a working xorg.conf? If so, I think you can tweak it directly from there ('Section: "Monitor"' and edit the options given).

ocafu 03-12-2011 02:36 PM

1 Attachment(s)
Hi dreamwalking

Sorry I didn't mention it before but I have run some tests of my own prior to opening this post.
This is what I had done before:

$ gtf 1920 1080 60
# 1920x1080 @ 60.00 Hz (GTF) hsync: 67.08 kHz; pclk: 172.80 MHz
Modeline "1920x1080_60.00" 172.80 1920 2040 2248 2576 1080 1081 1084 1118 -HSync +Vsync
$ xrandr --newmode "1920x1080_60.00" 172.80 1920 2040 2248 2576 1080 1081 1084 1118 -HSync +Vsync
xrandr: Failed to get size of gamma for output default
$ xrandr --addmode default "1920x1080_60.00"
xrandr: Failed to get size of gamma for output default
$ xrandr -q
xrandr: Failed to get size of gamma for output default
Screen 0: minimum 640 x 480, current 1600 x 1200, maximum 1600 x 1200
default connected 1600x1200+0+0 0mm x 0mm
1600x1200 0.0*
1280x1024 0.0
1024x768 0.0
800x600 0.0
640x480 0.0
1920x1080_60.00 60.0
Note that my monitor is named "default", which is strange. I think it's a sign that the driver is not detecting my monitor correctly. It should be TMPS or FDS or similar since it is connected via the DVI port, not VGA.

After running all the above commands, nothing has changed. Gnome-display-properties still cannot detect the new resolution or frequency or monitor (see attached screenshot below).

I've also tried a customized xorg.conf file but it doesn't work. I only get a black screen and no X window system.

This is the content of my xorg.conf file:

Section "ServerLayout"
Identifier " Configured"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"

Section "Files"
ModulePath "/usr/lib/xorg/modules"
FontPath "/usr/share/fonts/X11/misc"
FontPath "/usr/share/fonts/X11/cyrillic"
FontPath "/usr/share/fonts/X11/100dpi/:unscaled"
FontPath "/usr/share/fonts/X11/75dpi/:unscaled"
FontPath "/usr/share/fonts/X11/Type1"
FontPath "/usr/share/fonts/X11/100dpi"
FontPath "/usr/share/fonts/X11/75dpi"
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
FontPath "built-ins"

Section "Module"
Load "record"
Load "glx"
Load "dri"
Load "dri2"
Load "dbe"
Load "extmod"

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5 6 7"

Section "Monitor"
Identifier "Monitor0"
VendorName "Samsung"
ModelName "SyncMaster BX2440"

Section "Device"
Identifier "Card0"
Driver "intel"
VendorName "Intel Corporation"
BoardName "Sandy Bridge Integrated Graphics Controller"
BusID "PCI:0:2:0"
Modeline "1920x1080_60.00" 172.80 1920 2040 2248 2576 1080 1081 1084 1118 -HSync +Vsync
Option "PreferredMode" "1920x1080_60.00"

Section "Screen"
Identifier "Screen0"
Device "Card0"
Monitor "Monitor0"
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1920x1080" "1600x1200" "1280x1024"

jefro 03-12-2011 03:17 PM

Living the the bleeding edge would be my guess. Is there any other monitor available to test?

ocafu 03-12-2011 04:21 PM

Yep. Haven't tried it though... It's and old 15 incher (VGA only cable).
What should I do? Connect my older monitor to see if it works? I'm pretty sure it will.

I believe the problem is not the monitor but rather the intel graphics driver configuration, don't you think?
I can post a dump of the Xorg.0.log if you need it.

dreamwalking 03-13-2011 12:50 PM

I wouldn't worry for the naming of your monitor as 'default'. Also, despite the 'failed to get size of gamma' error, the new mode seems to have been added correctly.

Did you try a


xrandr --output default --mode "1920x1080_60.00"
Another thing, I don't have my xorg.conf backup from when I had a DVI monitor plugged, but I think that I had the lines:


Modeline    "1920x1080_60.00"  172.80  1920 2040 2248 2576  1080 1081 1084 1118  -HSync +Vsync
Option            "PreferredMode" "1920x1080_60.00"

In the section "Monitor" rather than the "Device" section.

ocafu 03-13-2011 01:41 PM


Yep, I noticed that the new mode was added correctly but since the "...gamma..." warning keeps is always present, I thought something was wrong behind the scenes. I'll give both of you suggestions a shot and post back.

(I hope it works! My eyes hurt from staring into a over-stretched, blurry and crappy image resolution (1600x1200) which is obviously not adequate for a 24" screen)

ocafu 03-14-2011 05:54 AM

No luck. None of the suggestions worked.

First one...


$ xrandr --output default --mode "1920x1080_60.00"
xrandr: Failed to get size of gamma for output default
xrandr: Configure crtc 0 failed

...resulted in error.

Second one, moving these lines...


Modeline    "1920x1080_60.00"  172.80  1920 2040 2248 2576  1080 1081 1084 1118  -HSync +Vsync
Option            "PreferredMode" "1920x1080_60.00" the "Monitor" section of xorg.conf, had no effect at all. X window system wouldn't even start up upon reboot.

If I may suggest, I'm sure the problem is somewhere in the graphics driver setup. From what I see in the /var/log/Xorg.0.log file...


X.Org X Server 1.7.7
Release Date: 2010-05-04
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.32-5-amd64 x86_64 Debian
Current Operating System: Linux blackbox 2.6.32-5-amd64 #1 SMP Wed Jan 12 03:40:32 UTC 2011 x86_64
Kernel command line: BOOT_IMAGE=/boot/vmlinuz-2.6.32-5-amd64 root=UUID=6277ffa7-432c-41c1-a9a8-fef32275dca4 ro quiet
Build Date: 12 January 2011  02:59:50AM
xorg-server 2:1.7.7-11 (Cyril Brulebois <>)
Current version of pixman: 0.16.4
        Before reporting problems, check
        to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Mon Mar 14 11:25:13 2011
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
(==) No Layout section.  Using the first Screen section.
(==) No screen section available. Using defaults.
(**) |-->Screen "Default Screen Section" (0)
(**) |  |-->Monitor "<default monitor>"
(==) No monitor specified for screen "Default Screen Section".
        Using a default monitor configuration.
(==) Automatically adding devices
(==) Automatically enabling devices

... when I don't use an "xorg.conf" file for setup, the X window system is searching for a config file (non-existing) in "/usr/share/X11/xorg.conf.d/" and therefore, reverts to "Using defaults" (whatever they are!) and then this: "Using a default monitor configuration" (wherever that default monitor config is coming from, who knows!)

Then, further down in the log file, after loading many modules, there are a lot of lines beginning with "VESA" (I imagine this is the default graphic driver that's being used, and not Intel) such as these..


(II) VESA(0): initializing int10
(II) VESA(0): Primary V_BIOS segment is: 0xc000
(II) VESA(0): VESA BIOS detected
(II) VESA(0): VESA VBE Version 3.0
(II) VESA(0): VESA VBE Total Mem: 65472 kB
(II) VESA(0): VESA VBE OEM: Intel(R)Sandybridge Desktop Graphics Chipset Accelerated VGA BIOS
(II) VESA(0): VESA VBE OEM Software Rev: 1.0
(II) VESA(0): VESA VBE OEM Vendor: Intel Corporation
(II) VESA(0): VESA VBE OEM Product: Intel(R)Sandybridge Desktop Graphics Controller
(II) VESA(0): VESA VBE OEM Product Rev: Hardware Version 0.0
(II) VESA(0): Creating default Display subsection in Screen section
        "Default Screen Section" for depth/fbbpp 24/32
(==) VESA(0): Depth 24, (--) framebuffer bpp 32
(==) VESA(0): RGB weight 888
(==) VESA(0): Default visual is TrueColor
(==) VESA(0): Using gamma correction (1.0, 1.0, 1.0)
(II) Loading sub module "ddc"
(II) LoadModule: "ddc"
(II) Module "ddc" already built-in

... some more, where the monitor is detected as Samsung and also its Digital Display Input (DVI, I presume), which is a good sign...


(II) VESA(0): VESA VBE DDC supported
(II) VESA(0): VESA VBE DDC Level 2
(II) VESA(0): VESA VBE DDC transfer in appr. 1 sec.
(II) VESA(0): VESA VBE DDC read successfully
(II) VESA(0): Manufacturer: SAM  Model: 68b  Serial#: 1128411700
(II) VESA(0): Year: 2011  Week: 2
(II) VESA(0): EDID Version: 1.3
(II) VESA(0): Digital Display Input
(II) VESA(0): Max Image Size [cm]: horiz.: 53  vert.: 30
(II) VESA(0): Gamma: 2.20
(II) VESA(0): DPMS capabilities: Off

... and then, shockingly, I see that somehow my desired screen resolution is in fact supported!!...


(II) VESA(0): EDID vendor "SAM", prod id 1675
(II) VESA(0): Using EDID range info for horizontal sync
(II) VESA(0): Using EDID range info for vertical refresh
(II) VESA(0): Printing DDC gathered Modelines:
(II) VESA(0): Modeline "1920x1080"x0.0  148.50  1920 2008 2052 2200  1080 1084 1089 1125 +hsync +vsync (67.5 kHz)
(II) VESA(0): Modeline "800x600"x0.0  40.00  800 840 968 1056  600 601 605 628 +hsync +vsync (37.9 kHz)
(II) VESA(0): Modeline "800x600"x0.0  36.00  800 824 896 1024  600 601 603 625 +hsync +vsync (35.2 kHz)
(II) VESA(0): Modeline "640x480"x0.0  31.50  640 656 720 840  480 481 484 500 -hsync -vsync (37.5 kHz)
(II) VESA(0): Modeline "640x480"x0.0  31.50  640 664 704 832  480 489 492 520 -hsync -vsync (37.9 kHz)
(II) VESA(0): Modeline "640x480"x0.0  30.24  640 704 768 864  480 483 486 525 -hsync -vsync (35.0 kHz)
(II) VESA(0): Modeline "640x480"x0.0  25.18  640 656 752 800  480 490 492 525 -hsync -vsync (31.5 kHz)
(II) VESA(0): Modeline "720x400"x0.0  28.32  720 738 846 900  400 412 414 449 -hsync +vsync (31.5 kHz)
(II) VESA(0): Modeline "1280x1024"x0.0  135.00  1280 1296 1440 1688  1024 1025 1028 1066 +hsync +vsync (80.0 kHz)
(II) VESA(0): Modeline "1024x768"x0.0  78.75  1024 1040 1136 1312  768 769 772 800 +hsync +vsync (60.0 kHz)
(II) VESA(0): Modeline "1024x768"x0.0  75.00  1024 1048 1184 1328  768 771 777 806 -hsync -vsync (56.5 kHz)
(II) VESA(0): Modeline "1024x768"x0.0  65.00  1024 1048 1184 1344  768 771 777 806 -hsync -vsync (48.4 kHz)
(II) VESA(0): Modeline "832x624"x0.0  57.28  832 864 928 1152  624 625 628 667 -hsync -vsync (49.7 kHz)
(II) VESA(0): Modeline "800x600"x0.0  49.50  800 816 896 1056  600 601 604 625 +hsync +vsync (46.9 kHz)
(II) VESA(0): Modeline "800x600"x0.0  50.00  800 856 976 1040  600 637 643 666 +hsync +vsync (48.1 kHz)
(II) VESA(0): Modeline "1152x864"x0.0  108.00  1152 1216 1344 1600  864 865 868 900 +hsync +vsync (67.5 kHz)
(II) VESA(0): Modeline "1280x800"x0.0  71.00  1280 1328 1360 1440  800 803 809 823 +hsync -vsync (49.3 kHz)
(II) VESA(0): Modeline "1280x960"x0.0  108.00  1280 1376 1488 1800  960 961 964 1000 +hsync +vsync (60.0 kHz)
(II) VESA(0): Modeline "1280x1024"x0.0  108.00  1280 1328 1440 1688  1024 1025 1028 1066 +hsync +vsync (64.0 kHz)
(II) VESA(0): Modeline "1440x900"x0.0  88.75  1440 1488 1520 1600  900 903 909 926 +hsync -vsync (55.5 kHz)
(II) VESA(0): Modeline "1600x1200"x0.0  162.00  1600 1664 1856 2160  1200 1201 1204 1250 +hsync +vsync (75.0 kHz)
(II) VESA(0): Modeline "1680x1050"x0.0  119.00  1680 1728 1760 1840  1050 1053 1059 1080 +hsync -vsync (64.7 kHz)
(II) VESA(0): Modeline "1440x900"x0.0  136.75  1440 1536 1688 1936  900 903 909 942 -hsync +vsync (70.6 kHz)

After all the above, I'm confused, and worried, that X system is using the VESA driver and not the Intel one.

Don't know what's going on, really. Sometimes I hope hardware manufacturers would give us Linux users a break and assist in providing same quality drivers and guidance as they do to the Windoze, and lately Mac, communities! I love Linux OS, but I hate :mad: it's hardware compatibility issues all round. It's no wonder Linux throws off many many people (basic PC users) :banghead:

Can anybody see something that I'm missing?

dreamwalking 03-15-2011 03:51 AM

Can you post what xserver-xorg packages you have installed? (If I remember well, it should be somewhere in /var/cache/apt, or a 'dpkg --get-selections | grep xserver-xorg' should do it).

Also, are you using the stock kernel, no modifications or anything? What xorg and xserver version you are using?

And, finally, how did you get your xorg.conf? Did you made it yourself, or you created one with the Debian tool to do this? (with a 'dpkg-reconfigure xserver-xorg' or something similar?).

ocafu 03-15-2011 05:49 AM

1 Attachment(s)
Dreamwalking, here is the info you requested.

First question:
These are all of the xserver-xorg packages installed in my system. Xorg version is 1:7.5+8


$ sudo dpkg --list | grep xserver-xorg
ii  xserver-xorg                        1:7.5+8                              the X.Org X server
ii  xserver-xorg-core                    2:1.7.7-13                          Xorg X server - core server
ii  xserver-xorg-input-all              1:7.5+8                              the X.Org X server -- input driver metapackage
ii  xserver-xorg-input-evdev            1:2.3.2-6                            X.Org X server -- evdev input driver
ii  xserver-xorg-input-synaptics        1.2.2-2                              Synaptics TouchPad driver for X.Org server
ii  xserver-xorg-input-wacom            0.10.5+20100416-1                    X.Org X server -- Wacom input driver
ii  xserver-xorg-video-all              1:7.5+8                              the X.Org X server -- output driver metapackage
ii  xserver-xorg-video-apm              1:1.2.2-2                            X.Org X server -- APM display driver
ii  xserver-xorg-video-ark              1:0.7.2-2                            X.Org X server -- ark display driver
ii  xserver-xorg-video-ati              1:6.13.1-2+squeeze1                  X.Org X server -- AMD/ATI display driver wrapper
ii  xserver-xorg-video-chips            1:1.2.3-1                            X.Org X server -- Chips display driver
ii  xserver-xorg-video-cirrus            1:1.3.2-2+squeeze1                  X.Org X server -- Cirrus display driver
ii  xserver-xorg-video-fbdev            1:0.4.2-2                            X.Org X server -- fbdev display driver
ii  xserver-xorg-video-i128              1:1.3.3-2                            X.Org X server -- i128 display driver
ii  xserver-xorg-video-intel            2:2.13.0-6                          X.Org X server -- Intel i8xx, i9xx display driver
ii  xserver-xorg-video-mach64            6.8.2-3                              X.Org X server -- ATI Mach64 display driver
ii  xserver-xorg-video-mga              1:1.4.11.dfsg-4+squeeze1            X.Org X server -- MGA display driver
ii  xserver-xorg-video-neomagic          1:1.2.4-3                            X.Org X server -- Neomagic display driver
ii  xserver-xorg-video-nouveau          1:0.0.15+git20100329+7858345-5      X.Org X server -- Nouveau display driver (experimental)
ii  xserver-xorg-video-nv                1:2.1.17-3                          X.Org X server -- NV display driver
ii  xserver-xorg-video-openchrome        1:0.2.904+svn842-2                  X.Org X server -- VIA display driver
ii  xserver-xorg-video-r128              6.8.1-3                              X.Org X server -- ATI r128 display driver
ii  xserver-xorg-video-radeon            1:6.13.1-2+squeeze1                  X.Org X server -- AMD/ATI Radeon display driver
ii  xserver-xorg-video-rendition        1:4.2.3-3                            X.Org X server -- Rendition display driver
ii  xserver-xorg-video-s3                1:0.6.3-2                            X.Org X server -- legacy S3 display driver
ii  xserver-xorg-video-s3virge          1:1.10.4-2                          X.Org X server -- S3 ViRGE display driver
ii  xserver-xorg-video-savage            1:2.3.1-2                            X.Org X server -- Savage display driver
ii  xserver-xorg-video-siliconmotion    1:1.7.3-2                            X.Org X server -- SiliconMotion display driver
ii  xserver-xorg-video-sis              1:0.10.3-1                          X.Org X server -- SiS display driver
ii  xserver-xorg-video-sisusb            1:0.9.3-2                            X.Org X server -- SiS USB display driver
ii  xserver-xorg-video-tdfx              1:1.4.3-2                            X.Org X server -- tdfx display driver
ii  xserver-xorg-video-trident          1:1.3.3-2                            X.Org X server -- Trident display driver
ii  xserver-xorg-video-tseng            1:1.2.3-2                            X.Org X server -- Tseng display driver
ii  xserver-xorg-video-vesa              1:2.3.0-3                            X.Org X server -- VESA display driver
ii  xserver-xorg-video-vmware            1:11.0.1-2                          X.Org X server -- VMware display driver
ii  xserver-xorg-video-voodoo            1:1.2.3-2                            X.Org X server -- Voodoo display driver

Second question:

I'm using the default stock kernel that comes with the GUI installation from DVD iso. No tweaking/modifications.


$ sudo dpkg --list | grep linux
ii  doc-linux-text                      2008.08-1                            Linux HOWTOs and FAQs in ASCII format
ii  lib32v4l-0                          0.8.0-1                              Collection of video4linux support libraries (32 bits)
ii  libselinux1                          2.0.96-1                            SELinux runtime shared libraries
ii  libv4l-0                            0.8.0-1                              Collection of video4linux support libraries
ii  linux-base                          2.6.32-31                            Linux image base package
ii  linux-headers-2.6.32-5-amd64        2.6.32-31                            Header files for Linux 2.6.32-5-amd64
ii  linux-headers-2.6.32-5-common        2.6.32-31                            Common header files for Linux 2.6.32-5
ii  linux-image-2.6.32-5-amd64          2.6.32-31                            Linux 2.6.32 for 64-bit PCs
ii  linux-kbuild-2.6.32                  2.6.32-1                            Kbuild infrastructure for Linux 2.6.32
ii  linux-libc-dev                      2.6.32-31                            Linux support headers for userspace development
ii  linux-sound-base                    1.0.23+dfsg-2                        base package for ALSA and OSS sound systems
ii  util-linux                          2.17.2-9                            Miscellaneous system utilities
ii  util-linux-locales                  2.17.2-9                            Locales files for util-linux

Third question:

I tried a few options to generate an "xorg.conf" file. First, dpkg-reconfigure xserver-xorg didn't seem to work, so I tried Xorg --configure instead, and it gave me a basic file to begin with. I tweaked it a little bit and that's what I posted here.

I've now removed the xorg.conf file from /etc/X11 after following your last suggestions since it's not working (black screen) so now I'm back to square one, which is... :scratch:

I've also attached a full copy of my Xorg.0.log file in case anyone needs to take an expert look at it. At this moment, I'm at my wits end and
don't know what else to try.
Thank you trying to help me, I really appreciate it :D

mister0905 03-17-2011 05:48 AM

i have got the same problem. And i tried the same things you did.

Unfortunately i found no solution :(

monitor: b2440
graphicscard: geforce 9800 gt

ocafu 03-17-2011 03:15 PM

Hi mister0905

As you can see, I haven't received any further reply after submitting the whole lot of information to the forum, which means, in my opinion at least, that the problem is quite difficult, if not impossible, to solve.

I've already solved it (by myself).

Solution: ditch Debian 6.

I may return to Debian in the future. After all, it's my first love in the Linux world ( :) hahaha!!) but I'm fed up with so many days searching and searching and testing and trying and... blah... blah... with no success and then, finally fed up with it so many tests and so little good suggestions/advice in Google, I just zipped in a couple of Ubuntu based live CDs and also a (very) cool new distro I found lately (Bodhi Linux)... and VOILÁ!!!! Monitor's working perfectly from the gate. No tweaking. No setup. No NOTHING!!!

Just wonderful!! I totally recomend trying new distros now and then. You'll be quite surprised.

mister0905 03-21-2011 04:40 AM

Hm, could you perhaps post your new xorg.conf?

btw: My System is Fedora 14

loren99 12-07-2011 02:28 AM

debian monitor resolution... continued
I have had the same problem now on two Debian systems, and I fully identify with the frustration. In the first situation, I was trying to dual-head an external monitor with a laptop and get both resolutions right. I tried a lot of things and the problem ended up miraculously fixing itself after an update a year later.
Now I am replacing the nine-year-old laptop and having the same problem with the new laptop, despite using the latest version of debian. But this time, dpkg-reconfigure xserver-xorg doesn't do anything. There is no xorg.conf file and I do not know how to start one. On the old laptop the xorg.conf file is not what makes it work, since the info in the file is not correct. For this reason I don't know whether to add an xorg.conf file to the new laptop.
Any ideas???

abhishan82 05-25-2012 07:30 PM

I had the same problem. I'm not sure if this is the solution, but all it took me to get rid of the problem was switching the monitor's DVI connector to the other DVI port.

All times are GMT -5. The time now is 09:23 AM.