-   Linux - Hardware (
-   -   DVD Player Problem in fedora /dev/dvd not found (

sxa 01-02-2004 01:12 AM

DVD Player Problem in fedora /dev/dvd not found
I have a Toshiba DVD/CDRW combo drive installed on my computer, now I know Fedora sees the drive because it shows the drive when booting into linux. Also it shows there is a DVD in the drive. Here is the problem..

I go into mplayer and type 'mplayer dvd://48' to try to play the DVD, and I get


Playing dvd://49
libdvdread: Using libdvdcss version 1.2.8 for DVD access
libdvdread: Could not open /dev/dvd with libdvdcss.
libdvdread: Can't open /dev/dvd for reading
Couldn't open DVD device: /dev/dvd
I was told in the software forum that is not a software issue that is a hardware issue.. so I come here ot all you hardware guys and gals to see if any of you could please give me a hand, and maybe we can get this working...

Thanks in advance..

vasudevadas 01-02-2004 03:47 AM

Try setting up a symbolic link; as root, type:

ln -s /dev/cdrom /dev/dvd

sxa 01-02-2004 04:39 PM

Here is what I get


[root@localhost sanness]# ln -s /dev/cdrom /dev/dvd
ln: `/dev/dvd': File exists
I guess thats a good sign..

acid_kewpie 01-02-2004 05:11 PM

it's not a "sign" either way.....

it's probably set up to point to a non-existant device.... do -sf rather than jsut -s to force the overwriting of the link. before you do so though, mke sure that /dev/cdrom does work:

mplayer dvd://49 -dvd-device /dev/cdrom

if that works then go nuts and create that link.

sxa 01-02-2004 08:44 PM

That command worked the mplayer dvd://1 -dvd-device /cdrom1

I found out several things, fist off someone toldme you had to enter the number of chapters to play on the DVD, I soon found out that what ever chapter number you put in is where it starts playing from.

I came to one problem, I need help now changing lanuagues, for some reason some of my DVDs won't play in english, I know its not the DVD, so I need to change the languages in mplayer..

I also really do wish you could see the DVD Main Menu.. that would really be nice.. like on DVD's where you can choose Widescreen or Regular.. how do you choose that in Mplayer?

acid_kewpie 01-03-2004 03:22 AM

just use "-alang en" to set the language.

no really.. you so don't want dvd menus... what a nasty waste of my life it is every time i play a real dvd on my tv...

BUT yes, it can be a little awkward, but generally the mplayer delvelopers do not want to support menus, which i do find slightly odd. You might like my application, which will print out the contents of a dvd so you know which tracks are worth playing etc...

vasudevadas 01-03-2004 06:07 AM

If dvd menus really is important to you, perhaps you should try out Xine too.

sxa 01-04-2004 12:39 AM

Right now I already have two DVD player Apps in linux Ogle, and Mplayer, both of them play DVDs, so I am all set.. Ogle comes us with the DVD menu.. which I can use when I want to use the special features on the DVD, and then I have Mplayer for VCDs, MPEGs, Divix.. and so on..

I do have another issue in Mplayer to resolve, I moved a file from my home directory to My Documents folder, a folder that I created myself, I tried to play the file after I moved it.. the same way I played it before 'mplayer YellowSub.mpg' and it can't find it.. unless it is in my home directory.. is that strange or what?

lmckinney 06-21-2006 06:06 PM

I've installed mplayer on Fedora 5. Everything works fine - as root. However, it will not play dvd's as a regular user. It exit out with the libdvdread error of Can't open /dev/dvd for reading. All of the symbolic links are in place. The following commands all play the dvd as root:
mplayer dvd://1 -dvd-device /dev/dvd
mplayer dvd://1 -dvd-device /dev/cdrom
mplayer dvd://1 -dvd-device /dev/hdc

All of these commands exit with the libdvdread error when run as a user.

My user accounts are mounted on an NFS share on "fileserver". Can mplayer be looking to run from the fileserver's dvd device rather than the local machine?


Keithj 08-23-2006 08:17 PM

Thanks for that, folks! It proved to me that Fedora Core 5 on this machine *can* play DVDs.

mplayer dvd://1 -dvd-device /dev/hdd worked just fine from a terminal window. I had no control over it - there was a window with my DVD and that was it, but it played. Is there a GUI interface for it?

I have Totem installed, but that complains that it doesn't have the plugins to play DVDs. I've not yet found what the plugins are that it wants.

Ogle does nothing - it just sits there and looks at me.

Xine installed the basics, but tells me it's missing MUX stuff. I tried Yumex and Yum to reinstall it, with xine-ui or gxine. Both failed with a message about a "Missing dependency" - something needs libxine>=1. That seems to be an insurmountable hurdle - yum and yumex can't find libxine in any form. I have the livna and freshrpms repos in the list, but they seem not to deliver.

Any thoughts on what I can try next?

All times are GMT -5. The time now is 04:01 AM.