-   Linux - Hardware (
-   -   DVB card is not working (

kapa 10-29-2005 04:06 PM

DVB card is not working

I bought a DVD wrtiter, to save lot of my data (legal movies that I have recorded from TV :)

But, met some severe drawbacks. Can someone give me guidance on how I should solve the problem!

My problem:

I installed DVD burner (Gigabyte GO-W1616A) to my computer, made it as master (on IDE/ATAPI) beside the DVD player (took avay Liteon's 52x24x52x CDwriter). It was a victory on DVD burning, now I really had burner in my device (my CDWriter did not work for ages). What a relief, untill...

... at the same time, my DVB-T card (Terratec Cinergy 1200 DVB-T) stopped to work. And I do not know why :-(

HOW could I get track on my problem, so that I can really solve it.

Seems an inter-operability problem :(

I have tried to modprobe budget_av (which has worked earlier), but it did not solve the problem. Firmware hotplug seems not to work (quessing), because I do not have /etc/hotplug/firmware.agent file!?

I am desperate, is there anyone, who could help me to find a solutions to my problem, which is:DVB card is not working, and change to when it worked was: I changed Lite-on's CD writer to Gigabyte's DVD writer. (and made DVD writer as master in it's IDE bus).

br. könä

kapa 10-30-2005 12:38 PM

something more
Not solved yet, but more information:

I tried master - slave to DVDwriter. No success.

I run hwinfo. It found my DVB card:

105: PCI 107.0: 0480 Multimedia controller
[Created at manual.278]
Unique ID: 2_DJ.wxSAesgcIj9
Parent ID: RE4e.f9Q95vpHUcA
SysFS ID: /devices/pci0000:00/0000:00:08.0/0000:01:07.0
SysFS BusID: 0000:01:07.0
Hardware Class: unknown
Model: "TERRATEC SAA7146"
Vendor: pci 0x1131 "Philips Semiconductors"
Device: pci 0x7146 "SAA7146"
SubVendor: pci 0x153b "TERRATEC Electronic GmbH"
SubDevice: pci 0x1157
Revision: 0x01
Memory Range: 0xee005000-0xee0051ff (rw,non-prefetchable)
IRQ: 11 (8418470 events)
Driver Info #0:
Driver Status: budget-av is active
Driver Activation Cmd: "modprobe budget-av"
Config Status: cfg=no, avail=no, need=no, active=unknown
Attached to: #27 (PCI bridge)

So, it is found, but not found :-(
It seems not to be problem in HW.

"modprobe budget-av" results:

Oct 30 20:32:55 linux kernel: saa7146: register extension 'budget dvb /w video in'.

It also should result

Sep 2 20:50:55 dhcppc1 kernel: saa7146: register extension 'budget dvb /w vide
o in'.
Sep 2 20:50:55 dhcppc1 kernel: ACPI: PCI interrupt 0000:01:07.0[A] -> GSI 11 (
level, low) -> IRQ 11
Sep 2 20:50:55 dhcppc1 kernel: saa7146: found saa7146 @ mem e15fe000 (revision
1, irq 11) (0x153b,0x1157).
Sep 2 20:50:55 dhcppc1 kernel: DVB: registering new adapter (Terratec Cinergy
1200 DVB-T).
Sep 2 20:50:55 dhcppc1 kernel: adapter failed MAC signature check
Sep 2 20:50:55 dhcppc1 kernel: encoded MAC from EEPROM was ff:ff:ff:ff:ff:ff:f
Sep 2 20:50:56 dhcppc1 kernel: KNC1-0: MAC addr = 00:0a:ac:01:a2:99
Sep 2 20:50:56 dhcppc1 kernel: DVB: registering frontend 0 (Philips TDA10046H
Sep 2 20:51:02 dhcppc1 kernel: tda1004x: waiting for firmware upload (dvb-fe-t
Sep 2 20:51:03 dhcppc1 kernel: tda1004x: firmware upload complete

For some reason, my kernel will not read tda1004x.bin firmware. What could be the reason?

Can anyone help me?

Br. könä

kapa 11-13-2005 06:57 AM

Update !!!

Now it is working. I have DVD burner working okay, at least yesterday it was :) Also DVB-T card is operating fine!

What I did was:

I changed Terratec Cinergy DVB-T 1200 card from PCI slot 3 to PCI slot 5. Nothing else was changed (except the installation of OpenSUSE 10.0).

It seams that there is something wrong in my computer set-up (which by-the-way is mostly self-build). But it is not a problem to me now, I can live with this setup for quite a while :)

br. Kari

All times are GMT -5. The time now is 06:33 PM.