LinuxQuestions.org

LinuxQuestions.org (http://www.linuxquestions.org/questions/index.php)
-   Linux - Hardware (http://www.linuxquestions.org/questions/forumdisplay.php?f=18)
-   -   Dual Monitors with AMD A6-3620 APU (http://www.linuxquestions.org/questions/showthread.php?t=937489)

replica9000 03-31-2012 09:14 PM

Dual Monitors with AMD A6-3620 APU
 
I'm trying to get a dual monitor setup on a new computer. The computer is a HP Pavilion P7-1254 with the A6-3620 APU.

I've done a fresh install of Debian 'Sid'. When I try to use the second monitor (VGA-0), it only goes into stand by. Output of the system booting is shown on both monitors until the xserver kicks in, then the seconds monitor goes into stand by, but does not complain about no signal. I've also tried other monitors to rule out the monitor itself.

Code:

00:01.0 VGA compatible controller: ATI Technologies Inc Device 964a (prog-if 00 [VGA controller])
        Subsystem: Hewlett-Packard Company Device 2acf
        Flags: bus master, fast devsel, latency 0, IRQ 45
        Memory at c0000000 (32-bit, prefetchable) [size=256M]
        I/O ports at f000 [size=256]
        Memory at feb00000 (32-bit, non-prefetchable) [size=256K]
        Expansion ROM at <unassigned> [disabled]
        Capabilities: [50] Power Management version 3
        Capabilities: [58] Express Root Complex Integrated Endpoint, MSI 00
        Capabilities: [a0] MSI: Enable+ Count=1/1 Maskable- 64bit+
        Capabilities: [100] Vendor Specific Information: ID=0001 Rev=1 Len=010 <?>
        Kernel driver in use: radeon

Code:

Screen 0: minimum 320 x 200, current 3040 x 900, maximum 8192 x 8192
VGA-0 connected 1440x900+1600+0 (normal left inverted right x axis y axis) 408mm x 255mm
  1440x900      59.9*+  75.0 
  1280x1024      75.0    60.0 
  1360x768      60.0 
  1024x768      75.1    70.1    60.0 
  800x600        72.2    75.0    60.3 
  640x480        72.8    75.0    60.0 
  720x400        70.1 
DVI-0 connected 1600x900+0+0 (normal left inverted right x axis y axis) 443mm x 249mm
  1600x900      60.0*+
  1280x1024      75.0    60.0 
  1440x900      59.9 
  1280x960      60.0 
  1280x800      59.8 
  1152x864      75.0 
  1024x768      75.1    70.1    60.0 
  832x624        74.6 
  800x600        72.2    75.0    60.3    56.2 
  640x480        72.8    75.0    66.7    60.0 
  720x400        70.1


adamk75 04-01-2012 07:28 AM

Please show us the output of 'dmesg | grep drm' and your /var/log/Xorg.0.log file.

Adam

replica9000 04-01-2012 10:23 AM

Code:

[    5.097987] [drm] Initialized drm 1.1.0 20060810
[    5.209615] [drm] radeon kernel modesetting enabled.
[    5.209840] [drm] initializing kernel modesetting (SUMO 0x1002:0x964A 0x103C:0x2ACF).
[    5.209907] [drm] register mmio base: 0xFEB00000
[    5.209908] [drm] register mmio size: 262144
[    5.210876] [drm] Detected VRAM RAM=512M, BAR=256M
[    5.210879] [drm] RAM width 32bits DDR
[    5.211014] [drm] radeon: 512M of VRAM memory ready
[    5.211016] [drm] radeon: 512M of GTT memory ready.
[    5.211033] [drm] Supports vblank timestamp caching Rev 1 (10.10.2010).
[    5.211035] [drm] Driver supports precise vblank timestamp query.
[    5.211115] [drm] radeon: irq initialized.
[    5.211120] [drm] GART: num cpu pages 131072, num gpu pages 131072
[    5.211983] [drm] Loading SUMO Microcode
[    5.454477] [drm] PCIE GART of 512M enabled (table at 0x0000000000040000).
[    5.470860] [drm] ring test succeeded in 1 usecs
[    5.470983] [drm] radeon: ib pool ready.
[    5.471088] [drm] ib test succeeded in 0 usecs
[    5.472872] [drm] Radeon Display Connectors
[    5.472876] [drm] Connector 0:
[    5.472877] [drm]  VGA
[    5.472879] [drm]  HPD2
[    5.472881] [drm]  DDC: 0x6440 0x6440 0x6444 0x6444 0x6448 0x6448 0x644c 0x644c
[    5.472883] [drm]  Encoders:
[    5.472885] [drm]    CRT1: INTERNAL_UNIPHY2
[    5.472887] [drm]    CRT1: NUTMEG
[    5.472888] [drm] Connector 1:
[    5.472889] [drm]  DVI-D
[    5.472891] [drm]  HPD1
[    5.472893] [drm]  DDC: 0x6430 0x6430 0x6434 0x6434 0x6438 0x6438 0x643c 0x643c
[    5.472894] [drm]  Encoders:
[    5.472896] [drm]    DFP1: INTERNAL_UNIPHY2
[    5.490293] [drm] Internal thermal controller without fan control
[    5.490338] [drm] radeon: power management initialized
[    5.720442] [drm] fb mappable at 0xC0142000
[    5.720444] [drm] vram apper at 0xC0000000
[    5.720446] [drm] size 5787648
[    5.720447] [drm] fb depth is 24
[    5.720449] [drm]    pitch is 6400
[    5.720513] fbcon: radeondrmfb (fb0) is primary device
[    5.794760] [drm:radeon_dp_link_train_ce] *ERROR* channel eq failed: 5 tries
[    5.794762] [drm:radeon_dp_link_train_ce] *ERROR* channel eq failed
[  10.800010] [drm:atom_op_jump] *ERROR* atombios stuck in loop for more than 5secs aborting
[  10.800014] [drm:atom_execute_table_locked] *ERROR* atombios stuck executing E262 (len 2585, WS 4, PS 4) @ 0xE94C
[  10.830673] fb0: radeondrmfb frame buffer device
[  10.830675] drm: registered panic notifier
[  10.830684] [drm] Initialized radeon 2.12.0 20080528 for 0000:00:01.0 on minor 0

The Xorg.0.log is too large to post here, so I linked to it here.

replica9000 04-01-2012 01:00 PM

xrandr and KDE's monitor settings show the second monitor as working fine. The available modes xrandr shows match the monitors specs. Even while changing modes, even to something that should be invalid, the monitor never leaves standby.

adamk75 04-01-2012 06:41 PM

Well, if I had to guess, I'd say these errors are pretty damning:

Code:

[    5.794760] [drm:radeon_dp_link_train_ce] *ERROR* channel eq failed: 5 tries
[    5.794762] [drm:radeon_dp_link_train_ce] *ERROR* channel eq failed
[  10.800010] [drm:atom_op_jump] *ERROR* atombios stuck in loop for more than 5secs aborting
[  10.800014] [drm:atom_execute_table_locked] *ERROR* atombios stuck executing E262 (len 2585, WS 4, PS 4) @ 0xE94C

HD6xxx GPU support is relatively new. Perhaps a newer/older kernel would work better?

replica9000 04-01-2012 11:06 PM

Well I thank you for the help, but I ended up installing a 9800GT into the machine. Even with the nouveau drivers, I had no problem using xrandr to set up dual monitors. I really didn't feel like messing with FGLRX drivers, which doesn't seem to support the A6-3620 GPU (HD6530D) at the moment.


All times are GMT -5. The time now is 08:05 PM.