LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 07-21-2006, 02:57 AM   #1
willythec
LQ Newbie
 
Registered: Jul 2006
Posts: 5

Rep: Reputation: 0
Dual Monitors on 6600GT Mandriva/Gnome


Iīm quite the Linux n00b but iīve searched around the internet quite a bit for an answer to this question before asking here...
Iīve in the past run a dual monitor setup in Windows XP with my 6600GT running two analogue monitors. The idea is the desktop spans the two which are side by side and gives me double the space.
I canīt get this to run under Linux however.
As stated in the title Iīm running Gnome under Mandriva.
I attach my xorg.conf in the hope that someone knows exactly what to do. I have discovered that it is possible my lack of BusID in the device section... this is not entered because I donīt know how to find out what my cardīs bus ID is.
Thanks a lot in advance, William.

Code:
Section "Monitor"
    Identifier "monitor0"
    VendorName "Generic"
    ModelName "1024x768 @ 70 Hz"
    HorizSync 31.5-57.0
    VertRefresh 50-70
EndSection

Section "Monitor"
    Identifier "monitor1"
    VendorName "Generic"
    ModelName "1024x768 @ 70 Hz"
    HorizSync 31.5-57.0
    VertRefresh 50-70
EndSection

Section "Device"
    Identifier "device0"
    BoardName "NVIDIA GeForce 6800 (generic)"
    Driver "nvidia"
    Option "DPMS"
    Option "IgnoreEDID" "1"
    Screen 0
EndSection

Section "Device"
    Identifier "device1"
    BoardName "NVIDIA GeForce 6800 (generic)"
    Driver "nvidia"
    Option "DPMS"
    Option "IgnoreEDID" "1"
    Screen 1
EndSection

Section "Screen"
    Identifier "screen0"
    Device "device0"
    Monitor "monitor0"
    DefaultColorDepth 24
    
    Subsection "Display"
        Depth 8
        Virtual 1024 768
    EndSubsection
    
    Subsection "Display"
        Depth 15
        Virtual 1024 768
    EndSubsection
    
    Subsection "Display"
        Depth 16
        Virtual 1024 768
    EndSubsection
    
    Subsection "Display"
        Depth 24
        Virtual 1024 768
    EndSubsection
EndSection
Section "Screen"
    Identifier "screen1"
    Device "device1"
    Monitor "monitor1"
    DefaultColorDepth 24
    
    Subsection "Display"
        Depth 8
        Virtual 1024 768
    EndSubsection
    
    Subsection "Display"
        Depth 15
        Virtual 1024 768
    EndSubsection
    
    Subsection "Display"
        Depth 16
        Virtual 1024 768
    EndSubsection
    
    Subsection "Display"
        Depth 24
        Virtual 1024 768
    EndSubsection
EndSection

Section "ServerLayout"
    Identifier "layout1"
    InputDevice "Keyboard1" "CoreKeyboard"
    InputDevice "Mouse1" "CorePointer"
    Screen 0 "screen0"
    Screen 1 "screen1" rightof "screen0"
EndSection
 
Old 07-21-2006, 06:15 PM   #2
willythec
LQ Newbie
 
Registered: Jul 2006
Posts: 5

Original Poster
Rep: Reputation: 0
bump? surely someone has done this and perhaps it is one of the simpler configurations people are asking help for!
 
Old 07-22-2006, 12:04 AM   #3
gloomy
Member
 
Registered: Jan 2006
Location: Finland
Distribution: Mainly Gentoo
Posts: 119

Rep: Reputation: 15
Your xorg.conf looks pretty fine.

However, it is missing the section "server flags", which define whether or not the xinerama is enabled (note also that the comment rightof is in reality RightOf; I would also use the ī"UseEDID" "false"ī option under the device section and define manually the DPI in the same section). It might look for instance like this:

Code:
Section "ServerFlags"
        Option          "Clone"         "off"
        Option          "Xinerama"      "on"
EndSection
You might also want to examine the TwinView option provided by the (binary) nVidia driver, as it might be more appropriate (~ efficient) for a dual head setup.
 
Old 07-22-2006, 12:49 AM   #4
Geminias
Member
 
Registered: Sep 2005
Posts: 201

Rep: Reputation: 30
if both of your monitors are analogue go with twinview. I suggest you delete everything you have just done and revert to the original xorg.conf and add these lines under the section "device"

Code:
	Option	    "NoLogo" "false"
	Option	    "TwinView" "true"
	Option	    "MetaModes" "800x600,1280x1024"
	Option	    "SecondMonitorHorizSync" "30.0 - 70.0"
	Option	    "SecondMonitorVertRefresh" "50.0 - 160.0"
	Option	    "TwinViewOrientation" "LeftOf"
Change the resolutions and orientation if they aren't set up correctly for your needs. For more information see here..
 
Old 07-22-2006, 01:13 AM   #5
willythec
LQ Newbie
 
Registered: Jul 2006
Posts: 5

Original Poster
Rep: Reputation: 0
does this look like iīve got it right? if so then thereīs something wrong because it doesnīt work..

Code:
# File generated by XFdrake.

# **********************************************************************
# Refer to the XF86Config man page for details about the format of
# this file.
# **********************************************************************

Section "Files"
    # Multiple FontPath entries are allowed (they are concatenated together)
    # By default, Mandrake 6.0 and later now use a font server independent of
    # the X server to render fonts.
    FontPath "unix/:-1"
EndSection

Section "ServerFlags"
    #DontZap # disable <Crtl><Alt><BS> (server abort)
    AllowMouseOpenFail # allows the server to start up even if the mouse does not work
    #DontZoom # disable <Crtl><Alt><KP_+>/<KP_-> (resolution switching)
EndSection

Section "Module"
    Load "dbe" # Double-Buffering Extension
    Load "v4l" # Video for Linux
    Load "extmod"
    Load "type1"
    Load "freetype"
    Load "/usr/X11R6/lib/modules/extensions/nvidia/libglx.so"
EndSection

Section "InputDevice"
    Identifier "Keyboard1"
    Driver "keyboard"
    Option "XkbModel" "pc105"
    Option "XkbLayout" "us(alt-intl)"
    Option "XkbOptions" "compose:rwin"
EndSection

Section "InputDevice"
    Identifier "Mouse1"
    Driver "mouse"
    Option "Protocol" "ExplorerPS/2"
    Option "Device" "/dev/mouse"
    Option "ZAxisMapping" "6 7"
EndSection

Section "Monitor"
    Identifier "monitor1"
    VendorName "Generic"
    ModelName "1024x768 @ 70 Hz"
    HorizSync 31.5-57.0
    VertRefresh 50-70
EndSection

Section "Device"
    Identifier "device1"
    BoardName "NVIDIA GeForce 6800 (generic)"
    Driver "nvidia"
    Option "IgnoreEDID" "1"
    Option "NoLogo" "false"
    Option "TwinView" "true"
    Option "MetaModes" "1024x768,1024x768"
    Option "SecondMonitorHorizSync" "30.0 - 70.0"
    Option "SecondMonitorVertRefresh" "50.0 - 160.0"
    Option "TwinViewOrientation" "RightOf"
    Option "ConnectedMonitor" "CRT, CRT"
EndSection

Section "Screen"
    Identifier "screen1"
    Device "device1"
    Monitor "monitor1"
    DefaultColorDepth 24
    
    Subsection "Display"
        Depth 8
        Virtual 1024 768
    EndSubsection
    
    Subsection "Display"
        Depth 15
        Virtual 1024 768
    EndSubsection
    
    Subsection "Display"
        Depth 16
        Virtual 1024 768
    EndSubsection
    
    Subsection "Display"
        Depth 24
        Virtual 1024 768
    EndSubsection
EndSection

Section "ServerLayout"
    Identifier "layout1"
    InputDevice "Keyboard1" "CoreKeyboard"
    InputDevice "Mouse1" "CorePointer"
    Screen "screen1"
EndSection
 
Old 07-22-2006, 02:50 AM   #6
gloomy
Member
 
Registered: Jan 2006
Location: Finland
Distribution: Mainly Gentoo
Posts: 119

Rep: Reputation: 15
It is probably due to the ConnectedMonitor you pass for the nvidia driver. I recall from using tvinview years ago that it was not neccessary for a dual head
setup. And as I remember, it was ConnectedMonitor "CRT-0, CRT-1". And since 1.0-8756, you must use UseDisplayDevice instead of ConnectedMonitor. You might want to also pass the option Xinerama off with ServerFlags.

You should also load simply the module "glx" if you use nVidias binary drivers; no need to pass /usr/X11R6/lib/modules/extensions/nvidia/libglx.so. Use simply "Modes" instead of "Virtual". Use DefaultDepth instead of DefaultColorDepth (man xorg.conf does not even recognize such an option).
 
Old 07-22-2006, 03:02 AM   #7
Geminias
Member
 
Registered: Sep 2005
Posts: 201

Rep: Reputation: 30
Yes and when you have done all that it is possible you will see your monitors hang for a bit as linux loads and some squigly lines over one of your monitors - but fear not. If you leave it alone for a little longer than usual (about 25s) it should load up fine and everything should be in order.
 
Old 07-22-2006, 05:58 AM   #8
willythec
LQ Newbie
 
Registered: Jul 2006
Posts: 5

Original Poster
Rep: Reputation: 0
I donīt think I quite get it... my latest attempt follows:

Code:
# File generated by XFdrake.

# **********************************************************************
# Refer to the XF86Config man page for details about the format of
# this file.
# **********************************************************************

Section "Files"
    # Multiple FontPath entries are allowed (they are concatenated together)
    # By default, Mandrake 6.0 and later now use a font server independent of
    # the X server to render fonts.
    FontPath "unix/:-1"
EndSection

Section "ServerFlags"
    #DontZap # disable <Crtl><Alt><BS> (server abort)
    AllowMouseOpenFail # allows the server to start up even if the mouse does not work
    #DontZoom # disable <Crtl><Alt><KP_+>/<KP_-> (resolution switching)
    Option          "Xinerama"      "off"
EndSection

Section "Module"
    Load "dbe" # Double-Buffering Extension
    Load "v4l" # Video for Linux
    Load "extmod"
    Load "type1"
    Load "freetype"
    Load "glx"
EndSection

Section "InputDevice"
    Identifier "Keyboard1"
    Driver "keyboard"
    Option "XkbModel" "pc105"
    Option "XkbLayout" "us(alt-intl)"
    Option "XkbOptions" "compose:rwin"
EndSection

Section "InputDevice"
    Identifier "Mouse1"
    Driver "mouse"
    Option "Protocol" "ExplorerPS/2"
    Option "Device" "/dev/mouse"
    Option "ZAxisMapping" "6 7"
EndSection

Section "Monitor"
    Identifier "monitor1"
    VendorName "Generic"
    ModelName "1024x768 @ 70 Hz"
    HorizSync 31.5-57.0
    VertRefresh 50-70
EndSection

Section "Device"
    Identifier "device1"
    BoardName "NVIDIA GeForce 6800 (generic)"
    Driver "nvidia"
    Option "IgnoreEDID" "1"
    Option "NoLogo" "false"
    Option "TwinView" "true"
    Option "MetaModes" "1024x768,1024x768"
    Option "SecondMonitorHorizSync" "30.0 - 70.0"
    Option "SecondMonitorVertRefresh" "50.0 - 160.0"
    Option "TwinViewOrientation" "RightOf"
    Option "ConnectedMonitor" "CRT-0, CRT-1"
EndSection

Section "Screen"
    Identifier "screen1"
    Device "device1"
    Monitor "monitor1"
    DefaultDepth 24
    
    Subsection "Display"
        Depth 8
        Modes 1024 768
    EndSubsection
    
    Subsection "Display"
        Depth 15
        Modes 1024 768
    EndSubsection
    
    Subsection "Display"
        Depth 16
        Modes 1024 768
    EndSubsection
    
    Subsection "Display"
        Depth 24
        Modes 1024 768
    EndSubsection
EndSection

Section "ServerLayout"
    Identifier "layout1"
    InputDevice "Keyboard1" "CoreKeyboard"
    InputDevice "Mouse1" "CorePointer"
    Screen "screen1"
EndSection
 
Old 07-22-2006, 07:57 AM   #9
Geminias
Member
 
Registered: Sep 2005
Posts: 201

Rep: Reputation: 30
1. Why are you using ConnectedMonitor option at all? It is only to be used if your monitors are very old and don't have DDC.
2. "Explicitly specifying Xinerama in the X config file or on the X server commandline will prohibit NVIDIA's Xinerama extension from installing." (taken from the link i gave you) You should take out xinerama option altogether since the default is off.
 
Old 07-22-2006, 08:05 AM   #10
Geminias
Member
 
Registered: Sep 2005
Posts: 201

Rep: Reputation: 30
Also put ServerLayout at the top, take out Serverflags altogether (meaning highlight the whole section and delete it." Then for screen put the line exactly like this:

Code:
Screen    0  "Screen1" 0 0
and try: Identifier "Default Layout" in ServerLayout section.

Remember to keep a backup of a working config at all times so if it fails to launch x you can revert to the back up and try a different config.
 
Old 07-22-2006, 08:10 AM   #11
Geminias
Member
 
Registered: Sep 2005
Posts: 201

Rep: Reputation: 30
Also you didn't specify a mode for the direct rendering infrastructure. Add this section at the end.

Section "DRI"
Mode 0666
EndSection
 
Old 07-22-2006, 06:47 PM   #12
willythec
LQ Newbie
 
Registered: Jul 2006
Posts: 5

Original Poster
Rep: Reputation: 0
Thanks so much for the help...
Only a couple of problems with it.
1. Windows maximize wrongly i.e. too far and the close button dissappears.
2. itīs a bit soft? some of the definition seems to have dissappeared, though that might just be an optical illusion.
Thanks again Geminias!
 
Old 07-23-2006, 01:56 AM   #13
Geminias
Member
 
Registered: Sep 2005
Posts: 201

Rep: Reputation: 30
your welcome. About the first part: I would say it has to do with which X server you run because I use FC5 with Gnome and I don't have that problem. (but it could also be the screen size you specified in the xorg.conf file. Read up on the specific size for your monitors and make sure its set correctly) If that doesnt work than go to nvidia's forum and ask them - they would be the most help i'd imagine.

2. If you think it lost some of its definition than take out all of the modes that specify lower than 24 depth. I only use 24 depth cause i have no reason to use a lower depth. (Also be sure to check what setting your display is on ie. millions of colors, thousands of colors, hundreds of colors.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Dual Monitors and Mandriva sleepykit Mandriva 1 04-01-2006 04:04 PM
GeForce 6600GT + Suse 10 + Dual CRT (newbie) aqwabawks SUSE / openSUSE 2 11-04-2005 11:18 AM
Setting up Dual Monitors on GeForce 6600GT dual DVI card. monkiidansu Linux - Hardware 1 09-29-2005 02:21 PM
Dual monitors in Mandriva z_t Linux - Newbie 1 09-09-2005 02:56 PM
Run two different WMs (or gnome-sessions) on dual monitors guardian653 Linux - Software 1 10-31-2004 01:02 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 04:34 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration