LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 11-08-2005, 06:58 AM   #1
pingu
Senior Member
 
Registered: Jul 2004
Location: Skuttunge SWEDEN
Distribution: Debian preferably
Posts: 1,350

Rep: Reputation: 127Reputation: 127
Dual monitor: nthing shows on second, system dies.


Older PIII-computer, 256 RAM, running Libranet with kernel 2.4.21
One AGP ATI-card, using "ati" driver - with only this one everything is ok. (Has been running daily since august.)
I added a PCI-card, S3 Trio 64V2/DX since I want to connect an LCD-projector (Philips LC4433).
Trying with default "RightOF":
First monitor is ok, on second (projector) there is no real background, but the mouse cursor is visible and moving.
Trying to drag a window to second display, instead it "cycles" - leaving first monitor out to right and comes back to the left of same monitor!
Trying with 'Second Screen "relative" 0 0 '
I get nothing at all on second monitor. And when I try to drag a window to second monitor system dies. No network, not even [alt]+[SysRq]-keys work.
There is nothing in the logs - I had 2 ssh-connections with "tail -f" checking /var/log/messages and XFree86.0.log - there is no error-message displayed at all. It dies immediately, without a chance to write to the logs.

Since I can't find any error-messages I don't know what to troubleshoot?
(At the end I want the two monitors to be cloned, that should be possible with "Relative" ?)

Here's the /etc/X11/XF86Config-4:
Code:
Section "ServerFlags"
        Option  "DontVTSwitch" "1"
        Option "Blank time" "600"
EndSection

Section "Module"
        Load    "ddc"
        Load    "dbe"
        Load    "extmod"
        Load    "glx"
        Load    "record"
        Load    "bitmap"
        Load    "freetype"
        Load    "type1"
        Load    "vbe"
        Load    "int10"
EndSection

Section "InputDevice"
        Identifier      "Default Keyboard"
        Driver          "keyboard"
        Option          "CoreKeyboard"
        Option          "XkbRules"      "xfree86"
        Option          "XkbModel"      "pc104"
        Option          "XkbLayout"     "se"
EndSection

Section "InputDevice"
        Identifier      "Default Mouse"
        Driver          "mouse"
        Option          "CorePointer"
        Option          "Device"                "/dev/psaux"
        Option          "Protocol"              "IMPS/2"
        Option          "Emulate3Buttons"       "true"
        Option          "ZAxisMapping"          "4 5"
EndSection

Section "Device"
        Identifier      "ATI 3D Rage Pro AGP 1X/2X"
        Driver          "ati"
        BusID           "PCI:1:0:0"
        #VideoRam       8192
EndSection

Section "Device"
        Identifier      "S3"
        Driver          "s3"
        BusID           "PCI:0:10:0"
EndSection

Section "Monitor"
        Identifier      "Kanon"
        HorizSync       30-60
        VertRefresh     50-75
EndSection

Section "Monitor"
        VendorName      "010b"
        ModelName       "SAM"
        Identifier      "Platt"
        HorizSync       30-81
        VertRefresh     56-75
EndSection

Section "Screen"
        Identifier      "Extra"
        Device          "S3"
        Monitor         "Kanon"
        DefaultDepth    16
        SubSection "Display"
                Depth           16
                Modes   "1024x768" "800x600"
        EndSubSection
EndSection

Section "Screen"
        Identifier      "Default Screen"
        Device          "ATI 3D Rage Pro AGP 1X/2X"
        Monitor         "Platt"
        DefaultDepth    16
        SubSection "Display"
                Depth           16
                Modes    "1152x864" "1024x768" "800x600" "640x480"
        EndSubSection
EndSection

Section "ServerLayout"
        Identifier      "Default Layout"
        Screen 0        "Default Screen" 0 0
        Screen 1        "Extra" Relative "Default Screen" 1024 40
        InputDevice     "Default Keyboard"
        InputDevice     "Default Mouse"
EndSection

Section "DRI"
        Mode    0666
EndSection
linne@li-bib-sok3:~$
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Dual monitor system goes black on reboot keeler Linux - Hardware 1 05-13-2005 06:26 PM
MDK 10.1 - Monitor only shows 800x600 DoddyUK Mandriva 2 01-19-2005 04:52 PM
Monitor dies after boot up! mcbath Fedora - Installation 9 07-01-2004 03:34 PM
Unable to start XFree86 server on new dual monitor system gothgeek84 Linux - Hardware 1 02-21-2004 07:35 PM
monitor shows 'out of range' marcusslatoni Linux - Newbie 1 09-27-2003 10:07 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 03:19 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration