LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (https://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   Dual head X configuration of Nvidia 5700 Ultra (https://www.linuxquestions.org/questions/linux-hardware-18/dual-head-x-configuration-of-nvidia-5700-ultra-204999/)

scaley187 07-14-2004 03:06 PM

Dual head X configuration of Nvidia 5700 Ultra
 
I'm having a bit of a problem. I have a dual headed Nvidia GeForce FX 5700 Ultra card with dual DVI outputs that are connected to 2 exactly the same Dell 1800FP flat screen monitors.
I am running this off of a dual AMD Opteron 242 system in the 64 bit version of Suse 9.1 and am having a hard time getting the 2nd monitor to work as a second desAktop as opposed to cloning.

I have installed the Nvidia drivers for AMD64 but when I switch the XF86Config file toA nvidia as the driver things get weird. More importantly no matter what I do the 2nd flat panel is either blank or still clones so I'm at a loss and am hoping someone can help. I have attached the XF86Config file as it is now if anyone has suggestions it is appreciated.

XF86Config File:

# /.../
# SaX generated XFree86 config file
# Created on: 2004-07-13T18:21:40-0500.
#
# Version: 4.8
# Contact: Marcus Schaefer <sax@suse.de>, 2002
#
# Automatically generated by [ISaX] (4.8)
# PLEASE DO NOT EDIT THIS FILE!
#

Section "Files"
FontPath "/usr/X11R6/lib/X11/fonts/misc:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/local"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/Type1"
FontPath "/usr/X11R6/lib/X11/fonts/URW"
FontPath "/usr/X11R6/lib/X11/fonts/Speedo"
FontPath "/usr/X11R6/lib/X11/fonts/PEX"
FontPath "/usr/X11R6/lib/X11/fonts/cyrillic"
FontPath "/usr/X11R6/lib/X11/fonts/latin2/misc:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/latin2/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/latin2/100dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/latin2/Type1"
FontPath "/usr/X11R6/lib/X11/fonts/latin7/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/baekmuk:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/japanese:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/kwintv"
FontPath "/usr/X11R6/lib/X11/fonts/truetype"
FontPath "/usr/X11R6/lib/X11/fonts/uni:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/CID"
FontPath "/usr/X11R6/lib/X11/fonts/ucs/misc:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/ucs/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/ucs/100dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/hellas/misc:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/hellas/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/hellas/100dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/hellas/Type1"
FontPath "/usr/X11R6/lib/X11/fonts/misc/sgi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/xtest"
FontPath "/opt/kde3/share/fonts"
EndSection

Section "ServerFlags"
Option "AllowMouseOpenFail"
Option "RandR" "on"
EndSection

Section "Module"
Load "dbe"
Load "type1"
Load "speedo"
Load "freetype"
Load "extmod"
Load "glx"
Load "v4l"
EndSection

Section "InputDevice"
Driver "Keyboard"
Identifier "Keyboard[0]"
Option "Protocol" "Standard"
Option "XkbLayout" "us"
Option "XkbModel" "pc104"
Option "XkbRules" "xfree86"
EndSection


Section "InputDevice"
Driver "mouse"
Identifier "Mouse[1]"
Option "Device" "/dev/input/mice"
Option "Emulate3Buttons" "on"
Option "Name" "Autodetection"
Option "Protocol" "explorerps/2"
Option "Vendor" "Sysp"
Option "ZAxisMapping" "4 5"
EndSection


Section "Monitor"
Option "CalcAlgorithm" "CheckDesktopGeometry"
DisplaySize 320 240
HorizSync 31-82
Identifier "Monitor[0]"
ModelName "1280X1024@75HZ"
VendorName "--> LCD"
VertRefresh 58-75
UseModes "Modes[0]"
EndSection

Section "Monitor"
Option "CalcAlgorithm" "CheckDesktopGeometry"
HorizSync 31-82
Identifier "Monitor[1]"
ModelName "1280X1024@75HZ"
VendorName "--> LCD"
VertRefresh 58-75
UseModes "Modes[1]"
EndSection


Section "Modes"
Identifier "Modes[0]"
Modeline "1280x1024" 114.54 1280 1360 1496 1712 1024 1025 1028 1062
Modeline "1280x1024" 134.72 1280 1368 1504 1728 1024 1025 1028 1068
Modeline "1024x768" 67.48 1024 1080 1184 1344 768 769 772 797
Modeline "1024x768" 79.52 1024 1080 1192 1360 768 769 772 801
Modeline "800x600" 40.19 800 832 912 1024 600 601 604 623
Modeline "800x600" 47.53 800 840 920 1040 600 601 604 626
Modeline "640x480" 25.10 640 656 720 800 480 481 484 498
Modeline "640x480" 29.84 640 664 728 816 480 481 484 501
Modeline "1280x1024" 135.0 1280 1296 1440 1688 1024 1025 1028 1066 +hsync +vsync
EndSection

Section "Modes"
Identifier "Modes[1]"
Modeline "1280x1024" 114.54 1280 1360 1496 1712 1024 1025 1028 1062
Modeline "1280x1024" 134.72 1280 1368 1504 1728 1024 1025 1028 1068
Modeline "1024x768" 67.48 1024 1080 1184 1344 768 769 772 797
Modeline "1024x768" 79.52 1024 1080 1192 1360 768 769 772 801
Modeline "800x600" 40.19 800 832 912 1024 600 601 604 623
Modeline "800x600" 47.53 800 840 920 1040 600 601 604 626
Modeline "640x480" 25.10 640 656 720 800 480 481 484 498
Modeline "640x480" 29.84 640 664 728 816 480 481 484 501
Modeline "1280x1024" 135.0 1280 1296 1440 1688 1024 1025 1028 1066 +hsync +vsync
EndSection


Section "Screen"
DefaultDepth 16
SubSection "Display"
Depth 15
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1280x1024"
EndSubSection
SubSection "Display"
Depth 24
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 32
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
Device "Device[0]"
Identifier "Screen[0]"
Monitor "Monitor[0]"
EndSection

Section "Screen"
DefaultDepth 16
SubSection "Display"
Depth 15
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1280x1024"
EndSubSection
SubSection "Display"
Depth 24
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 32
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
Device "Device[1]"
Identifier "Screen[1]"
Monitor "Monitor[1]"
EndSection


Section "Device"
BoardName "0x0341"
BusID "2:0:0"
Driver "nv"
Identifier "Device[0]"
Screen 0
Option "Rotate" "off"
VendorName "NVidia"
EndSection

Section "Device"
BoardName "0x0341"
BusID "2:0:0"
Driver "nv"
Identifier "Device[1]"
Screen 1
Option "Rotate" "off"
VendorName "NVidia"
EndSection


Section "ServerLayout"
Identifier "TwinView"
Screen "Screen[0]"
Screen "Screen[0]" LeftOf "Screen[1]"
EndSection

Section "DRI"
Group "video"
Mode 0660
EndSection

theonebeyond 11-11-2004 07:45 AM

Maybe you want to use xinerama? :-)

Electro 11-11-2004 07:45 PM

You are still using XFree86 modules. To use nVidia modules, you have to change nv to nvidia. Read the nVidia documentation it tells how to setup TwinView.

Remove or comment DRI section. You do not need it when using nVidia modules.


All times are GMT -5. The time now is 05:44 PM.