LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
LinkBack Search this Thread
Old 11-15-2005, 03:16 AM   #1
tts
LQ Newbie
 
Registered: Nov 2005
Posts: 5

Rep: Reputation: 0
dual boot DELL and every time BIOS switching


Hi all !

I have a DELL Dimension 8400 Desktop-PC, double boot (WinXP and Debian Linux).
I don't have any problems. There is only one inconvenience. If I'm in WinXP and want to boot Linux next time I have to enter the BIOS to change the drive settings. I also have to do the settings back if I want to boot WinXP after using Linux.
- my question is: is there a way to do this changes automatically?
- is it only with DELL computers or is it common for any PC?

any help appreciated.

Tts
 
Old 11-15-2005, 04:29 AM   #2
saikee
Senior Member
 
Registered: Sep 2005
Location: Newcastle upon Tyne UK
Distribution: Any free distro.
Posts: 3,398
Blog Entries: 1

Rep: Reputation: 112Reputation: 112
yes

You can amend Linux's boot loader to boot Windows.

Debian use Grub and the text file controlling booting is /boot/grub/menu.lst

Just add these 3 lines at the end will do the trick

title MY Windows now booted by Debian
root (hd1,0)
chainloader +1

The above should work if there is no Windows partition in the Debian disk. If you have difficulty then re-map the two drives also (cheating Windows in believing it is beeing booted as the first bootable disk) by adding two extra lines to the above as

title MY Windows now booted by Debian
root (hd1,0)
map (hd1) (hd0)
map (hd0) (hd1)
chainloader +1

This is the standard way of dual-booting with Windows and Linux but keeping Windows MBR untouched like a virgin. It is only possible for rich guys who can afford two hard disks.

Last edited by saikee; 11-15-2005 at 04:32 AM.
 
Old 11-15-2005, 08:58 PM   #3
tts
LQ Newbie
 
Registered: Nov 2005
Posts: 5

Original Poster
Rep: Reputation: 0
Thank you for your reply


I actually do use the GNU GRUB already. I didn't know about the /boot/grub/menu.lst
At the end of this file I already have the following text:

# This entry automatically added by the Debian installer for a non-linux OS
# on /dev/hda2
title Microsoft Windows XP Professional
root (hd0,1)
savedefault
makeactive
chainloader +1

This allows me to boot WinXP from GNU GRUB, but I still need to make the following changes in
BIOS:
'-Drives
'- SATA Operation

here if I want to boot WinXp I have to choose the option:
- RAID Autodetect/AHCI

and if I want to boot Linux :
- SATA/PATA combination mode

If I try to boot WinXP with the "SATA/PATA combination mode" I get error messages after booting and the other way around Linux will get angry if I feed it with the "RAID Autodetect/AHCI" mode.
my Linux and my WinXP are on 2 separated hard disks.
Is there still a way to make the settings in the BIOS being changed automatically?

-------------
by the way
after adding the 3 or 5 lines as you recommended I get another menu entry in the GNU GRUB loader but when I choose it I get:
root(hd1,0)
Filesystem type is ext2fs, partition type 0x83
chainloader +1
Error 13: Invalid or unsupported executable format
and nothing happens, I have to get back to the GNU GRUB again.
----------

Tts
 
Old 11-16-2005, 02:27 AM   #4
saikee
Senior Member
 
Registered: Sep 2005
Location: Newcastle upon Tyne UK
Distribution: Any free distro.
Posts: 3,398
Blog Entries: 1

Rep: Reputation: 112Reputation: 112
Two points here

Point one - The error is obviously telling you are barking on the wrong tree! The XP partition isn't in (hd1,0) or the 1st partition of the 2nd disk (Grub counts from 0). Its partition type 0x83 is LInux, file type ext2. The partition you need to hunt down to boot is type 0x7 with file type NTFS.

Can you locate it from the GNU/Linux? Just post the content of the screen after issuing

fdisk -l

Point 2 -You GNU Linux has arranged to boot your XP with partition (hd0,1). This means the 2nd partition of the 1st disk. Did you multi-boot XP via another partition, like a DOS of Win9x? It is possible that GNU/Linux has picked up the wrong partition (any FAT32, NTFS, FAT can be a system to GNU/Linu) but you must have agreed to it and supplied the wording

Microsoft Windows XP Professional

during installation. Any way You told us that you swap the disk so that you installed Linux in the 1st when XP was the second disk. Why has 2nd partition of the 1st disk been singled out as the XP partition?

-----------

You can put GNU/LINUX and XP any where in the box but you must preserve the disk order (or know it) otherwise Grub will boot to the wrong partition.ped
 
Old 11-17-2005, 10:40 PM   #5
tts
LQ Newbie
 
Registered: Nov 2005
Posts: 5

Original Poster
Rep: Reputation: 0
hello
thank you for your help till now

Point one -
Here is the output after issuing the command fdisk -l .
I did it for both hard disks. hda and hdb:

----------------------------------------------
debiana:/# fdisk -l /dev/hda

Disk /dev/hda: 250.0 GB, 250000000000 bytes
255 heads, 63 sectors/track, 30394 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/hda1 1 9 72261 de Dell Utility
/dev/hda2 * 10 30392 244051447+ 7 HPFS/NTFS
----------------------------------------------
debiana:/# fdisk -l /dev/hdb

Disk /dev/hdb: 251.0 GB, 251000193024 bytes
255 heads, 63 sectors/track, 30515 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/hdb1 1 12158 97659103+ 83 Linux
/dev/hdb2 12159 12219 489982+ 83 Linux
/dev/hdb3 12220 12341 979965 82 Linux swap / Solaris
----------------------------------------------

it looks like WinXP is on (hd0,1), With the automatically written settings in GNU GRUB I have been able to boot WinXP correctly.
on (hd0,0) there seems to be some DELL utility I don't know the reason for.
Linux seems to be on (hd1,1). Is that right?


The history of this PC is:
- I bought this DELL PC with WinXP already installed on it.
- then I bought a new hard disk
- with the help of a friend I made the partitions on the second disk
- and installed Debian Linux on it
- since that time I have also GNU GRUB. It was added automatically.
- and I have this inconvenience to change the BIOS SATA setting every time I want to boot the other OS.

sorry to repeat but I want to make sure that we are talking about the same thing.
- I have no problem booting WinXP from GNU GRUB. (if the BIOS setting are: RAID Autodetect/AHCI)
- I also have no problem booting Linux rom GNU GRUB. (if the BIOS settings are: SATA/PATA combination mode)
The only problem is the necessary changing in BIOS.

If I try to boot Linux with "RAID Autodetect/AHCI" I get :
"Kernel panic: Attempted to kill init!"

supposing
WinXP being on (hd0,1) and
Linux being on (hd1,1)

I added :
title MY Windows now booted by Debian
root (hd0,1)
chainloader +1

then I get the same kernel panic if the BIOS is not set appropriately

if I add
map (hd0) (hd1)
map (hd1) (hd0)
as well I get nothing. The PC is rebooting from zero.

can the BIOS settings be changed in the GNU GRUB?
or can I go around them?

tts
 
Old 11-18-2005, 04:06 AM   #6
saikee
Senior Member
 
Registered: Sep 2005
Location: Newcastle upon Tyne UK
Distribution: Any free distro.
Posts: 3,398
Blog Entries: 1

Rep: Reputation: 112Reputation: 112
I think you got yourself into a hole. Sorry I misunderstood your problem completely.

You are in fact able to boot to both systems satisfactorily but the booting has been configured differently in BIOS for the two systems.

You problem could have been created by the Linux or yourself. You motherboard obviously supports RAID which is putting two identical disks to work as one. Raid 0 split the files into two halves shared by both disks and so the access time is theoretically cut down by half.

You current problem is using the RAID setting in the BIOS but not actually having a RAID, as you put the two systems into separate disks.

Long term damage to your filing system can be resulted. You must make a decision as if you want to go with RAID, which must be setup properly and will have only one disk in the end (with the space =sum of the two disks). Bearing in mind Linux may not support the RAID on your board and XP may have to be re-installed to have the driver up front in order to work then you are better to forget the RAID completely, unless you are prepared to reinstall both systems.

Your best course of action is to forget RAID and stick with a BIOS setting to do without it. Try to see if there is a setting in BIOS to disable RAID. Re-install one of the system if you have to. Auto detect is an acceptable setting because RAID won't work unless it is properly setup.

Your hda and hdb disk designations tell me that you have no Sata disk as it is known as sda or sdb in Linux (or hde and hdg). Therefore Sata/Pata combination mode should never have been used.

------------------

GNU/Linux does not interfere with your BIOS setting. It works on the information hand down by it.
 
Old 11-19-2005, 06:35 AM   #7
tts
LQ Newbie
 
Registered: Nov 2005
Posts: 5

Original Poster
Rep: Reputation: 0
thanks once again

I have 4 possibilities in the BIOS
nr1 - RAID Autodetect/AHCI (if RAID not detected -> AHCI)
nr2 - RAID Autodetect/ATA (if RAID not detected -> ATA)
nr3 - RAID on
nr4 - SATA/PATA combination mode

I will not consider nr3.

I tryed:
Linux boots only with nr4.
Trying to boot Linux with nr1 or nr2 results in kernel panic.

WinXP boots only with nr1.
Trying to boot WinXP with nr2 or nr4 results in a blue screen with dangerously looking warnings.

nr1 is the factory default so as I got the computer with WinXP installed on it was set to nr1.

following your advise:
-I forget RAID. (I already forgot it, (what was RAID again?, I forgot ;-)))
-there is no setting in the BIOS to disable RAID (i will look for it again) but autodetect is acceptable (nr1 and nr2).
-nr4 is not good
-I stick to a BIOS setting. Since I don't want to reinstall WinXP I will stick to nr1.
-then Linux is not booting
-so what do I do? I reinstall it?

-What was my mistake installing Linux that now I have to change BIOS settings all the time?
-What do I have to do in order to boot without these setting changing? You said I have to reinstall one of the systems if its necessary. How do I know if its necessary? So for example if I reinstall Linux how do I make sure I don't run into the same hole?
-there is no other way but to reinstall?

btw
I just found that somebody else had a similar problem.
It seems not really solved.
Please have a look:
https://www.redhat.com/archives/fedo.../msg01881.html

tts
 
Old 11-19-2005, 04:04 PM   #8
saikee
Senior Member
 
Registered: Sep 2005
Location: Newcastle upon Tyne UK
Distribution: Any free distro.
Posts: 3,398
Blog Entries: 1

Rep: Reputation: 112Reputation: 112
You obviously will stick to No. 1 setting and never again change the BIOS.
 
Old 11-22-2005, 12:56 AM   #9
tts
LQ Newbie
 
Registered: Nov 2005
Posts: 5

Original Poster
Rep: Reputation: 0
Smile

Hello

I was talking once again with the friend who helped me to install Linux on my PC.
According to him and to my memory it was not possible to install Lunux (Debian) with BIOS setting nr1 (RAID Autodetect/AHCI )
We had to change to nr4 to be able to progress with the instalation.

So I would like to know if there is somebody using Debian with settings nr1.
Does Debian support it?
or is there anybody with a DELL desktop pc and Debian who was able to stick to nr1 BIOS settings?

I want to be sure before I go through the reinstalation hell once again.

anyhow thanks. Even I dont feel that my problem is solved many things got clear to me after these postings.
 
Old 11-22-2005, 05:25 AM   #10
saikee
Senior Member
 
Registered: Sep 2005
Location: Newcastle upon Tyne UK
Distribution: Any free distro.
Posts: 3,398
Blog Entries: 1

Rep: Reputation: 112Reputation: 112
Debian is not known to be user or hardware friendly so why do you get a variant of it and try it out or better still go for one from Slackware, Suse or Mandriva if you prefer the big guns.

I think both Suse and Mandriva are pretty up to date with the 2.6 kernels which are known to cope well with the hardware. Debian and Slackware are stable distros still sticking with the 2.4 kernels.

The point is you should adhere to one BIOS setting and boot disk order once you start to multi-boot.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Howto install linux with BIOS RAID 0, dual boot with windows? jbmigel Linux - Newbie 5 10-28-2005 03:52 AM
Partitioning Dell HD for dual-boot SadPenguin Linux - Software 3 06-26-2005 02:25 PM
Dual Boot = No Boot (hangs at bios splash screen) nedwardss Debian 4 12-03-2004 04:09 AM
Dual boot with BIOS twist Question Dobie Linux - Newbie 6 06-12-2004 07:13 AM
Dual boot on dell notebook prema Linux - Software 7 10-31-2003 06:24 PM


All times are GMT -5. The time now is 06:46 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration